GLib 2.0 and libasound2 prevent LM 19.3 Cinnamon (64-bit) from upgrading to LM 20

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
MichalProchazka
Level 1
Level 1
Posts: 3
Joined: Thu Jul 09, 2020 2:00 pm

GLib 2.0 and libasound2 prevent LM 19.3 Cinnamon (64-bit) from upgrading to LM 20

Post by MichalProchazka »

Hello, I've tried to upgrade Linux Mint 19.3 Cinnamon 64-bit to Linux Mint 20 with the new upgrade guide, however, upon running 'mintupgrade check' and changing the repos, it seems like gir1.2-glib-2.0, libasound2 and libglib2.0-0 cause issues and lead to APT crashing. When I tried to 'apt purge' them, I realised these packages are dependencies for possibly every application installed on the system. Is there anything I can do, or am I just better off wiping my current installation and doing a fresh install? (not desirable, but I could live with it)

Here's the output from mintupgrade after changing the repos:

Code: Select all

    APT will now calculate the package changes necessary to upgrade to Linux Mint 20 'Ulyana'.

    If conflicts are detected and APT is unable to perform the upgrade, take note of the packages
    causing the issue, remove them, and restart the upgrade.

    Pay close attention to what appears on the screen, particularly the packages being REMOVED. Take
    note of any you may wish to reinstall after the upgrade.

    Press Enter to continue

  + Simulating an upgrade...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gir1.2-glib-2.0 : Depends: libgirepository-1.0-1 (>= 1.59.4) but 1.56.1-1 is to be installed
 libasound2:i386 : Breaks: alsa-utils (< 1.2.1)
                   Breaks: alsa-utils:i386 (< 1.2.1)
 libasound2 : Breaks: alsa-utils (< 1.2.1)
              Breaks: alsa-utils:i386 (< 1.2.1)
 libglib2.0-0 : Breaks: libgirepository-1.0-1 (< 1.62.0-4~) but 1.56.1-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Traceback (most recent call last):
  File "/usr/bin/mintupgrade", line 626, in <module>
    upgrader.check()
  File "/usr/bin/mintupgrade", line 398, in check
    cache.upgrade(True)
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 385, in upgrade
    self._depcache.upgrade(dist_upgrade)
apt_pkg.Error: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 154, in apport_excepthook
    os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
FileNotFoundError: [Errno 2] No such file or directory: '/var/crash/_usr_bin_mintupgrade.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/mintupgrade", line 626, in <module>
    upgrader.check()
  File "/usr/bin/mintupgrade", line 398, in check
    cache.upgrade(True)
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 385, in upgrade
    self._depcache.upgrade(dist_upgrade)
apt_pkg.Error: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Also, here's the 'inxi -Fxxxrz' output, if that could help in any way:

Code: Select all

System:
  Host: Lenovo-B50-50 Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc 
  v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin 4.4.2 dm: LightDM 1.26.0 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 80S2 v: Lenovo B50-50 
  serial: <filter> Chassis: type: 10 v: Lenovo B50-50 serial: <filter> 
  Mobo: LENOVO model: Nano BDW v: SDK0J40700 WIN serial: <filter> 
  UEFI: LENOVO v: 0QCN25WW date: 01/13/2016 
Battery:
  ID-1: BAT0 charge: 18.5 Wh condition: 18.5/30.1 Wh (61%) volts: 16.3/14.4 
  model: ANYO 15S4A01 type: Li-ion serial: <filter> status: Full 
CPU:
  Topology: Dual Core model: Intel Core i3-5005U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15963 
  Speed: 798 MHz min/max: 500/1900 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 
  Device-2: NVIDIA GK208BM [GeForce 920M] vendor: Lenovo driver: N/A 
  bus ID: 04:00.0 chip ID: 10de:1299 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 19.2.8 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Device-3: NVIDIA GK208 HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 04:00.1 chip ID: 10de:0e0f 
  Sound Server: ALSA v: k5.4.0-40-generic 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo 
  driver: r8169 v: kernel port: 5000 bus ID: 02:00.0 chip ID: 10ec:8136 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lenovo 
  driver: rtl8723be v: kernel port: 4000 bus ID: 03:00.0 chip ID: 10ec:b723 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.09 TiB used: 130.93 GiB (11.7%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37960G size: 894.25 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: K1B3 temp: 33 C scheme: GPT 
  ID-2: /dev/sdb vendor: Kingston model: SA400S37240G size: 223.57 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: 5A temp: 33 C scheme: GPT 
Partition:
  ID-1: / size: 61.27 GiB used: 29.97 GiB (48.9%) fs: ext4 dev: /dev/sdb2 
  ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3 
Sensors:
  System Temperatures: cpu: 60.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  No active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
  Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list 
  1: deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
  Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/home:ungoogled_chromium.list 
  1: deb http://download.opensuse.org/repositories/home:/ungoogled_chromium/Ubuntu_Bionic/ /
  Active apt repos in: /etc/apt/sources.list.d/nilarimogard-webupd8-bionic.list 
  1: deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://ucho.ignum.cz/linuxmint tricia main upstream import backport
  2: deb http://ftp.cvut.cz/ubuntu bionic main restricted universe multiverse
  3: deb http://ftp.cvut.cz/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://ftp.cvut.cz/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
  1: deb [arch=amd64] https://repo.skype.com/deb stable main
  Active apt repos in: /etc/apt/sources.list.d/steam.list 
  1: deb [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam
  2: deb-src [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam
  Active apt repos in: /etc/apt/sources.list.d/webupd8team-indicator-kdeconnect-bionic.list 
  1: deb http://ppa.launchpad.net/webupd8team/indicator-kdeconnect/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/xapienz-curl34-bionic.list 
  1: deb http://ppa.launchpad.net/xapienz/curl34/ubuntu bionic main
Info:
  Processes: 249 Uptime: 53m Memory: 7.69 GiB used: 2.08 GiB (27.0%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 4.8/7/8 
  clang: 6.0.0-1ubuntu2 Shell: bash v: 4.4.20 running in: gnome-terminal 
  inxi: 3.0.32 
Thanks in advance!
MichalProchazka
Level 1
Level 1
Posts: 3
Joined: Thu Jul 09, 2020 2:00 pm

Re: GLib 2.0 and libasound2 prevent LM 19.3 Cinnamon (64-bit) from upgrading to LM 20

Post by MichalProchazka »

Well, screw it, I did a fresh install, just to be safe :D
Post Reply

Return to “Installation & Boot”