Can't upgrade from 19.3 to 20

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
carlitador
Level 2
Level 2
Posts: 70
Joined: Fri Oct 04, 2019 8:36 am

Can't upgrade from 19.3 to 20

Post by carlitador »

Hello everyone,

I started to consider upgrading to 20 but I am having some problems when doing

Code: Select all

mintupgrade download
Here is what i get:

Code: Select all

Les paquets suivants contiennent des dépendances non satisfaites :
 libgirepository-1.0-1 : Casse: python-gi (< 3.34.0-4~) mais 3.26.1-2ubuntu1 devra être installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
Sorry its all french but its about unmet dependencies. The package that seems to make problems is libgirepository-1.0-1 which is a vital package.
Any idea ?
Tried to find a solution on google but didnt see anything

Cheers
User avatar
LanceM
Level 10
Level 10
Posts: 3279
Joined: Sun Jul 08, 2018 11:50 pm

Re: Can't upgrade from 19.3 to 20

Post by LanceM »

So many failures on the forum trying to upgrade. My advice is do a clean install from scratch. That works.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php
dorsetUK
Level 4
Level 4
Posts: 493
Joined: Thu Sep 19, 2019 4:40 am

Re: Can't upgrade from 19.3 to 20

Post by dorsetUK »

Hi carlitador

Are you following this https://linuxmint-user-guide.readthedoc ... nt-20.html?

Cuz it does say
You also need to be experienced with APT. During the upgrade you’ll need to understand the output of APT commands. You’ll need to understand if a package needs to be removed, if it blocks the upgrade or if it conflicts with another package.
I don't.

A clean install is much more reliable.

Edit: Whoops, LanceM beat me to it.
User avatar
Joe2Shoe
Level 5
Level 5
Posts: 538
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Post by Joe2Shoe »

Ditto.
I upgraded 3 laptops from LM19.3 to LM20, so many problems, which much of them I resolved. But, I finally threw in the towel and did a "clean" install via USB flash drive.
Presto! Good to go. All problems solved.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire
asinoro
Level 6
Level 6
Posts: 1163
Joined: Mon Feb 12, 2018 11:43 am

Re: Can't upgrade from 19.3 to 20

Post by asinoro »

What it shows this command:

Code: Select all

sudo dpkg --configure -a
carlitador
Level 2
Level 2
Posts: 70
Joined: Fri Oct 04, 2019 8:36 am

Re: Can't upgrade from 19.3 to 20

Post by carlitador »

asinoro wrote:
Wed Aug 12, 2020 1:09 am
What it shows this command:

Code: Select all

sudo dpkg --configure -a
Hi,
It doesnt return anything...
Thanks
carlitador
Level 2
Level 2
Posts: 70
Joined: Fri Oct 04, 2019 8:36 am

Re: Can't upgrade from 19.3 to 20

Post by carlitador »

LanceM wrote:
Tue Aug 11, 2020 2:02 pm
So many failures on the forum trying to upgrade. My advice is do a clean install from scratch. That works.
This work but it doesnt help me much. Its too much time for me to reinstall all my setup and applications
I did the upgrade from 18 to 19 and I didnt have problems
User avatar
LanceM
Level 10
Level 10
Posts: 3279
Joined: Sun Jul 08, 2018 11:50 pm

Re: Can't upgrade from 19.3 to 20

Post by LanceM »

This work but it doesnt help me much. Its too much time for me to reinstall all my setup and applications
I did the upgrade from 18 to 19 and I didnt have problems
Top
Good luck.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php
Post Reply

Return to “Installation & Boot”