Page 1 of 1

[SOLVED] Disable acceleration? Advice requested

Posted: Fri Oct 16, 2020 1:08 pm
by rumplestiltskin
I have a 2011 iMac with an AMD video card that has gone partially south. What I mean by that is there is no longer any ability to run macOS. So I dropped in a hard drive running Mint 19.2 and it gets to the boot menu (grub?). If I select the usual boot option (or leave it for the 30 seconds), it attempts to boot but will fail with a black screen. However, if I use one of the recovery modes, it gets to an option screen where one of the choices is to "resume boot". I choose that and I get a message about (IIRC) video acceleration being disabled and some apps won't work well. But it does boot to the Desktop properly and everything I normally use seems to work fine. BTW, I do get a notification in the upper right about (IIRC) video acceleration being off but I just dismiss it.

I checked the Driver Manager and it tells me there are no proprietary drives in use. I don't know if that's because there aren't any proprietary drivers installed or if it's just that I booted into Mint using this recovery mode and whatever proprietary drivers there may be installed just haven't loaded.

So here's my question: I'd like to make this boot mode (without the video drivers, I guess) the standard process without having to manually go through the steps I listed above. I did see a "load video" line in the grub(?) options and replaced it with "nomodeset" but that didn't work (and the "load video" was back in the subsequent boot).

Again, this is only necessary because the AMD video card in this iMac has gone bad but is still working enough to get this machine booted in Mint and working. Suggestions appreciated. Thanks very much.

Barry

Re: Disable acceleration? Advice requested

Posted: Fri Oct 16, 2020 1:32 pm
by Larry78723
Please post an inxi -Fxxxz report. This will give us a concise overview of your hardware and on how Mint sees it.

Here is how to generate the report and post it:

Boot from your installation media (USB/DVD)
Open a terminal window (Ctrl-Alt-t). Make it fullscreen to avoid unneeded linebreaks or chopped lines. Execute the command

Code: Select all

 inxi -Fxxxz 
exactly as it has been typed here.

Mark the complete text output which the command will display with your mouse.
Press the keyboard shortcut <Shift><Ctrl>C to copy the marked text into the clipboard.
Enclose the results between the code markers by selecting </> from the mini toolbar above the textbox where you type your reply then paste <Ctrl>V them in your reply between the code markers.

The results will help us to help you.

Larry

Re: Disable acceleration? Advice requested

Posted: Fri Oct 16, 2020 2:37 pm
by SMG
AMD video drivers are included in the Linux kernel. They are not proprietary drivers. I am not sure why 'nomodeset' is not working.

Please provide the information Larry78723 requested, but you can just use your install to provide it (you do not need to use installation media).

Re: Disable acceleration? Advice requested

Posted: Fri Oct 16, 2020 3:19 pm
by rumplestiltskin
I'll add that the video in recovery mode provides the native resolution so that's fine. I just need the iMac to provide this behavior when booting. Even though I can get to the Web, it appears that the local LAN isn't available. I imagine that's due to the "recovery" mode, though.

Thanks!

Results from the inxi command:

Code: Select all

System:
  Host: macuser-17MBP Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc 
  v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin 4.4.2 dm: LightDM 1.26.0 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Apple product: iMac12,2 v: 1.0 serial: <filter> 
  Chassis: type: 13 v: Mac-942B59F58194171B serial: <filter> 
  Mobo: Apple model: Mac-942B59F58194171B v: iMac12,2 serial: <filter> 
  UEFI: Apple v: 87.0.0.0.0 date: 06/14/2019 
CPU:
  Topology: Quad Core model: Intel Core i7-2600 bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54274 
  Speed: 1823 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1621 2: 1661 
  3: 1629 4: 1619 5: 1661 6: 1661 7: 1666 8: 1661 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Apple driver: N/A bus ID: 00:02.0 chip ID: 8086:0102 
  Device-2: AMD Blackcomb [Radeon HD 6970M/6990M] vendor: Apple driver: N/A 
  bus ID: 01:00.0 chip ID: 1002:6720 
  Display: x11 server: X.Org 1.20.8 driver: ati,fbdev 
  unloaded: modesetting,radeon,vesa resolution: 2560x1440~93Hz 
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.8 
  compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
  Device-2: AMD Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM] 
  vendor: Apple driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aa88 
  Sound Server: ALSA v: k5.4.0-42-generic 
Network:
  Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet 
  PCIe 
  driver: tg3 v: 3.137 port: 2000 bus ID: 02:00.0 chip ID: 14e4:16b4 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR93xx Wireless Network Adapter 
  vendor: Apple AirPort Extreme driver: ath9k v: kernel port: 2000 
  bus ID: 03:00.0 chip ID: 168c:0030 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 922.21 GiB used: 49.84 GiB (5.4%) 
  ID-1: /dev/sda vendor: Toshiba model: APPLE HDD MK7559GSXF 
  size: 698.64 GiB speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1B scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: OWC model: Aura Pro 6G SSD 
  size: 223.57 GiB serial: <filter> scheme: GPT 
Partition:
  ID-1: / size: 685.22 GiB used: 6.25 GiB (0.9%) fs: ext4 dev: /dev/dm-0 
  ID-2: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 940 
Info:
  Processes: 237 Uptime: 2h 24m Memory: 15.62 GiB used: 856.6 MiB (5.4%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 Shell: bash 
  v: 4.4.20 running in: gnome-terminal inxi: 3.0.32 


Re: Disable acceleration? Advice requested

Posted: Fri Oct 16, 2020 3:48 pm
by rumplestiltskin
I just noticed this part of the report:

Code: Select all

  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Apple driver: N/A bus ID: 00:02.0 chip ID: 8086:0102 
I had always thought that the iMac only had a discrete video card but the above code seems to indicate there's a motherboard video chip(!) like a 15"/16" MacBook Pro. On MBP's whose video cards have failed, I've used some firmware code to disable the card and force it to only use the mobo's embedded video chip. the Mac could then run a slightly hacked version of macOS (that lacked any drivers for the Nvidia/AMD cards and used only the Intel GPU chip).

Maybe my iMac is actually just running its video on the Intel chip. Perhaps there's a command that would reveal this (as my iMac is still running in the recovery mode).

Barry

Re: Disable acceleration? Advice requested

Posted: Fri Oct 16, 2020 3:58 pm
by SMG
Recovery mode is loading neither of the graphics device drivers (in red) and is unloading the display drivers for each (in blue). So the drivers are available in the kernel and you could use them if the system would boot normally.

Graphics:
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Apple driver: N/A bus ID: 00:02.0 chip ID: 8086:0102
Device-2: AMD Blackcomb [Radeon HD 6970M/6990M] vendor: Apple driver: N/A
bus ID: 01:00.0 chip ID: 1002:6720
Display: x11 server: X.Org 1.20.8 driver: ati,fbdev
unloaded: modesetting,radeon,vesa resolution: 2560x1440~93Hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.8
compat-v: 3.1 direct render: Yes

I seem to recall that there may be special steps need to boot iMacs/Macs, so that may be why you are only able to boot in recovery mode. Do a search in this forum on "iMac" and you may find what you need. One can not just boot from a USB to a live-session on a Mac/iMac. I think Refined and some other steps are needed? I don't recall for sure, but I know it is not as simple as booting on other computers.

Re: Disable acceleration? Advice requested

Posted: Fri Oct 16, 2020 4:37 pm
by rumplestiltskin
The iMac is booting from a drive that already had Mint installed; I just grabbed it off the shelf and plugged it into the iMac's SATA connectors.

If neither the Intel nor AMD drivers are loaded, then it's some sort of generic VGA driver built into the kernel that's loaded and running? I guess this is the crux of the issue: What driver is actually loaded/running that is providing perfectly good video in this "recovery" mode and how do I tell Mint to do this all the time?

No other special steps are needed to get Mint installed (on Macs that aren't borked in the manner this one is). I will say that even the MB Pros with the disabled video cards install Mint without issues (as Mint sees the mobo Intel GPU and installs/loads whatever is required).

Barry

Edited: Did some more searching and found enough negative responses to show that the Intel built-in GPU can't be accessed on the iMac; it needs to have the discrete GPU card. So whatever video driver that's running in recovery mode is the correct one for the GPU. Need to know what driver that is and how to permanently set this Mint installation to use only it.
SMG wrote:
Fri Oct 16, 2020 3:58 pm
Recovery mode is loading neither of the graphics device drivers (in red) and is unloading the display drivers for each (in blue). So the drivers are available in the kernel and you could use them if the system would boot normally.

Graphics:
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Apple driver: N/A bus ID: 00:02.0 chip ID: 8086:0102
Device-2: AMD Blackcomb [Radeon HD 6970M/6990M] vendor: Apple driver: N/A
bus ID: 01:00.0 chip ID: 1002:6720
Display: x11 server: X.Org 1.20.8 driver: ati,fbdev
unloaded: modesetting,radeon,vesa resolution: 2560x1440~93Hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.8
compat-v: 3.1 direct render: Yes

I seem to recall that there may be special steps need to boot iMacs/Macs, so that may be why you are only able to boot in recovery mode. Do a search in this forum on "iMac" and you may find what you need. One can not just boot from a USB to a live-session on a Mac/iMac. I think Refined and some other steps are needed? I don't recall for sure, but I know it is not as simple as booting on other computers.

Re: Disable acceleration? Advice requested

Posted: Fri Oct 16, 2020 5:28 pm
by SMG
It's called "nomodeset" and you add it on the "quiet splash" line in grub.

Manual "nomodeset" Kernel Boot Line Option for Linux Booting Scroll down to the section on permanent "nomodeset".

Re: Disable acceleration? Advice requested

Posted: Sat Oct 17, 2020 3:49 pm
by rumplestiltskin
Thanks, SMG, for the link. Apparently, 'gedit' isn't in my Mint installation but I used Text Editor to open the grub file, modified it, saved it to the desktop, then used 'sudo cp...' to move it to the correct location. I followed that up with the 'update' command as specified in the header of the grub file. Upon a reboot, it comes to the Mint Desktop without any intervention needed.

Now the only issue (and it is minor) is the "Check your video drivers" dialog that pops up (warning me that acceleration is turned off). Any idea how to stop that one dialog from appearing? I read a post somewhere that would restrict it to the systray but that method would send all notifications there rather than pop up a (probably useful) dialog.

Thanks very much!

Barry

Re: Disable acceleration? Advice requested

Posted: Sat Oct 17, 2020 4:26 pm
by SMG
rumplestiltskin wrote:
Sat Oct 17, 2020 3:49 pm
Thanks, SMG, for the link. Apparently, 'gedit' isn't in my Mint installation but I used Text Editor to open the grub file, modified it, saved it to the desktop, then used 'sudo cp...' to move it to the correct location. I followed that up with the 'update' command as specified in the header of the grub file. Upon a reboot, it comes to the Mint Desktop without any intervention needed.
Glad that worked. I pulled the link from a thread where I was helping someone else who had to use nomodeset because there never were linux drivers created for that laptop's graphic card. The card actually worked fine in Windows, but the person wanted to use Mint.
rumplestiltskin wrote:
Sat Oct 17, 2020 3:49 pm
Now the only issue (and it is minor) is the "Check your video drivers" dialog that pops up (warning me that acceleration is turned off). Any idea how to stop that one dialog from appearing? I read a post somewhere that would restrict it to the systray but that method would send all notifications there rather than pop up a (probably useful) dialog.
The only thing of which I am aware is the last post in this thread <SOLVED> Disable "check your video drives" *notification*. The person was using it on a virtual machine, but I think it would work for you as well.

Re: Disable acceleration? Advice requested

Posted: Sat Oct 17, 2020 6:25 pm
by rumplestiltskin
Thanks; will give that a shot.

Funny how this iMac should have just been dropped off at the recycling center. But here we are, in Linux Mint, and simply by telling the computer to use the generic driver, we have a nice 27" machine that may have some years left in it.

:D

Re: Disable acceleration? Advice requested

Posted: Sat Oct 17, 2020 9:41 pm
by rumplestiltskin
Thanks again, SMG, for the link to the "Check your video drivers" solution. Worked perfectly.

Be safe; stay healthy!

Barry

Re: Disable acceleration? Advice requested - [SOLVED]

Posted: Sun Oct 18, 2020 8:57 am
by SMG
Glad you are all set. If you would edit the title of your first post and add [SOLVED] that would alert others in a similar situation that this might be a good thread to read.