HP Pavillion 15-cw1511sa issues :(

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
AbitOnTheMintySide
Level 1
Level 1
Posts: 28
Joined: Wed Nov 18, 2020 10:14 am

HP Pavillion 15-cw1511sa issues :(

Post by AbitOnTheMintySide »

Hi all,

Hope this is the correct place to post this:

A heads up on some installation issues and how this laptop with Linux installed is unusable as an everyday / office machine.
HP Pavillion 15-cw1511sa touchscreen AMD Ryzen 3 with Radeon graphics.

Pt:1 MS Office 2016.
Installion was fine, because all Docs had been created on Windows 10 I though MS office would be a breeze with POL and Wine.
(We would go with Open or Libre office but the Docs were messed up)
After following a page of instructions to the letter it worked, or so I thought. Word and Excel will randomly freeze crashing the apps and causing a blackscreen, and Docs will not open with their shortcuts regardless of them pointing to the apps.

PT2: WI-FI Drivers.
Nothing worked after a system update, Had to scour the web for the correct files. Mint forums came to the rescue.
Any clue as to why the driver that was already installed wouldn't work?

P3: Touch screen and display.
It works but scrolling doesn't. I can open and close progs and apps and that's it.
Display. I thought it was all done and dusted. I was told I don't need proprietry drivers, WRONG.
After black screen during the initial login screen, and having to do a repair install, I found AMD's drivers fixed the problem, but the touch screen scrolling issue remains.

So, It's back to Windows 10 for this machine. We have other Intel laptops (Non touchscreen) that will run Mint perfectly.
Has anyone else has these issues with AMD laptops? Would love to Have Mint running on this laptop. Windows slows it down :(

Thanks for reading, hope you didn't fall asleep :)
User avatar
Pjotr
Level 22
Level 22
Posts: 16207
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: HP Pavillion 15-cw1511sa issues :(

Post by Pjotr »

You might want to try a kernel from a newer series on that machine:
Update manager - panel: View - Linux kernels
Install the latest kernel of the 5.8 series. Then reboot.
Tip: 10 things to do after installing Linux Mint 20.1 Ulyssa
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
User avatar
kato181
Level 6
Level 6
Posts: 1114
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: HP Pavillion 15-cw1511sa issues :(

Post by kato181 »

Code: Select all

(We would go with Open or Libre office but the Docs were messed up) 
Have you installed the MS fonts?
Copy & paste the following command in terminal..
wget http://ftp.us.debian.org/debian/pool/co ... .8_all.deb -P ~/Downloads
the..
sudo apt install ~/Downloads/ttf-mscorefonts-installer_3.8_all.deb
Finally, copy/paste this command into the terminal:
sudo dpkg-reconfigure fontconfig
Then do the following..
sudo apt-get install fonts-crosextra-carlito fonts-crosextra-caladea
Press Enter.
b. Now you're going to configure Libre Office to use them as replacement for the Calibri en Cambria fonts from Microsoft:

Launch LibreOffice Writer.

In the panel of LibreOffice Writer: Tools - Options... - section LibreOffice: Fonts

Tick: Apply replacement table

c. Type in for Font (it's not in the dropdown list, you have to type it): Calibri
Replace by: Carlito (it's in the dropdown list)

Press the button with the green tick.

Tick: Always and Screen only

d. Now type in for Font (it's not in the dropdown list, you have to type it): Cambria
Replace by: Caladea (it's in the dropdown list)

Press the button with the green tick.
Tick: Always and Screen only
Then check to see if the doc files work.
Here is the link.. I'm assuming you are using LM20
https://easylinuxtipsproject.blogspot.c ... namon.html
AbitOnTheMintySide
Level 1
Level 1
Posts: 28
Joined: Wed Nov 18, 2020 10:14 am

Re: HP Pavillion 15-cw1511sa issues :(

Post by AbitOnTheMintySide »

Pjotr wrote:
Fri Nov 20, 2020 4:27 pm
You might want to try a kernel from a newer series on that machine:
Update manager - panel: View - Linux kernels
Install the latest kernel of the 5.8 series. Then reboot.
I will try that, thanks!
AbitOnTheMintySide
Level 1
Level 1
Posts: 28
Joined: Wed Nov 18, 2020 10:14 am

Re: HP Pavillion 15-cw1511sa issues :(

Post by AbitOnTheMintySide »

kato181 wrote:
Sat Nov 21, 2020 5:31 am

Code: Select all

(We would go with Open or Libre office but the Docs were messed up) 
Have you installed the MS fonts?
Copy & paste the following command in terminal..
wget http://ftp.us.debian.org/debian/pool/co ... .8_all.deb -P ~/Downloads
the..
sudo apt install ~/Downloads/ttf-mscorefonts-installer_3.8_all.deb
Finally, copy/paste this command into the terminal:
sudo dpkg-reconfigure fontconfig
Then do the following..
sudo apt-get install fonts-crosextra-carlito fonts-crosextra-caladea
Press Enter.
b. Now you're going to configure Libre Office to use them as replacement for the Calibri en Cambria fonts from Microsoft:

Launch LibreOffice Writer.

In the panel of LibreOffice Writer: Tools - Options... - section LibreOffice: Fonts

Tick: Apply replacement table

c. Type in for Font (it's not in the dropdown list, you have to type it): Calibri
Replace by: Carlito (it's in the dropdown list)

Press the button with the green tick.

Tick: Always and Screen only

d. Now type in for Font (it's not in the dropdown list, you have to type it): Cambria
Replace by: Caladea (it's in the dropdown list)

Press the button with the green tick.
Tick: Always and Screen only
Then check to see if the doc files work.
Here is the link.. I'm assuming you are using LM20
https://easylinuxtipsproject.blogspot.c ... namon.html
Yes I did installed everything MS to make sure I didn't run into trouble.
The fonts were fine, the layout of the Docs appeared broken, and the fact that neither Word or Excel would start from shortcuts made it nearly impossible to use.
Most of the time the MS apps would crash making it unusable.

I'll give it another try next weeks with the information you've given and report back. Thanks for helping me out. all info is on how to solve this is welcome.
Post Reply

Return to “Installation & Boot”