Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help


Postby sourwire » Tue Jun 19, 2007 3:34 pm

Ok, I was trying to make a grub splashimage, so I modified the menu.lst (/boot/grub). I added this:

Code: Select all

The splashimage I was making was called mintsplash-blue.xpm.
Now, all of the sudden grub won't load either Windows OR Linux. When I press enter, it just restarts.
I tried using my Knoppix rescue CD, to revert my menu.lst back to what it was (I have a backup), but Knoppix tells me that the filesystem is read-only.
I tried some other live-cd distros, same thing.
Please help me!

PS And by the way grub 'c' key which is supposed to launch the command-line, restarts the computer too.

User avatar
Level 8
Level 8
Posts: 2277
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Re: HELP!!!

Postby scorp123 » Tue Jun 19, 2007 5:02 pm

sourwire wrote:but Knoppix tells me that the filesystem is read-only.
The shell is your friend :D You have to mount your partitions manually ... just clicking on those stupid desktop icons will mount the disk in question as read-only.

The easiest thing would probably be this:

- boot Knoppix
- click on the one disk icon that represents your harddisk where you need write access to
- open a terminal
- become root: sudo su -
- check what is mounted and where: mount
- You should get a listing, maybe containing a line something like this:

Code: Select all

/dev/sda5 on /mnt/sda5 type ext3 (ro)

Now, as you are root, you can tell it to remount read-write:
mount -o remount,rw /dev/sda5 /mnt/sda5

=> This should give you instant write-access.

!!To be used with extreme caution!! :wink:



Postby sourwire » Wed Jun 20, 2007 1:19 am

scorp123, you are the awesomest! My grub is back and running! :lol:
Thank you SO much! :D

Return to “Installation & Boot”