Dual Boot with Win 10, no GRUB shows up

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
zephead98
Level 1
Level 1
Posts: 3
Joined: Fri Jan 01, 2021 6:27 pm

Dual Boot with Win 10, no GRUB shows up

Post by zephead98 »

So that pretty much explains it!
Dual boot laptop, Win 10 on one partition, Mint 20 on the other.
I did the install from a live USB. Went very smoothly.
UEFI enabled in BIOS. Secure boot is disabled.
No matter what I try (in BIOS, set the boot order to the linuxmint entry), boots straight to Win 10.
I reboot with the live USB and run the GRUB utility under Administration, and it says everything is good, but I never get a GRUB menu.
Just always straight into Win 10.

Appreciate any help. Happy New year everyone!
JeremyB
Level 20
Level 20
Posts: 11968
Joined: Fri Feb 21, 2014 8:17 am

Re: Dual Boot with Win 10, no GRUB shows up

Post by JeremyB »

What manufacturer/model of computer?
User avatar
ThrashZone2
Level 1
Level 1
Posts: 36
Joined: Fri Oct 30, 2020 2:27 pm

Re: Dual Boot with Win 10, no GRUB shows up

Post by ThrashZone2 »

Hi,
You select default os in win-10 ?
Cinnamon 20-x64----Win-7 & 10 pro's
Reddog1
Level 4
Level 4
Posts: 220
Joined: Wed Jun 01, 2011 2:12 pm

Re: Dual Boot with Win 10, no GRUB shows up

Post by Reddog1 »

You have to disable Fast Startup inside Windows (not the bios, turn off Fast Startup after booting to Windows).

Windows Control Panel>System and Security>Power Options>select 'choose what the power button does'>choose 'change settings that are currently unavailable'>in the window that appears UNCHECK 'turn on fast startup'>Save Changes

Reboot and see if Grub appears

When Fast Startup is enabled, Windows hijacks the system boot and somehow bypasses grub, even if grub is installed correctly
zephead98
Level 1
Level 1
Posts: 3
Joined: Fri Jan 01, 2021 6:27 pm

Re: Dual Boot with Win 10, no GRUB shows up

Post by zephead98 »

IT's an HP Pavilion laptop, newer model, I5 Intel.
When I disable "Fast Startup",in typical Windows bass-ackwards funtionality, there is now NO prompt to get into BIOS, and it still boots right into Win 10.
The only reason I keep Win 10 around is for tax filing.
Doing dual boot used to be so easy (we used to use LILO back in the day), but Microsoft has made it very difficult it seems.

When I do get into the BIOS, there is Boot Order, which is fine, then Boot Loader. There are two options:the windows boot loader, or the ubuntu boot loader. No matter which one I choose, upon bootup, Welcome to Windows....ARGH!
JeremyB
Level 20
Level 20
Posts: 11968
Joined: Fri Feb 21, 2014 8:17 am

Re: Dual Boot with Win 10, no GRUB shows up

Post by JeremyB »

You need to move ubuntu to the top of the boot loader list and press F10 twice, then it might boot to Grub
zephead98
Level 1
Level 1
Posts: 3
Joined: Fri Jan 01, 2021 6:27 pm

Re: Dual Boot with Win 10, no GRUB shows up

Post by zephead98 »

JeremyB wrote:
Sat Jan 02, 2021 10:35 am
You need to move ubuntu to the top of the boot loader list and press F10 twice, then it might boot to Grub
Oh the oddities of BIOS. Where you move Ubuntu to the top, hit ESC to close that little screen, Press ENTER on Boot Loader just to make sure Ubutu is still at the top, and it is, press ESC then F10 to save...and NOTHING.

Do what JeremyB says, and VOILA!

Thanks so much, def appreciate it!
JeremyB
Level 20
Level 20
Posts: 11968
Joined: Fri Feb 21, 2014 8:17 am

Re: Dual Boot with Win 10, no GRUB shows up

Post by JeremyB »

On a lot of laptops with UEFI installs there are no issues but some laptops will not allow the UEFI bootmenu to be altered by a Linux install and it has to be done manually.
Reddog1
Level 4
Level 4
Posts: 220
Joined: Wed Jun 01, 2011 2:12 pm

Re: Dual Boot with Win 10, no GRUB shows up

Post by Reddog1 »

You should be able to access the BIOS at boot by tapping one of the F keys at powerup. Don't know which one for that laptop, maybe F10 or F2 should take you directly to BIOS. I think you need to get to the bios and set the administrative BIOS password before the rest of this will work, because I'm guessing that HP has an Insyde BIOS, which has some screwy requirements. The bios password has to be set in order to access the BIOS Secure Boot functions. If it isn't an Insyde Bios, disregard most of this post.

There should also be a Function key that you can press at startup that will bring up the Windows bootloader screen, and that will show an entry for 'ubuntu'. Might be the Esc key or something else, laptop models use different function keys. That key will pause the Windows bootloader and stop the direct boot to windows. Anyway, if you can get to that Windows bootloader screen there should be a choice for 'ubuntu' which will bring up the grub menu. From there, you can access 'system setup' (the last grub menu entry, probably) and get to the bios and disable Secure Boot, if you haven't managed to get to it via one of the F keys, and if you haven't already set a bios password you can do that, too.

One of those password protected bios areas is under the Secure Boot section, which allows the BIOS to register the linux *.efi file (probably shimx64.efi) which will allow grub as an approved bootloader. If the file it wants isn't the shimx64 you will get an error similar to 'you must first load a kernel'. If that happens, choose the grubx64.efi. You can also label your bootloader Mint.

Things were so much simpler before UEFI.
Post Reply

Return to “Installation & Boot”