[Solved] Dual Boot with W10 - Avoiding UEFI Issues

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
ytene
Level 4
Level 4
Posts: 217
Joined: Sat Mar 16, 2013 3:10 pm

[Solved] Dual Boot with W10 - Avoiding UEFI Issues

Post by ytene »

I've just spent a day tripping over a couple of entirely avoidable mistakes during an attempt to build a brand new, dual-booting machine with Windows 10 Pro and Mint 20.0 set to dual-boot via grub. The symptoms I experienced related to an inability to get Windows 10 and Mint to co-exist peacefully - if I got Windows 10 installed first, adding Mint afterwards would not work.

Hardware:-
ASRock Z390M-ITX/ac - Intel Z390 chipset and support for 9th Generation Socket 1151 CPUs [including Core i9s]
Samsung 970 EVO Plus 1Tb PCIe NVMe M.2 SSD (with 3rd party heatsink added
Intel Core i9-9900-8C16T CPU
32Gb DDR4 3800 RAM
Streacom FC8 fanless case

I installed Windows 10 first, using an existing Microsoft original USB key, selecting the 64-Bit Pro OS version...
Clean installation, giving 3 formatted partitions - a ~ 500Mb hidden partition, a 500Gb "C:" partition I specified and finally a ~500Mb "Windows Recovery" partition...
I let Windows update run and perform the not inconsiderable updated to get to the latest edition of Windows...
Performed a clean reboot to make sure that there were no lingering tasks...

Placed a USB key with Mint 20.0 Ulyana/Cinnamon/64-Bit prepared from an existing Mint build and the "USB Writer" utility...

With the Motherboard BIOS set to boot from USB in preference to local SSD, rebooted the system.
Mint "live" came up and I was able to run the installer without difficulty.

Issue 1 - EFI Partition
After choosing to manually partition my drive [and do so] and then click "Install", I got an error message to the effect that my configuration lacked a partition, "/efi". I checked and discovered that one of the "partition types" now offered by the installer is just such a partition... So, backed out all the proposed changes and started over, this time adding an 8Gb "/efi" partition to the requested configuration. [A message from the installer suggests that 4Gb is an absolute minimum, but since that's a tiny amount I felt OK to double it for safety].

However, when I rebooted the machine after this "successful" installation, I got an BIOS error message to tell me that no Operating System was visible. Had Mint completely trashed my build? Well, no. It turns out (I think) that I was trying to boot a version of Mint configured to run on UEFI hardware with a machine that wasn't set for UEFI.

The Windows 10 Installer USB key was not a UEFI style installer, so with the machine running in "non-UEFI" "BIOS" mode, it went in just fine.
However, I had adjusted the boot order on my BIOS to prioritize USB over SSD... The Mint USB ISO image will default to UEFI mode if you just put it in a machine and let it boot "by itself".

The solution to the problem was trivially simple: when you POST your machine with the Mint USB stick present, go directly to your system BOOT menu. There, you should find at least 2 options for your Mint USB key - one will be UEFI, but the other will be "USB". If you're running a non-UEFI motherboard, you MUST select the USB Mint option if you want it to work...

An easy mistake to make.

Always use your motherboard's boot menu...
User avatar
ThrashZone2
Level 1
Level 1
Posts: 36
Joined: Fri Oct 30, 2020 2:27 pm

Re: [Solved] Dual Boot with W10 - Avoiding UEFI Issues

Post by ThrashZone2 »

Hi,
Sorry but harmony with win-10 and linux is not possible lol
Beside think you'd need to disable fast start features in win-10

Only way it's remotely possible to have any sort of harmony is if you use a device like this to keep them far apart by removing one and inserting the other you want to use and data for the second slot but don't worry grub sludge will be installed on the data disk soon enough :lol:
http://www.amazon.com/gp/product/B00CDS ... UTF8&psc=1

Another note if the usb win-10 media was format fat32 maybe the issue wouldn't of happened and you would of found out only disabling fast start in win-10 would made it possible to have both os's installed uefi.
Cinnamon 20-x64----Win-7 & 10 pro's
ytene
Level 4
Level 4
Posts: 217
Joined: Sat Mar 16, 2013 3:10 pm

Re: [Solved] Dual Boot with W10 - Avoiding UEFI Issues

Post by ytene »

Your comment regarding the need to disable "Fast Start" is an important point...

I tend to install W10 first, then Mint, then allocate the balance of the physical volume to a single NTFS partition which I then share between the two Operating Systems. That worked really well prior to W10, but as you rightly point out, you do have to go in to Control Panel > Power Options and disable "Fast Start".

For the technically-minded, "Fast Start" is a Windows 10 feature that instead of writing drive volume back to a disk before closing down the OS [i.e. forcing a "sync" with the file system], it writes the open header and pointer values to Windows Swap space, which it then loads more quickly at the next start-up. If you let a W10 system shut down with "Fast Start" enabled, checksums designed in to NTFS will not be valid and any attempt to open the drive under Mint will throw a drive integrity error.

The really annoying part of this is that each major release of Windows 10 over-writes whatever you have set your "Fast-Start" value to, in other words it will turn it back on, even if you disable it. Obviously this is because Windows doesn't believe that you own your computer and that you have no right to configure it the way that you want it.
User avatar
ThrashZone2
Level 1
Level 1
Posts: 36
Joined: Fri Oct 30, 2020 2:27 pm

Re: [Solved] Dual Boot with W10 - Avoiding UEFI Issues

Post by ThrashZone2 »

Hi,
Yeah you can run cmd and powercfg -h off and never have to look at power options to turn off hibernation.
Cinnamon 20-x64----Win-7 & 10 pro's
Post Reply

Return to “Installation & Boot”