mint, ubuntustudio share home patition failed

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
holyct
Level 1
Level 1
Posts: 7
Joined: Mon Apr 09, 2007 2:06 am
Location: Singapore

mint, ubuntustudio share home patition failed

Postby holyct » Sat Jun 23, 2007 6:00 pm

well, I have my harddisk hda for windows,
hdb1 primary partition 10gb, ext3
hdb2 primary partition 10gb, ext3
hdb5 logic partition 60gb, ext3
I installed ubuntustudio first, in hdb1, and /home in hdb5
then I installed mint in hdb2, and /home in hdb5
i use different user name for the two distribution.
I am able to boot up mint, everything fine, but when i boot up ubuntustudio, it says not able to mount hdb5 and fsck unable to solve the problem.

do I have to reinstall ubuntustudio with different /home partition or is there a easier work around for my problem?

User avatar
scorp123
Level 8
Level 8
Posts: 2264
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 » Sat Jun 23, 2007 6:28 pm

When you do something like that you obviously have to make sure that the /home partition doesn't get formatted ...

From the installation that works ... can you check what's in /home?

Code: Select all

ls -al /home

holyct
Level 1
Level 1
Posts: 7
Joined: Mon Apr 09, 2007 2:06 am
Location: Singapore

Postby holyct » Sat Jun 23, 2007 11:11 pm

ya, I didn't format my /home partition at all.
the /home partition has both my username folders, but ubuntustudio username folder has nothing inside.

when booting it just complain something like

Code: Select all

hdb5.ext3: fsck not able to solve problem "UUID=xxxxxxxxxxxxxxxxxxx"

where "xxxxxxx..." is a string of don't know what.

User avatar
scorp123
Level 8
Level 8
Posts: 2264
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Postby scorp123 » Sun Jun 24, 2007 5:12 am

holyct wrote: but ubuntustudio username folder has nothing inside.
meaning that everything inside probably got deleted. :?

holyct wrote: when booting it just complain something like

Code: Select all

hdb5.ext3: fsck not able to solve problem "UUID=xxxxxxxxxxxxxxxxxxx"

where "xxxxxxx..." is a string of don't know what.
That's an identifier for your harddisk ... I hate that nonsense. It's only recently they came up with that UUID crap. I personally disable this stuff on my systems and use the classic /dev/hda6, /dev/hdb1 etc. designations -- they simply work and don't break so easily like this UUID stuff.

The error you get probably means that one of the harddisks cannot be found anymore. When you installed that second Linux it probably changed the UUID's of one of the disks, meaning that the previous installation cannot find it now.

Check this file: /etc/fstab for both of your Linux installations. You probably will have to use a Live CD for this. If you say you share /home between the two, then the entry for the /home partition should be the same in both /etc/fstab files. Obviously you will have to replace the one that doesn't want to work anymore with the one entry that still seems to work. Hint: Don't delete any lines, just comment them out by placing a "#" on their beginning and then add your new corrected entry underneath the disabled one ... should anything still go wrong you can easily revert your changes by deleting the new entry you did and by removing "#" you placed on the beginning of the lines you disabled.


Return to “Installation & Boot”

Who is online

Users browsing this forum: No registered users and 4 guests