[SOLVED] Changing timer for man-db.service

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
kevin987
Level 5
Level 5
Posts: 802
Joined: Fri Dec 11, 2015 12:35 pm

[SOLVED] Changing timer for man-db.service

Post by kevin987 »

I'm trying to reduce boot time on a computer that is only powered on 2 hours a day running Linux Mint 20.1. The man-db.service always takes 17+ seconds. The timer is set for every 12 hours. I would like to change the timer to once per week. Can I simply change the OnCalendar to weekly. Would I change the AccuracySec setting.

Code: Select all

systemctl cat man-db.timer
# /lib/systemd/system/man-db.timer
[Unit]
Description=Daily man-db regeneration
Documentation=man:mandb(8)

[Timer]
OnCalendar=daily
AccuracySec=12h
Persistent=true

[Install]
WantedBy=timers.target
Last edited by kevin987 on Tue May 11, 2021 9:05 pm, edited 1 time in total.
Linux Mint 20.3 (Cinnamon)
Linux Mint 19.3 (Cinnamon)
Bodhi Linux 6.0 (MokshaArcGreen)
Fedora 35 (Cinnamon)
User avatar
kevin987
Level 5
Level 5
Posts: 802
Joined: Fri Dec 11, 2015 12:35 pm

Re: Changing timer for man-db.service

Post by kevin987 »

I was able to successfully change the OnCalendar setting to weekly and I left the AccuracySec at 12 hours.

Code: Select all

OnCalendar=weekly
AccuracySec=12h
The man-db.service now only checks at 00:00 Monday, or at first boot on Monday if the computer is not powered on at that time.

I didn't think it a good idea to disable that service permanently, so only having it check once a week seemed reasonable.

That way it only adds the additional 17+ seconds once per week for the boot time.
Linux Mint 20.3 (Cinnamon)
Linux Mint 19.3 (Cinnamon)
Bodhi Linux 6.0 (MokshaArcGreen)
Fedora 35 (Cinnamon)
motoryzen
Level 7
Level 7
Posts: 1897
Joined: Sun Dec 08, 2019 12:25 am

Re: [SOLVED] Changing timer for man-db.service

Post by motoryzen »

How exactly did you change the timer?

I mentioned this url with your results to another one as a suggestion option to trim some boot up time but I forgot you didn't post..HOW ..you were able to make this change.
Primary rig:
asrock x570 taichi
ryzen 5900x
128GB of kingston fury at 3600mhz 1.44 volts 20-20-20 ( I forgot the rest) 1T timings
corsair mp600 pro xt NVME ssd 4TB
8GB rx580 sapphire nitro+ video card
Viewsonic Elite UHD 32" 144hz monitor
User avatar
kevin987
Level 5
Level 5
Posts: 802
Joined: Fri Dec 11, 2015 12:35 pm

Re: [SOLVED] Changing timer for man-db.service

Post by kevin987 »

motoryzen wrote:
Mon Jan 31, 2022 5:55 pm
How exactly did you change the timer?

I mentioned this url with your results to another one as a suggestion option to trim some boot up time but I forgot you didn't post..HOW ..you were able to make this change.
You can access lib/systemd/system/man-db.timer through nemo with your text editor using root privileges, or use the terminal with nano text editor using the command cd /lib/systemd/system/ && sudo nano man-db.timer

You would change the OnCalender=daily to OnCalender=weekly
Linux Mint 20.3 (Cinnamon)
Linux Mint 19.3 (Cinnamon)
Bodhi Linux 6.0 (MokshaArcGreen)
Fedora 35 (Cinnamon)
motoryzen
Level 7
Level 7
Posts: 1897
Joined: Sun Dec 08, 2019 12:25 am

Re: [SOLVED] Changing timer for man-db.service

Post by motoryzen »

Awesome..thanks for the info kevin987 . Cheers.
Primary rig:
asrock x570 taichi
ryzen 5900x
128GB of kingston fury at 3600mhz 1.44 volts 20-20-20 ( I forgot the rest) 1T timings
corsair mp600 pro xt NVME ssd 4TB
8GB rx580 sapphire nitro+ video card
Viewsonic Elite UHD 32" 144hz monitor
Post Reply

Return to “Installation & Boot”