Grub Boot loader (Solved)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Daft Fooker
Level 1
Level 1
Posts: 5
Joined: Sat Dec 05, 2009 10:10 am

Grub Boot loader (Solved)

Post by Daft Fooker »

I have just upgraded from Linux Mint 7 to Helena 8 on a HP 9005 Laptop dual boot with Windows XP Pro.
Linux Mint 7 worked fine but now I find when I use the down arrow on keyboard to select another option to boot from
the boot loader will just lock up and I have to power unit down?
If I leave the option to boot into Helena as default it will boot ok.
If I select XP as the default OS it will boot in but again if I use the down arrow on keyboard to select another option to boot from the boot loader will just lock up and I have to power unit down?
Any Ideas?
Last edited by Daft Fooker on Sat Dec 05, 2009 5:41 pm, edited 1 time in total.
User avatar
lagagnon
Level 7
Level 7
Posts: 1878
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: Grub Boot loader

Post by lagagnon »

Are you absolutely positive that your keyboard is plugged in properly and functioning? I have only ever seen that situation occur in one of those two conditions.
Daft Fooker
Level 1
Level 1
Posts: 5
Joined: Sat Dec 05, 2009 10:10 am

Re: Grub Boot loader

Post by Daft Fooker »

Hi
Yes Im sure keyboard works ok on laptop as I said it worked OK with Mint 7 I have tried adding 3rd party boot managers
and the keyboard works fine selecting different options under these.
Daft Fooker
Level 1
Level 1
Posts: 5
Joined: Sat Dec 05, 2009 10:10 am

Re: Grub Boot loader

Post by Daft Fooker »

I have now connected a PS2 Keyboard again this functions correctly when in the BIOS all keys work fine.
Soon as I go into Grub 1.97 beta and try to select another option computer locks?
Think it would be a good idea to select your boot manager at time of install I can not see an option to do this when partitioning drives ?
breaker
Level 5
Level 5
Posts: 607
Joined: Sun Mar 16, 2008 5:28 am

Re: Grub Boot loader

Post by breaker »

Check in your BIOS for legacy usb [keyboard] support. Try turning this on/off and see what happens if you try to use your usb keyboard. Even try a different usb port.
rtfm - read the fine manual...
Boot info script: http://ubuntuforums.org/showthread.php?t=1291280
grub2 https://help.ubuntu.com/community/Grub2
PC-BIOS based booting, mbr, boot records; http://thestarman.pcministry.com/
Daft Fooker
Level 1
Level 1
Posts: 5
Joined: Sat Dec 05, 2009 10:10 am

Re: Grub Boot loader (Solved)

Post by Daft Fooker »

Ok I flashed the BIOS but this made no difference then I read your reply Breaker and thought I would give it a try
and to my surprise it done the trick thanks for that :D I have used this laptop with the same settings for testing Linux Mint 4
and above as well as Ubuntu,PC Linux OS,Susie,Mandrake,Simply Mepis and many more and all have worked up till now
without disabling USB Legacy support it just goes to prove you should always look for the simple fix first.
Thanks again.
PS. Still think boot config tools should be loaded as standard install
Post Reply

Return to “Installation & Boot”