Macbook Pro won't boot after external drive Mint install.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Mon Jan 04, 2010 2:57 am

Macbook Pro won't boot after external drive Mint install.

Postby OHNOES » Mon Jan 04, 2010 4:35 am


I installed Mint 8 via Parallels desktop 5 for fun and was having problems with screen resolutions so I figured, what the hell, I'll install a copy on an external firewire drive, after all, that couldn't hurt anything on my internal hard drive right? Well needless to say something went very wrong. I'm going to try to be as detailed as possible in hopes someone can help me fix this without me having to completely reinstall OS X.

Computer specs:

Macbook Pro 17"
OS X 10.5.8 on a 500GB HD with no partitions
No special bootloaders etc
External 30GB firwire drive.

1. DLed Mint 8 iso, and made a live CD
2. Loaded live CD by holding "option" while booting up my mac and selected to boot from the live CD
3. With the live CD booted, used Disk Utility to format external drive to ext4 filesystem
4. Went about installing Mint on the external drive via the desktop installation package. Allowed Mint to use the entire external drive.
5. When Mint finished installing got to the "remove LiveCD and press Enter" so I did.
6. Upon reboot loaded to grey screen, and the good ol' flashing "?" Folder icon
7. Tried rebooting using "option" startup, nothing with the ability to start up found.
8. Restart again and load factory 10.5 install DVD. Internal drive is recognized as having a bootable install of OS X 10.5.8 in "Startup Disk." Used Disk Utilities to repair permission and disk of both the volume and the drive itself. Only a few permissions needing repairing and there were no errors found when running repair disk.
9. Reboot and nothing again.
10. Use Drive Genius 2.2 to repair disk, report says no problems found, reboot, nothing. Verify again by loading factory OS X DVD and using "startup disk" that OS X is still there.
11. Use Tech Tools 5 to repair disk, report says no problems found, reboot, nothing. Verify again by loading factory OS X DVD and using "startup disk" that OS X is still there.
12. Start Macbook Pro in target mode and try to boot OS X via firewire from girlfriends MacBook. Does not recognize.
13. Tried swapping girlfriends MacBook's "BootX" and "boot.efi" with my MacBook Pro's. Notta
14. Tried installing rEFIt using the "Installing on a separate volume or external disk" guide on their site. Seemed install but didn't do anything.
15. Tried using their live CD option, and it saw I had a drive with OS X on it but when I tried to load it, grey screen, then reloaded the CD (because it didn't find the OS). Was going to use their Disk Utility/Installer but it said it had to partition the drive, and I am not sure if thats doing be destructive or not.

As it stands right now all my files seem to be fine on my internal drive. All my media, applications etc etc, are showing up when I use another computer to examine the drive. I could back them up and reinstall OS X, but I have a huge sample library and a lot of programs I would have to reauthorize, and I would rather not. I'll try anything that might help, post logs, etc. I am NOT experienced with Linux and not that great at using the Terminal either. If I can get Mint running too that'd be a bonus.


Level 5
Level 5
Posts: 608
Joined: Sun Mar 16, 2008 5:28 am

Re: Macbook Pro won't boot after external drive Mint install.

Postby breaker » Mon Jan 04, 2010 6:28 am

The Mint installer will by default put the grub2 boot loader on your first bootable drive, so in that sense, the install does touch your first drive, unless you were to tell the installer (advanced button) to install the boot loader to another drive.

Perhaps an incompatibility with grub2 and your MacBook BIOS, or whatever it is called caused the problem.

I'm on a mac now, and I see that the Terminal provides access to many bsd commands, such as fdisk (man fdisk). It looks like you might be able to restore your mbr (and keep your partition table) with a "sudo fdisk -u" if such a thing can be done from your Mac CD or Mac Live CD.

This is just a guess as I know very little about Macs. This perhaps does not apply to you if your Mac uses GPT instead of MBR or a hybrid.

Sounds dire, good luck!
rtfm - read the fine manual...
Boot info script:
PC-BIOS based booting, mbr, boot records;

Return to “Installation & Boot”

Who is online

Users browsing this forum: thursty and 5 guests