Screen flickering & High temp & High fan.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Fri Oct 15, 2010 10:01 am

Screen flickering & High temp & High fan.

Post by lasseo »

Hi all,

Here are some strange stuff. All hints are appreciated.

My machine is a HP laptop nx9240, ATI graphic. I have for some weeks now trying to use Ubuntu 10.10.
It was working kind of OK, but the problem I had was that the computer goes warm and CPU fan running in high speed all the time. A couple of postings on the Net seams to tell that there are some issues with HP laptops and Ubuntu. ( I think the problem startet when upgrading from ubuntu 10.04 too 10.10)

Anyhow, a lot of people as talked well about Mint Debian edition. Hence I decided to try it out yesterday.
Unfortunalety it is far from a success for me.

* when booting, ( live cd or installed on hd ), the LCD screen on the laptop start to "flicker" during the boot process. It looks like there is no sync.
plugging in a external monitor and the display is OK on that monitor. Using fn-F4 a couple of times gives good picture on internal screen.
(it is possible to set "nomodeset" as boot parameter and display is ok)

* when X starts, display flickers. Either use the trick with the external monitor or use "Screen Resolution" tool to change the resolution back and forth. Now the screen works as normal again.

none of these screen issues has been seen using Ubuntu on the same machine.

Anyway, if I get the display up and running nicely, the CPU fan is still behaving as in the Ubuntu case. Computer gets warm and then the fan spinns up. And it never spinns down. It runs at maximum speed. Not sure it is due to warm CPU or GPU or if it is only fan requlation that works incorrectly.
There are no CPU load according to "top".
So, any hints?


Level 1
Level 1
Posts: 7
Joined: Thu Oct 14, 2010 9:16 pm

Re: Screen flickering & High temp & High fan.

Post by ShinyFeather »

Oh my... I was trying to answer this when I accidentally closed the window. But well, here it comes again. I don't know if my advice will help you because I'm afraid to say I'm not a very knowledgeable person when it comes to Linux (I've been using Mint for a year and a half, but I hardly have more experience than this). Nevertheless there are some things I would like to mention.

I have a similar problem on my new HP laptop (HP pavilion dv7-3110ss) as I explain in a thread here called "Mint 9 - Something went wrong with installation", which I don't know if you have seen or would be interested in reading. My problems are very similar to yours, specially at booting. Moreover, my fan behaves in a similar way than yours. My laptop don't seems to get very hot, but the fan starts spinning as soon as I start the computer and keeps doing so until I shut it off.

I'm currently using the Main Edition of Linux Mint 9. Initially I thought of some error in my installation CD, despite I used the same CD to install Isadora on my old Packard Bell laptop and it always behaved very nicely. But after seeing your case, it actually seems that HP laptops are a little "special" in what regards to Linux. In my case, I asked some experienced people for advice and the only conclusion they had was that it doesn't seem to be any clear reason which could cause these problems. So, to put it simple, we don't have a clue. And that's why, what I find more important to do here is to try various distros and versions (this is what I'm going to do as soon as I have some free time), see what works and what doesn't, and use that information to determine the problem.

Also, I remember that some days ago (I'm kind of sure it was on Windows 7, which was preinstalled on my system and it's currently installed along Linux Mint 9) I found an option about my laptop's fan, which asked if I wanted the fan "Always on" or not. "Always on" was selected by default, so, could it be the deal? Maybe it's normal for HP laptops to have the fan always spinning? Or maybe I'm just talking nonsense... what it's true is that I wonder if is there in Linux a similar option to set that. I hope someone less ignorant than me can answer us that questions.

Post Reply

Return to “Installation & Boot”