HD with Mint boots in Desktop but not Laptop

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
coolguy2008
Level 1
Level 1
Posts: 6
Joined: Wed Sep 15, 2010 1:39 pm

HD with Mint boots in Desktop but not Laptop

Post by coolguy2008 »

I installed Linux Mint in a desktop, and it works, running it right now. But when I put the hard drive back into a laptop it won't boot past the Grub manager.

What do I change so that I can put the hard drive back into the laptop.

This is on a 40 GB Laptop Hard Drive Hitachi
Laptop is Toshiba A45 S120, 256 Ram, 2.6 Ghz.
Desktop is a Dell Optiplex GX240, 1024 Ram, 1.7 Ghz.
I partitioned a 1 GB linux swap file on the drive before installing, I'm not sure how that's working.

Linux Mint boots fine when hard drive is in the Desktop.

I tried writting nomodeset at the Grub manager before booting, but that didn't solve the problem.

What do I change so that I can put the hard drive back into the laptop.

User avatar
OldManHook
Level 5
Level 5
Posts: 500
Joined: Wed May 26, 2010 5:57 am
Location: SomeWhere In The US of A

Re: HD with Mint boots in Desktop but not Laptop

Post by OldManHook »

Your Hardware is not the same in the two computers,so it may not boot in the other computer,You need to make the install on the notebook.
Also how do you fit the desktop drive into the laptop? :)
"Be the change you want to see in the world"
Gandhi

ShinyFeather
Level 1
Level 1
Posts: 7
Joined: Thu Oct 14, 2010 9:16 pm

Re: HD with Mint boots in Desktop but not Laptop

Post by ShinyFeather »

coolguy2008 wrote: This is on a 40 GB Laptop Hard Drive Hitachi [...]
I guess the Hard Drive was originally from the laptop, then he connected it to the desktop, installed Mint, and put it again inside the laptop. What makes me ask, why did you do that? As it seems you will have to install the Linux directly from the laptop, is there any problem with doing so?

Maybe we'll be able to help.

coolguy2008
Level 1
Level 1
Posts: 6
Joined: Wed Sep 15, 2010 1:39 pm

Re: HD with Mint boots in Desktop but not Laptop

Post by coolguy2008 »

The laptop has no DVD drive or bootable USB port. I successfully completed the same operation with Ubuntu 9.04 Jaunty Jackalope, which now runs from the laptop. From this message on ubuntuforums, I see that no hardware profiles are necessary in Ubuntu: http://ubuntuforums.org/showthread.php?t=1291824

So my question is it possible to change hardware profiles in Mint?

(Also, I realised that GNOME requires 512MB Ram, and so I installed XFCE over it, and thought that might fix it, but same problem. I now likewise run Mint 9 XFCE successfully on the Desktop but the laptop goes blank after showing the four green dots for a minute after the Grub manager.)

ShinyFeather
Level 1
Level 1
Posts: 7
Joined: Thu Oct 14, 2010 9:16 pm

Re: HD with Mint boots in Desktop but not Laptop

Post by ShinyFeather »

coolguy2008 wrote:The laptop has no DVD drive or bootable USB port. [...]
Please excuse me my ignorance, what you said makes me very curious. *What* laptop do you have?
I've never came across something like that, and I didn't knew it could be possible. It is not like I have a wide experience, either. So I would like to know. Something's broken, maybe?

Anyways, I'm very happy to see you have managed to run at least one Linux distro on your laptop :wink:
I hope you get an answer soon. I'm sorry for not being able to answer you properly what you are now asking.

User avatar
oobetimer
Level 7
Level 7
Posts: 1877
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle
Contact:

Re: HD with Mint boots in Desktop but not Laptop

Post by oobetimer »

coolguy2008 wrote: (Also, I realised that GNOME requires 512MB Ram, and so I installed XFCE over it, and thought that might fix it, but same problem. I now likewise run Mint 9 XFCE successfully on the Desktop but the laptop goes blank after showing the four green dots for a minute after the Grub manager.)
When your laptop is booting up, press e-key and edit the booting-line. Remove quiet splash and add nomodeset

If there is no the booting-menu, press a shift-key when a laptop is booting-up

The final fix will be made via /etc/default/grub.file

gksudo gedit /etc/default/grub

Change GRUB_HIDDEN_TIMEOUT=0 to #GRUB_HIDDEN_TIMEOUT=0

and GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

sudo update-grub

https://wiki.ubuntu.com/Grub2#grub (/etc/default/grub)

coolguy2008
Level 1
Level 1
Posts: 6
Joined: Wed Sep 15, 2010 1:39 pm

Re: HD with Mint boots in Desktop but not Laptop

Post by coolguy2008 »

Replacing quiet splash with nomodeset made it run a list text lines, and then, same problem.

I did however get XFCE to start in recovery mode. After choosing recovery mode, I selected "failsafex failsafe graphics mode"
I then get a message: "Linux Mint is running in low graphics mode." "The following error was encountered. You may need to update your configuration to solve this: (EE) R128 (0): No DFP detected."
DFP = Digital Flat Panel, I'm not sure if this is the problem.

Then, I get a list of choices, "edit configuration" etc., I choose:
"Run Linux Mint in Low Graphics mode for just one session" and it works, it boots up and looks and works normal.

I don't know how to edit x or what to change however. I played around with the system settings and still after the grub manager and the five green dots for a minute it's like the screen turns off completely, but the computer's on.

User avatar
oobetimer
Level 7
Level 7
Posts: 1877
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle
Contact:

Re: HD with Mint boots in Desktop but not Laptop

Post by oobetimer »

coolguy2008 wrote:Replacing quiet splash with nomodeset made it run a list text lines, and then, same problem.

I did however get XFCE to start in recovery mode. After choosing recovery mode, I selected "failsafex failsafe graphics mode"
I then get a message: "Linux Mint is running in low graphics mode." "The following error was encountered. You may need to update your configuration to solve this: (EE) R128 (0): No DFP detected."
DFP = Digital Flat Panel, I'm not sure if this is the problem.

Then, I get a list of choices, "edit configuration" etc., I choose:
"Run Linux Mint in Low Graphics mode for just one session" and it works, it boots up and looks and works normal.

I don't know how to edit x or what to change however. I played around with the system settings and still after the grub manager and the five green dots for a minute it's like the screen turns off completely, but the computer's on.
Xorg -configure will help you .. :wink:

http://forums.linuxmint.com/viewtopic.p ... nf#p305445

Post Reply

Return to “Installation & Boot”