Page 1 of 1

Linux Mint 10 RC Live USB fails to startx

Posted: Wed Oct 20, 2010 3:27 pm
by Kainous
*EDIT*
Forgot to say that I'm trying the 64 bit version.
*EDIT

This is the simplest way to describe my experience:

IMG_20101020_040551.jpg


After that I tried running in compatibility mode, where I got a terminal. I did startX and it said fatal error. No screen found.

My graphics card is an Nvidia GTS 250M, also there was another person on the help chat channel who was having the same issue as well.
I've tried re-downloading the .iso and reinstalling it to a different USB. Same problem.

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Wed Oct 20, 2010 4:14 pm
by Smiff2
does this happen with Ubuntu 10.10 ?

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Wed Oct 20, 2010 5:23 pm
by Kainous
I don't know, I'll download an try now.

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Thu Oct 21, 2010 7:11 am
by Kainous
Smiff2 wrote:does this happen with Ubuntu 10.10 ?
Yes, it does. Same exact thing.

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Thu Oct 21, 2010 1:00 pm
by Smiff2
right well clearly an upstream problem
such a major one that Mint might want to hold off on release until this is fixed/worked around e.g. by including older xorg or driver?

there are loads of reports of nvidia problems with maverick if you google.

maybe try nvidia 256.x driver, seems 260.x with latest xorg may be the problem.

i don't know but i'm about to roll out on an all-nvidia network so i care.
amazing, how each ubuntu release has some major disaster like this?

edit: what i don't understand is why nouvou driver isn't working, did you first get a good boot on nouvou, then install nvidia, then dead?

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Thu Oct 21, 2010 1:56 pm
by Kainous
Smiff2 wrote:right well clearly an upstream problem
such a major one that Mint might want to hold off on release until this is fixed/worked around e.g. by including older xorg or driver?

there are loads of reports of nvidia problems with maverick if you google.

maybe try nvidia 256.x driver, seems 260.x with latest xorg may be the problem.

i don't know but i'm about to roll out on an all-nvidia network so i care.
amazing, how each ubuntu release has some major disaster like this?

edit: what i don't understand is why nouvou driver isn't working, did you first get a good boot on nouvou, then install nvidia, then dead?
No, didn't even get a first boot on either Mint 10 or Ubuntu 10.10
And yes you are right the amount of people having this issue is great. Hope they fix it soon.

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Thu Oct 21, 2010 2:23 pm
by Monarch
I add the same issue with an ATI x700
solution
on the grub menu press TAB

once the grub options popup type in

Code: Select all

ro nomodeset


and hit enter you should see an orange verboose after that u should be able to use mint on a live session im actualy typing this tru the live session

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Thu Oct 21, 2010 2:47 pm
by Smiff2
ro nomodeset

this disables KMS so not something you'd want to use forever.

http://www.uluga.ubuntuforums.org/showt ... ?t=1592763

see if that lets you boot, then try installing nvidia driver, hopefully after rebooting you won't need nomodeset. no guarantees though.

maybe nouveau doesn't like newer nvidia cards? horrible showstopper bug for anyone hit. this did not happen on my old 7600GS - that loaded with nouveau fine.

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Thu Oct 21, 2010 6:36 pm
by Kainous
Smiff2 wrote:ro nomodeset

this disables KMS so not something you'd want to use forever.

http://www.uluga.ubuntuforums.org/showt ... ?t=1592763

see if that lets you boot, then try installing nvidia driver, hopefully after rebooting you won't need nomodeset. no guarantees though.

maybe nouveau doesn't like newer nvidia cards? horrible showstopper bug for anyone hit. this did not happen on my old 7600GS - that loaded with nouveau fine.
Tried ro nomodset
Didn't fix anything. Same issue is there.

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Thu Oct 21, 2010 8:18 pm
by vincent
nomodeset

One word, with the "e" between "mod" and "set". Spelling counts. ;)

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Thu Oct 21, 2010 10:40 pm
by Kainous
vincent wrote:nomodeset

One word, with the "e" between "mod" and "set". Spelling counts. ;)
I didn't notice that e. Thanks my friend, it worked! I am posting this from Linux Mint RC10 :D

Cheers and thanks everyone. Hopefully they'll get this fixed before releasing.

Huzzah for Linux!

Re: Linux Mint 10 RC Live USB fails to startx

Posted: Fri Oct 22, 2010 12:51 pm
by Smiff2
i guess my post above (where i bolded the e) was too subtle :(

did it work without nomodeset after installing nvidia drivers?

i can't see a way to test mint10 (or ubuntu 10.10) with nvidia drivers without installing to disk, a slight catch22