USB livecd error: vesamenu.c32 : not a COM32R image

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
RyuK
Level 1
Level 1
Posts: 10
Joined: Wed Jun 10, 2009 4:23 pm

USB livecd error: vesamenu.c32 : not a COM32R image

Post by RyuK » Wed Nov 24, 2010 4:29 pm

If you get the error vesamenu.c32 : not a COM32R image when using a live cd on a usb stick, hit tab and type live then enter. This will carry on the boot as normal. Annoying we have to do this with default settings when making a livedvd from within linux using the downloaded iso.
http://www.RyuKent.com - Linux | Android | Technology | Japanese

User avatar
oobetimer
Level 7
Level 7
Posts: 1878
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle
Contact:

Re: USB livecd error: vesamenu.c32 : not a COM32R image

Post by oobetimer » Wed Nov 24, 2010 4:33 pm

RyuK wrote:If you get the error vesamenu.c32 : not a COM32R image when using a live cd on a usb stick, hit tab and type live then enter. This will carry on the boot as normal. Annoying we have to do this with default settings when making a livedvd from within linux using the downloaded iso.
That would be a good HowTo .. :wink:

http://forums.linuxmint.com/viewforum.php?f=42

jvossler
Level 2
Level 2
Posts: 72
Joined: Sun Apr 11, 2010 8:00 pm

Re: USB livecd error: vesamenu.c32 : not a COM32R image

Post by jvossler » Thu Dec 23, 2010 11:34 pm

Thanks for the assist. Great tip!

annabeel80
Level 1
Level 1
Posts: 1
Joined: Wed Aug 10, 2011 6:36 pm

Re: USB livecd error: vesamenu.c32 : not a COM32R image

Post by annabeel80 » Wed Aug 10, 2011 6:52 pm

Each example I see of syslinux.cfg is different from mine, but the key lines are the same, and when you hit "tab" at the "boot" prompt you should see those options (label) for booting
live
xforcevesa
install
textonly
debug
memtest


...then, as noted by others, if you type one of these commands you will boot in that mode.

So type "live" and you will boot normally.

But, like you, I wanted to do it automatically; that's how I got here; looking for answers. Not quick enough!!

So I experimented....

*****Change the "default" where, at or near the first line of syslinux.cfg, it says

default vesamenu.c32

replace "vesamenu.c32" with "live" and voila!!!! the autoboot we wanted!!

default live
prompt 0
timeout 300

menu title ArtistX DVD 1.0
menu background splash.png
menu color title 1;37;44 #c0ffffff #00000000 std

label live
menu label live - boot the Live System
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper initrd=/casper/initrd.gz quiet splash --

label xforcevesa
menu label xforcevesa - boot Live in safe graphics mode
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper xforcevesa initrd=/casper/initrd.gz quiet splash --

label install
menu label install - start the installer directly
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper only-ubiquity initrd=/casper/initrd.gz quiet splash --

label textonly
menu label textonly - boot Live in textonly mode
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper textonly initrd=/casper/initrd.gz quiet --

label debug
menu label debug - boot the Live System without splash and show boot info
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/custom.seed boot=casper initrd=/casper/initrd.gz nosplash --

label memtest
menu label memtest - Run memtest
kernel /isolinux/memtest
append -

label hd
menu label hd - boot the first hard disk
localboot 0x80
append -
this isn't my words, I'm not good in english, but I think it's useful.

Post Reply

Return to “Installation & Boot”