Boot Error

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 2
Level 2
Posts: 83
Joined: Sat Apr 28, 2007 10:00 am

Boot Error

Postby Branta » Tue Oct 30, 2007 10:41 am

Bianca, The file system is:
    /dev/hda2-3, 6 and /dev/hdb9 are ext3
    /dev/hda1, 5 and /dev/hdb8 are swap
    dev/hdb1-2 and 5-7 are Vista (ntfs)
    /dev/hda6 and /dev/hdb9 nothing is installed
    /dev/hda2 is /root and /dev/hda1 is swap on this system
When booting, I get the following error. When I enter a Control-D it continues and correctly boots. /var/checkfs and /var/checkroot are listed (I could not find where they could be attached).

What should I do?

Here is the terminal listing:
    /dev/hda2: clean, 119712/3981312 files, 822146//7956191 blocks [ ok ]

    Checking file systems....
    fsck 1.40-WIP (14-Nov-2006)
    /home:clean, 94216/6406144 files,....blocks
    fsck.ext3 Unable to resolve 'UUID=8ecffefa-2f87....'
    fsck.ext3:Unable to resolve 'UUID=63be5bfa-c059....'
    fsck died with exit status 8
    * file system check failed.
    A log is being saved in /var/log/fsck/checkfs if that location is writable.
    Please repair the file system manually.
    * a maintenance shell will now be started.
    CONTROL-D will terminate this shell and resume system boot.
    Give root password for maintenance
    (or type Control-D to continue):
Here is /var/checkfs:
    Log of fsck -C -R -A -a
    Tue Oct 30 06:15:17 2007

    fsck 1.40-WIP (14-Nov-2006)
    /home: clean, 94216/6406144 files, 10621538/12799788 blocks
    fsck.ext3: Unable to resolve 'UUID=8ecffefa-2f87-428f-92fb-0dbd95206560'

    fsck.ext3: Unable to resolve 'UUID=63be5bfa-c059-4a62-aade-ff526b9d3840'

    fsck died with exit status 8

    Tue Oct 30 06:15:17 2007
Here is /var/chcheckroot:
    Log of fsck -C -a -t ext3 /dev/hda2
    Tue Oct 30 06:15:16 2007

    fsck 1.40-WIP (14-Nov-2006)
    /dev/hda2: clean, 119712/3981312 files, 822146/7956191 blocks

    Tue Oct 30 06:15:17 2007

--- Bob ---

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Wed Oct 31, 2007 7:40 am

A) You only need one swap in each computer - there are never two systems active at the same time
B) You have come to UUID hell :)
Luckily the solution is fairly simple ... _a_problem
Don't fix it if it ain't broken, don't break it if you can't fix it


Re: Boot Error

Postby bmike78 » Fri Feb 15, 2008 8:55 pm

I've had this same problem for months after upgrading from edgy to feisty and have been hitting Ctl+D to bypass.

I'm not sure why this worked, but I was having issues with /dev/hdd. It would show up fine in /etc/fstab and in vol_id.

I noticed that if I ran blkid, it would NOT show /dev/hdd. Running "blkid /dev/hdd" seemed to detect it. When running blkid this time, it showed up!

I rebooted to verify things worked and they did... no UUID errors this time.

I guess when fsck runs on boot, it must look to the information in blkid to reference the UUID's/

Anyways, hope this helps people out there. I'm glad to rid this "annoyance".



Re: Boot Error

Postby Guest » Wed Feb 27, 2008 7:43 am


having same problem as above but cant seem to solve it with what i've found so far. I can only get to a command line by booting recovery mint linux... I have a dual boot set up mint & XP pro with 4 main partitions (first one is dell utility, second is XP, third is extended for linus mint [holds / , /home & /swap] and fourth partition is an NTFS formatted for XP). I have installed Mint light. When I turn on PC its doesnt automatically go to the grub menu, it give me a screen with linux mint background pic and a text box in top left corner that look a bit like this:
/ ----- pstk------------------rstk--- \
: :
: :
: :
: :
:0 5ffae. a :
:1 5ff8a. a :
:2 2c244. 4 :
:3 147. 9: 0: fffffff. 5:
:4 a. 1: 1: 1462. 5:

pressing enter then takes me to the grub menu where i can adequately boot into XP.

When I try to boot to linux Mint however there are a few problems...
something only happens when booting into recovery mode (ie normal boot fails miserably)

then i get a few bad file names in sda1 (the dell utility drive I think) with error message
fsck died with exit status 8
*File system check failed.

i get a shell in recovery mode but pressing ctl-D doesnt boot normally as suggested by the messages...

what gives? any quick fix? is the dell utility partition causing problems? I noticed when I was making partitions in gparted from live CD that there was a triangle with ! beside the dell utility drive. Is the problem related to this in any way?
why is linux even having a look at that partition if i contained mint to sda3-6?
Anyone with suggestions?


Re: Boot Error

Postby dimx2 » Thu Apr 03, 2008 6:48 am

i have the same error :(

Return to “Installation & Boot”