Page 1 of 1

Outsmarting Grub2 . . .

Posted: Fri Jan 14, 2011 8:32 pm
by wwoof
Ok, I used Mint 6 for quite a while until I read about LMDE. I liked the rolling update idea so I got the 201009 disk (disk 1 for x86) and loaded her up. Everything, including Grub, worked fine. Then the 12/24/10 release came along and I spent several hours watching my box download the 'new stuff'. When it had completed Grub still worked. Yeah.

I got the hair for an SSD and bought one and ordered the 201012 release on disk (64 bit version) in order to load up the new release quickly and thoroughly. Once I did this Grub no longer worked correctly by the fact it no longer saw XP when it booted up my box. I made some efforts to try to rectify this on chatbox and got really bogged down and may have made some mistakes myself in trying to fix Grub. It ended badly with me having to reformat the SSD and reload XP.

Now, I an using XP and, once again, want to dual boot to LMDE. I am thinking of using the 201009 disk instead of the 201012 disk so as to be able to load a version of Grub that was working. I am willing to sit for hours through the endless updates that will follow. :(

1. When running Gparted should the existing Windos partition always remain root and boot?
2. When asked, Grub should be loaded to the root and boot partition?
3. Is there a chance that the streaming updates will, once again, go blind to my XP?

Please provide plain speaking answers to my non-digital brain. Thanks. :shock:

Re: Outsmarting Grub2 . . .

Posted: Mon Jan 17, 2011 12:52 am
by wwoof
Not ONE suggestion from you pro's? What is this? :?

Well, for giggles I decided to go the with latest disk instead of the first. So, I started the install and noticed that NFS was the root so I made it boot and installed it to that partition. Afte rall, XP was laid down first. When it came to the question of "do you remember which partition was boot" I selected both. Then it asked if I wanted to used "legacy" or migrate to the "dependency" driven grub. There was no Hell No response available so I selected no. It worked.

Not sure what I did the first time but I figure I put the root and boot in Linux and it just didn't work or I didn't know how to make it work.

After a few hours of surfing I noticed my front USB ports weren't working. I powered down and tried to boot back up and Mint wouldn't do it. It went into an endless cycle of black screens telling me port 5 and 6 weren't responding. I killed the power and got back to XP which kept telling me I had a USB malfunction and to load a driver. Well, after playing around for a while I finally got out my driver disk for the box and placed it in the dvd, turned it off, and cranked back up. WAH LAH, everything was working and Mint came right up.

Lots of mysterious, ghost in the machine stuff going on.

Glad you guys could be of help. :lol: