I get these errors in compatibility mode

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
x0fx3
Level 1
Level 1
Posts: 18
Joined: Tue Feb 09, 2010 12:23 pm

I get these errors in compatibility mode

Post by x0fx3 »

What can I do to fix these.

(EE) VESA: Kernel modesetting driver in use, refusing to load
(EE) No devices detected.

There was another error below those but the pic I took was bad and forgot what is was but I think it was about no display. My monitor is hooked up via hdmi to dvi cable.

Any help would be appreciated, thanks.
Attachments
IMAG0191.jpg
IMAG0191.jpg (287.91 KiB) Viewed 695 times
dawgdoc
Level 9
Level 9
Posts: 2743
Joined: Mon Oct 05, 2009 12:53 am
Location: Formerly of Kentucky, the land of Mint Juleps

Re: I get these errors in compatibility mode

Post by dawgdoc »

If you are using LM 9/Isadora or possibly LMDE, you may be having trouble with kernel modesetting.

If you are using LMDE, check HERE.
If you are using LM 9, check HERE.

Looking closer at your screenshot, based on the kernel version I guess you are using LM 10. I have not really heard of nomodeset being a problem with Julia. Give it a try, nomodeset turns off kernel modesetting, KMS.

What I haven't a clue about is how HDMI plays into the matter.
SYSTEMS:
HP 15-bw0017cl -- Mint 19.3 Cinnamon
Compaq Presario CQ62 -- Mint 17 Cinnamon (support for 80 y/o family members 1st install)
READING:
The Secret of the Ninth Planet by Donald A. Wollheim
x0fx3
Level 1
Level 1
Posts: 18
Joined: Tue Feb 09, 2010 12:23 pm

Re: I get these errors in compatibility mode

Post by x0fx3 »

Yeah I should of put in more details. I'm using the LM 10 x64 dvd. My HDD and BD ODD are both sata, Graphics card is EVGA GeForce 240. The other error I had was "Fatal server error: no screens found" But I'll try changing the setting that you mention.
x0fx3
Level 1
Level 1
Posts: 18
Joined: Tue Feb 09, 2010 12:23 pm

Re: I get these errors in compatibility mode

Post by x0fx3 »

dawgdoc wrote:If you are using LM 9/Isadora or possibly LMDE, you may be having trouble with kernel modesetting.

If you are using LMDE, check HERE.
If you are using LM 9, check HERE.

Looking closer at your screenshot, based on the kernel version I guess you are using LM 10. I have not really heard of nomodeset being a problem with Julia. Give it a try, nomodeset turns off kernel modesetting, KMS.

What I haven't a clue about is how HDMI plays into the matter.

I tried nomodeset and that didn't work. I'm gonna try googling again for answers.
RavanH
Level 2
Level 2
Posts: 53
Joined: Sun Jan 17, 2010 6:24 am

Re: I get these errors in compatibility mode

Post by RavanH »

x0fx3 wrote:
dawgdoc wrote:If you are using LM 9/Isadora or possibly LMDE, you may be having trouble with kernel modesetting.

If you are using LMDE, check HERE.
If you are using LM 9, check HERE.

Looking closer at your screenshot, based on the kernel version I guess you are using LM 10. I have not really heard of nomodeset being a problem with Julia. Give it a try, nomodeset turns off kernel modesetting, KMS.

What I haven't a clue about is how HDMI plays into the matter.

I tried nomodeset and that didn't work. I'm gonna try googling again for answers.
Did you ever find a solution? I have lost my gdm login screen on my 32bit laptop (with only the integrated screen, nothing fancy) and after Ctrl+Alt+F1 > login > startx , I'm seeing the same message :(

EDIT: I spoke too soon... adding the boot option "nomodeset" did work after all, even though we are talking Mint 10 Julia here. I wonder why this is needed since my upgrade, while in Mint 9 it was not necessary.

Anyway, thanks dawgdog! :)
Post Reply

Return to “Installation & Boot”