Grub menu does not automatically launch an OS

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
travlemon
Level 2
Level 2
Posts: 54
Joined: Fri Mar 05, 2010 2:18 pm

Grub menu does not automatically launch an OS

Post by travlemon » Wed Mar 02, 2011 11:00 pm

Hello,

I've had Mint 10 on my laptop for about 2 weeks now. Everything's been great so far! Only have really one issue that came up just hours before I decided to post this.

When I installed Mint 10, I used the entire drive, and have no other operating systems installed. When installed, it didn't give me a grub screen when it booted up. It simply just booted directly into the OS automatically. As of just a few hours ago, it now shows a grub menu to choose an OS (which I don't mind), but there's no timeout.

It doesn't countdown 10 seconds before automatically launching a default choice. It just sits there infinitely, until I choose an OS manually. From the Mint 10 OS, I tried going to System>Administration>Startup Manager, and changing the timeout to 9 seconds, hoping it would rewrite the config and clear the issue.

No go! The only thing I can think of that caused this is that there were some system updates today.

Anyone have any ideas on how I can get it to start automatically booting again? Any help is much appreciated!
For my video tutorials, check out:
http://www.youtube.com/webhunterification

travlemon
Level 2
Level 2
Posts: 54
Joined: Fri Mar 05, 2010 2:18 pm

Re: Grub menu does not automatically launch an OS

Post by travlemon » Thu Mar 03, 2011 5:21 pm

Ok this fix was a lot simpler than I thought. For anyone else out there with this problem, or similar GRUB issues, here was the solution:

I simply rename the file /boot/grub/grub.cfg to /boot/grub/grub.OLD. I then ran

Code: Select all

sudo update-grub
to generate a new grub.cfg file. *POOF!!!* It magically works now. The old grub.cfg file must have somehow gotten a bad line written to it.
For my video tutorials, check out:
http://www.youtube.com/webhunterification

Post Reply

Return to “Installation & Boot”