computer does not detect Hard drive

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
TangoVirtud
Level 1
Level 1
Posts: 26
Joined: Sun May 22, 2011 8:57 am

computer does not detect Hard drive

Post by TangoVirtud » Fri Jul 08, 2011 5:58 am

Hi kids.

Well..., I was a bit angered at the whole fact that Linux mint had an untable grub. My computer would repeatedly freee and then I had to remount aeverything, or use super grub, or reinstall it all from synaptic. But last time, things changed.
Now, my computer does not see my only hard drive, so... I cannot mount it or anything of the kind.
I-m a bit frustrated. I did everything to mount it, I used supergrub, I also tried some other things, and now I-m writing from the booting pen drive but I cannot reinstall anything for my computer only sees the pen drive and calls it sda1
what could have happened and what can I do?
I even updated bios, but things didn-t change. Please, help me.

AOA110 aw
512 Mb ram
8Gb HD
linux mint lxde

Thanks in advance

sergio

Image

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: computer does not detect Hard drive

Post by AlbertP » Fri Jul 08, 2011 6:00 am

Are you dual-booting with Windows 7 on this computer? It's a known 'feature' of Windows 7 to destroy Grub.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

SimonTS
Level 6
Level 6
Posts: 1270
Joined: Thu Feb 24, 2011 5:19 pm
Location: Bristol, United Kingdom

Re: computer does not detect Hard drive

Post by SimonTS » Fri Jul 08, 2011 6:43 am

My first question would be - are those specs you quoted correct? An 8Gig hard-drive?

As you are able to boot from the Live image, can you please open a terminal window and post the outputs of;-

Code: Select all

sudo fdisk -l
sudo parted -l
lspci

itsme4401
Level 3
Level 3
Posts: 168
Joined: Sat Nov 27, 2010 4:12 pm
Location: Netherlands

Re: computer does not detect Hard drive

Post by itsme4401 » Fri Jul 08, 2011 9:40 am

y first question would be - are those specs you quoted correct? An 8Gig hard-drive?
Seems to be correct:
http://www.notebookcheck.net/Short-Revi ... 014.0.html, paragraph -2.

SimonTS
Level 6
Level 6
Posts: 1270
Joined: Thu Feb 24, 2011 5:19 pm
Location: Bristol, United Kingdom

Re: computer does not detect Hard drive

Post by SimonTS » Fri Jul 08, 2011 10:34 am

Thanks - I didn't think to check the product code the OP posted. That means it doesn't actually have a hard-drive at all - it is an 8GB flash drive, which is a different beast.

It would still be useful to see the results of the commands I posted as they should, hopefully, tell us if Mint is actually seeing the drive at all. I guess the other thing is whether the drive is shown in the BIOS (I assume it can do an auto-detect) or whether it is listed correctly on the BIOS spalsh-screen at boot-up.

TangoVirtud
Level 1
Level 1
Posts: 26
Joined: Sun May 22, 2011 8:57 am

Re: computer does not detect Hard drive

Post by TangoVirtud » Fri Jul 08, 2011 10:54 am

AlbertP wrote:Are you dual-booting with Windows 7 on this computer? It's a known 'feature' of Windows 7 to destroy Grub.
Thankyou, Albert. Nope. Just linuxmint 10 lxde there. It came with ubuntu and it was slow, so I finally installed this one, which was faster in spite of these grub problems.

TangoVirtud
Level 1
Level 1
Posts: 26
Joined: Sun May 22, 2011 8:57 am

Re: computer does not detect Hard drive

Post by TangoVirtud » Fri Jul 08, 2011 11:04 am

SimonTS wrote:My first question would be - are those specs you quoted correct? An 8Gig hard-drive?

As you are able to boot from the Live image, can you please open a terminal window and post the outputs of;-

Code: Select all

sudo fdisk -l
sudo parted -l
lspci
Yes, Simon, and thanks to you too, it is a flash drive. I've got another computer just like this one... in blue. Not bios nor LM10 seem to detect the drive at all. When I press F2 to set, Id0: is displayed empty. If I don't press it at all, it gives me the option to boot from legacy through internet, when I connected it, it said sth like mac address> 00 07 p7 g7 sth like this, but in the end no file was downloaded and asked me to press any key to boot from cd. The pen drive is the only one working through the unetbooting menu.
To the formats you suggest, these are the responses:

mint ~ # sudo fdisk -l

Disk /dev/sda: 8015 MB, 8015282176 bytes
247 heads, 62 sectors/track, 1022 cylinders
Units = cylinders of 15314 * 512 = 7840768 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x06e858c3

Device Boot Start End Blocks Id System
/dev/sda1 * 1 1022 7825423 b W95 FAT32


mint ~ # sudo parted -l
Model: Kingston DataTraveler 2.0 (scsi)
Disk /dev/sda: 8015MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 31.7kB 8013MB 8013MB primary fat32 boot


mint ~ # lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
04:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
04:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
04:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
04:00.4 System peripheral: JMicron Technology Corp. xD Host Controller


Thank you again, Simon. Do you see any light ahead?

Sergio
:(

SimonTS
Level 6
Level 6
Posts: 1270
Joined: Thu Feb 24, 2011 5:19 pm
Location: Bristol, United Kingdom

Re: computer does not detect Hard drive

Post by SimonTS » Fri Jul 08, 2011 11:18 am

Well, it's definitely not seeing the flash drive, but it does appear to be seeing the SATA controller. I don't know if this is possible, so I will ask.
1) What happens if you try booting the Mint LiveUSB on the other identical machine? Does it see the flash drive or not?
2) Can you take the flash drive from the non-working machine, put it into the other machine and test it out - see if we can identify where the fault lies?
3) Can you take the flash drive form the working machine and put it into the non-working one?

All these just to try and pinpoint where, precisely, the problem lies.

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: computer does not detect Hard drive

Post by AlbertP » Fri Jul 08, 2011 11:23 am

Make sure the flash drive has not died.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

TangoVirtud
Level 1
Level 1
Posts: 26
Joined: Sun May 22, 2011 8:57 am

Re: computer does not detect Hard drive

Post by TangoVirtud » Mon Jul 11, 2011 2:08 pm

AlbertP wrote:Make sure the flash drive has not died.
It has not. The computer has just boot as if it was brand new:

Disco /dev/sda: 8069 MB, 8069677056 byte
255 testine, 63 settori/tracce, 981 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x0009e19a

Dispositivo Boot Start End Blocks Id System
/dev/sda1 * 1 933 7490560 83 Linux
La partizione 1 non termina al limite del cilindro.
/dev/sda2 933 981 387073 5 Esteso
La partizione 2 non termina al limite del cilindro.
/dev/sda5 933 981 387072 82 Linux swap / Solaris


sergio@TangoVirtud ~ $ sudo parted -l
Modello: ATA SSDPAMM0008G1 (scsi)
Disco /dev/sda: 8070MB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos

Numero Inizio Fine Dimensione Tipo File system Flag
1 1049kB 7671MB 7670MB primary ext4 avvio
2 7672MB 8069MB 396MB extended
5 7672MB 8069MB 396MB logical linux-swap(v1)


sergio@TangoVirtud ~ $ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
04:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
04:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
04:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
04:00.4 System peripheral: JMicron Technology Corp. xD Host Controller


What do you think?

TangoVirtud
Level 1
Level 1
Posts: 26
Joined: Sun May 22, 2011 8:57 am

Re: computer does not detect Hard drive

Post by TangoVirtud » Wed Jul 13, 2011 8:06 am

Now it's running well. Do you think it could be some false contact of my flash drive?

SimonTS
Level 6
Level 6
Posts: 1270
Joined: Thu Feb 24, 2011 5:19 pm
Location: Bristol, United Kingdom

Re: computer does not detect Hard drive

Post by SimonTS » Wed Jul 13, 2011 8:34 am

If it is working fine now then I wouldn't worry too much. It is entirely possible that you had a loose connection that you have resolved by messing around with the hardware.

TangoVirtud
Level 1
Level 1
Posts: 26
Joined: Sun May 22, 2011 8:57 am

Re: computer does not detect Hard drive

Post by TangoVirtud » Thu Jul 14, 2011 5:36 am

SimonTS wrote:If it is working fine now then I wouldn't worry too much. It is entirely possible that you had a loose connection that you have resolved by messing around with the hardware.
Thank you, Simon. I'll be back here if it messes up again.
Thanks!

Post Reply

Return to “Installation & Boot”