GRUB screen does not display on boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
lindsey
Level 1
Level 1
Posts: 24
Joined: Tue Sep 20, 2011 1:53 am

GRUB screen does not display on boot

Post by lindsey »

GRUB screen does not display on boot, BIOS info is followed by a blank screen with some monitor input complaint* then the next thing that displays is the login screen.

The problem is I need GRUB to display for what I want to do.

Granted Linux Mint 11 32-bit is my only OS on this computer, I can understand if the GRUB screen is not enabled, since there is no choice to be made.

However, Unetbootin has been executed on my HDD and so a new entry has been added to the GRUB screen which will allow me to do a frugal install of another OS.

If GRUB screen doesn't display on boot, i cannot access this new GRUB entry.

Ideas?

*I'm not sure if this display input complaint is relevant or not so I just included a screenshot - see attached.
Attachments
disp_input_error.png
disp_input_error.png (105.66 KiB) Viewed 1271 times

User avatar
xenopeek
Level 24
Level 24
Posts: 24279
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: GRUB screen does not display on boot

Post by xenopeek »

Login, then open a terminal and run:

Code: Select all

gksudo gedit /etc/default/grub
Uncomment the following line (remove the # in front of it):

Code: Select all

#GRUB_TERMINAL=console
Save & close the file. Then run:

Code: Select all

sudo update-grub2
I think this may resolve your problem. By default GRUB tries to load a graphical mode (for whatever convoluted reason), and with the above you change it back to just use 80x25 text mode. That should hopefully work fine. Otherwise, there is also an option to change the graphical mode resolution used, but I think this will solve it.

If GRUB doesn't automatically show, comment the next two lines (put a # in front of them):

Code: Select all

GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
And change the value on the following line to whatever timeout you want (the GRUB menu will be shown for that many seconds, and close again unless you press a key). I suggest setting it to 5 or 10:

Code: Select all

GRUB_TIMEOUT=0
Image

lindsey
Level 1
Level 1
Posts: 24
Joined: Tue Sep 20, 2011 1:53 am

Re: GRUB screen does not display on boot

Post by lindsey »

lol - I wanted to try your solution but I got impatient waiting for an answer and started uncommenting and changing the resolution in the grub.cfg file, and changing one of the timeout values. I cannot be sure what happened but now my desktop environment will not display... I just get a black screen - can't even go into my desktop terminal to edit my cfg. file because everything is just black...

The same happens with liveCDs though, so I don't know if it was a result of modifying the grub.cfg file or something else...

Once I fix this up, I can try your solution. Any ideas on how I can get my desktop back?

The error pictured in the OP might be relevant...

Post Reply

Return to “Installation & Boot”