Sudo and Gnome desktop not working

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Arcosanti
Level 1
Level 1
Posts: 39
Joined: Mon Jul 04, 2011 9:46 am

Sudo and Gnome desktop not working

Post by Arcosanti »

A couple of weekends ago I was trying to find out why a windows program that was working under wine had stopped working all of a sudden. While I was in the middle of doing that, I discovered that the sudo command was no longer working. When trying to use it a couple of errors would be displayed. They are permission denied and no valid sudoers file is present. S I stopped working on the wine issue and started looking into this. Everything I found on the net indicated that the sudo command should be working. All of the permissions were set correctly for /etc/sudoers and sudo itself. The sudoers file was a bit different than what was shown on the net. The difference was that (all) was (all:all) in my sudoers file. The sudoers files that were shown on the net appear to be for older ubuntu distribution releases which probably explains the difference. So anyway I have no idea as to why the command stopped working all of a sudden. The su command on the other hand is still working, so I ended up using it in place of sudo for the time being in trying to figure out what was wrong with the Windows program under wine. I decided to change window managers from Metacity back to the original Compiz to see if that was the problem, although I am not sure how a window manager could cause issues with wine. I originally changed from Compiz to Metacity to see if that would resolve some sluggishness problems I was having under Gnome desktop. After changing back to Compiz, I decided to do a reboot and test the Windows program from there. Instead I got the black screen of death upon reboot. No Graphical login at all. I am able to switch over to the text console and login from there with no problem. Using su I am able to kill the Xwin processes and then exit out of root. Then I can start up Xwin with the xstart command were I am put in a slightly crippled Gnome desktop.

So does anyone know of a way to fix these two problems? I'll see what I can do to get the necessary files and settings displayed here in this forum as needed to diagnose this problem. I am working in XP at the moment.

User avatar
gn2
Level 5
Level 5
Posts: 885
Joined: Mon Nov 30, 2009 5:54 am
Location: Bonnie Scotland

Re: Sudo and Gnome desktop not working

Post by gn2 »

No idea if it will work, but I would suggest purging Wine and re-installing sudo.

Arcosanti
Level 1
Level 1
Posts: 39
Joined: Mon Jul 04, 2011 9:46 am

Re: Sudo and Gnome desktop not working

Post by Arcosanti »

I tried to reinstall sudo. That had no effect. I found a log file that was telling me why my gnome desktop was not coming up. GDM was apparently hanging with a black screen as dbus-launch and gnome-sessions was not executing from permissions denied. I checked the permission on those files, and they are set correctly. I decided that my system installation is borked and tried to reinstall Katya on top of the old installation. It didn't solve the problem and now I can't login either. I guess I am going to have to do a clean reinstallation at this point.

Post Reply

Return to “Installation & Boot”