[SOLVED] Installation of BURG failed before completion

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Jim Mac
Level 1
Level 1
Posts: 8
Joined: Sun Nov 20, 2011 10:03 pm

[SOLVED] Installation of BURG failed before completion

Postby Jim Mac » Tue Nov 22, 2011 12:25 am

[SOLVED]
I formatted and re-installed Mint 11.

I am relatively new to Linux.
I have just installed a dual boot Linux 11 and Windows 7 system for the first time.
It's working fine.
I wanted to install BURG for the more attractive boot interface.
During installation it locked due to the darn touch-pad and apparently didn't complete the installation correctly.
I have tried to re-initiate the installation with no luck and then tried:
"sudo update-burg" (from a Google search)
with the following result:
"Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information."
Maybe I can figure it out but.....I'm still a little uncomfortable (afraid) of scripts without a little guidance.
I think the update would let me edit the script (if it worked)......but the last part was supposed to generate something to "ok".
I don't know.
Could someone help please?
Last edited by Jim Mac on Tue Nov 29, 2011 2:46 pm, edited 1 time in total.

User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4595
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: Installation of BURG failed before completion - Need hel

Postby Aging Technogeek » Tue Nov 22, 2011 2:50 am

All you will ever need to know about Grub:

https://help.ubuntu.com/community/Grub2
Registered Linux User 483387

User avatar
Roken
Level 5
Level 5
Posts: 740
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK
Contact:

Re: Installation of BURG failed before completion - Need hel

Postby Roken » Tue Nov 22, 2011 8:35 am

How are you trying to install burg? By far the easiest way is to use the ppa. To do so, open a terminal and type:

Code: Select all

sudo gedit /etc/apt/sources.list


Then look for the following lines in the text file that opens. If they are not there, add them at the end:

Code: Select all

deb http://ppa.launchpad.net/bean123ch/burg/ubuntu maverick main
deb-src http://ppa.launchpad.net/bean123ch/burg/ubuntu maverick main


Then save and close. You will need the gpg key, so download http://keyserver.ubuntu.com:11371/pks/l ... 1EE06803C5 to your desktop and open synaptic. In synaptic go to the Settings/Repositories menu, in the new window click the Authentication tab and click the "Import Key File" button. Navigate to the file you just downloaded in the file requester and select it. Then close the settings window, and click the reload button. Look for burg and select it to install. If it says installed, right click and re-install. While it's installing expand the drop down in the progress window so that you can see what's happening, and at the end it should show that update-burg is run and will list the found operating systems. If all goes well, then you are good to go.

NB. Although the use of PPAs is not recommended, this works just fine on LMDE, too.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image

KilUma
Level 2
Level 2
Posts: 93
Joined: Sat Feb 12, 2011 9:08 pm

Re: [SOLVED] Installation of BURG failed before completion

Postby KilUma » Tue Mar 26, 2013 7:02 pm

I realize this is a rather old post, but it's the closest thing I could find. I'm running grub-customizer in LM14KDE64. I can modify GrUB to my hearts content, but I can't get burg to install properly. My burg.cfg file is missing(I've searched, and it's not anywhere on this system).

I realize the burg.cfg is most likely auto-generated, but I can't figure out how to trigger that generation. Burg is installed, it's just not installed correctly.

The following is the error I get after being prompted to modify burg:

Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.

I checked into the:

Code: Select all

burg-probe --help


This led me to try the following:

Code: Select all

burg-probe -d /dev/sda5

Which gave me the following output:

Code: Select all

burg-probe: error: cannot find a GRUB drive for /dev/sda5.  Check your device.map

I searched for device.map, and came up empty handed. Any guidance would be greatly appreciated.
Toshiba Satellite A305-A6858; Intel Core 2Duo CPU T5750 @ 2.0GHz; 4G ddr3; Intel Mobile GM965/GL960 Integrated Graphics; External 1TB with Mint17.2KDE; Internal 250GB with Mint17.3MATE.

KilUma
Level 2
Level 2
Posts: 93
Joined: Sat Feb 12, 2011 9:08 pm

Re: [SOLVED] Installation of BURG failed before completion

Postby KilUma » Sun Mar 31, 2013 11:08 pm

Excuse me while I bump this topic.
Toshiba Satellite A305-A6858; Intel Core 2Duo CPU T5750 @ 2.0GHz; 4G ddr3; Intel Mobile GM965/GL960 Integrated Graphics; External 1TB with Mint17.2KDE; Internal 250GB with Mint17.3MATE.

User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4595
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: [SOLVED] Installation of BURG failed before completion

Postby Aging Technogeek » Sun Jul 21, 2013 12:54 pm

Burg does not currently have a 64 bit compatible version. What I have been doing is installing a 32 bit, Ubuntu based OS just to host burg and designating a default 64 bit OS by editing /etc/default/burg.
Registered Linux User 483387


Return to “Installation & Boot”

Who is online

Users browsing this forum: bilbander and 3 guests