No dual boot menu - SOLVED!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Surp
Level 1
Level 1
Posts: 8
Joined: Mon Dec 12, 2011 2:07 am

No dual boot menu - SOLVED!

Post by Surp »

I've installed Linux Mint 12 alongside Windows XP but I don't get a dual boot menu when I reboot the computer. Windows XP starts as if there is no other OS installed.
Any ideas, please?
Last edited by Surp on Thu Dec 15, 2011 9:16 am, edited 1 time in total.
wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: No dual boot menu

Post by wayne128 »

May be you have not install grub on MBR?
Surp
Level 1
Level 1
Posts: 8
Joined: Mon Dec 12, 2011 2:07 am

Re: No dual boot menu

Post by Surp »

I selected the option to make a dual boot system during the install of Linux Mint so I supposed this automatically generate a boot menu.
Being a complete Linux novice, can you help me with instructions on how to install this grub on my mbr, please?
wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: No dual boot menu

Post by wayne128 »

Boot computer with Mint CD/DVD.
Run Live.

Open a terminal,
Just two commands:

1. Mount Mint partition by
sudo mount /dev/sdaX /mnt , replace X by your actual root partition of Mint installation

2. Assuming you have only one internal hard disk, reinstall grub to hard disk's MBR by
sudo grub-install --root-directory=/mnt /dev/sda

3. Watch its display on terminal, it should probe the hard disk for all OSes, and find Mint as well as Win.

4. If you want to know where are the OS it find, type this command
sudo os-prober
Surp
Level 1
Level 1
Posts: 8
Joined: Mon Dec 12, 2011 2:07 am

Re: No dual boot menu

Post by Surp »

Thanks for your support. Please find the result of these commands below.

mint@mint ~ $ sudo os-prober
/dev/sda2:Microsoft Windows XP Home Edition:Windows:chain
/dev/sda5:Linux Mint 12 Lisa (12):LinuxMint:linux
mint@mint ~ $ sudo mount /dev/sda5 /mnt
mint@mint ~ $ sudo grub-install --root-directory=/mnt /dev/sda
grub-probe: error: cannot find a device for /boot (is /dev mounted?).
/usr/sbin/grub-setup: warn: Sector 32 is already in use by FlexNet; avoiding it. This software may cause boot or other problems in future. Please ask its authors not to store data in the boot track.
Installation finished. No error reported.
mint@mint ~ $

As you probably can guess, the dual boot menu is still missing...
AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: No dual boot menu

Post by AlbertP »

Please open Startup Manager from the menu.

The time-out of 10 seconds sometimes does not work. Usually setting it to 9 or 11 will fix it.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
Surp
Level 1
Level 1
Posts: 8
Joined: Mon Dec 12, 2011 2:07 am

Re: No dual boot menu

Post by Surp »

Now I have the dual boot menu! Thank you very much for the great support.
Hopefully I can finaly discard Windows all together.
AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: No dual boot menu

Post by AlbertP »

Now that you got it working, you should be able to set the time-out to 10 seconds again if you wish. Worked fine at me.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
seanducati
Level 1
Level 1
Posts: 5
Joined: Tue Dec 13, 2011 11:45 am

Re: No dual boot menu

Post by seanducati »

I'm having the same problem as this poster. I tried to dual boot and now I can't get grub loader to come on upon boot up.
When I type in the command you were referring too....

sudo mount /dev/sda1 mnt

I get mount point mnt does not exist.
seanducati
Level 1
Level 1
Posts: 5
Joined: Tue Dec 13, 2011 11:45 am

Re: No dual boot menu

Post by seanducati »

ok, I got a little farther.....this is what the screen says...

______________________________________________________________________________________________

jason@jason-VGN-NW225F ~ $ sudo grub-install --root-directory=/mnt /dwv sda1
More than one install_devices?
Usage: grub-install.real [OPTION] install_device
Install GRUB on your drive.

-h, --help
-v, --version
--modules=MODULES
--boot-directory=DIR

--grub-setup=FILE
--grub-mkimage=FILE
--grub-mkdevicemap=FILE
--grub-probe=FILE
--no-floppy
--allow-floppy

--recheck
--force
--disk-module=MODULE

INSTALL_DEVICE can be a GRUB device name or a system device filename.

grub-install.real copies GRUB images into /boot/grub, and uses grub-setup
to install grub into the boot sector.

Report bugs to <bug-grub@gnu.org>.
jason@jason-VGN-NW225F ~ $
AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: No dual boot menu

Post by AlbertP »

Code: Select all

/dwv sda1
It has to be:

Code: Select all

/dev/sda
without a space between /dev and /sda.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
Post Reply

Return to “Installation & Boot”