Mint 12 RAID 0 DMI Pool verification "system halt"

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
jameslinuxmint
Level 1
Level 1
Posts: 1
Joined: Sun Jan 29, 2012 9:59 pm

Re: Mint 12 RAID 0 DMI Pool verification "system halt"

Post by jameslinuxmint »

First of all,

Thanks jack_

I just ran through this using linuxmint-12-kde-dvd-32bit-rc.iso on a bios (not EFI) motherboard using gpt partitioning.

I thought I'd update what I had to do to get this installed.

when running through the grup-setup I ran into an error like:

grub-setup warn this gpt partition label has no bios boot partition

Apparently a second 2MiB unformatted partition (EF02 or bios_grub flag) set needs to be created to put the BIOS Boot Partition core.img

Once I redid install I was able to grub-setup as above with no errors.

Anyway thanks again.
jack_
Level 1
Level 1
Posts: 22
Joined: Mon Dec 19, 2011 8:36 pm
Location: Poland

Re: Mint 12 RAID 0 DMI Pool verification "system halt"

Post by jack_ »

You are right.
Partition with bios_grub flag on is needed on BIOS systems to BOOT from GPT partition table.
You can use that 1MiB in front - that what you've leaved for front aligning.

http://en.wikipedia.org/wiki/BIOS_Boot_partition

I have to correct my tutorial.
invisiblewave
Level 1
Level 1
Posts: 3
Joined: Thu Dec 14, 2017 5:29 pm

Re: Mint 12 RAID 0 DMI Pool verification "system halt"

Post by invisiblewave »

I might be a bit late to show my appreciation, but THANKS! I've lost count of the number of RAID installation guides I've followed, and this is the first one I've found that works. It was a sad day when Ubuntu decided to drop RAID support from Ubiquity, particularly when the decision was accompanied by a statement which talked about the relatively trivial task of converting to RAID after installation......

Anyway, the other reason for my post was to add a little to this excellent guide:
My goal was RAID1, with mirrored 2TB drives. I partitioned the drives with a small GRUB primary partition, then four logical partitions inside the extended partition, for /boot, /, /home & swap. I couldn't get it to work with either GRUB or SWAP as part of the array, so I ended up with three RAID partitions.
Working from the Mint installation disk, I used GParted to do the partitioning, setting the ESP flag on the GRUB partition and the BOOT flag on the /boot partition.
The process did NOT work if I ran the installer to completion, because /target was no longer complete, when I tried to mount I got an error about bash missing. The solution was to just leave the installer open when it crashed on the GRUB error.
By setting the ESP flag on the GRUB partition, and by leaving the installer "open", the whole process worked perfectly.
Last edited by karlchen on Thu Dec 14, 2017 5:46 pm, edited 1 time in total.
Reason: As this thread was about Mint 12 and had been 5 years old: locking this outdated thread
Locked

Return to “Installation & Boot”