Virtual Box Install Error?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Akacheebe
Level 1
Level 1
Posts: 49
Joined: Tue Jul 01, 2014 5:03 pm

Virtual Box Install Error?

Post by Akacheebe » Fri Feb 09, 2018 1:39 pm

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Keep seeing this each time I do updates/upgrades. Online search and search in here didn't give me much so can someone tell me why this is happening since it's doing this on multiple systems that I have running here at home?

Linux Mint 17.3 upgraded to the 4.4.0-112 kernel.

User avatar
WharfRat
Level 20
Level 20
Posts: 11834
Joined: Thu Apr 07, 2011 8:15 pm

Re: Virtual Box Install Error?

Post by WharfRat » Fri Feb 09, 2018 1:52 pm

Akacheebe wrote:
Fri Feb 09, 2018 1:39 pm

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Keep seeing this each time I do updates/upgrades. Online search and search in here didn't give me much so can someone tell me why this is happening since it's doing this on multiple systems that I have running here at home?

Linux Mint 17.3 upgraded to the 4.4.0-112 kernel.
If you didn't place those packages on hold you probably have to use apt dist-upgrade
ImageImage

Akacheebe
Level 1
Level 1
Posts: 49
Joined: Tue Jul 01, 2014 5:03 pm

Re: Virtual Box Install Error?

Post by Akacheebe » Fri Feb 09, 2018 7:18 pm

WharfRat wrote:
Fri Feb 09, 2018 1:52 pm
If you didn't place those packages on hold you probably have to use apt dist-upgrade
No, I didn't "place them on hold"?? I don't have "virtual box" installed on any of my systems that I know of?

So what does "dist-upgrade" do?

User avatar
WharfRat
Level 20
Level 20
Posts: 11834
Joined: Thu Apr 07, 2011 8:15 pm

Re: Virtual Box Install Error?

Post by WharfRat » Fri Feb 09, 2018 7:34 pm

The explanation is in man apt-get

I recall that dist-upgrade was needed with 17.3 when upgrading kernels.

Those packages look like they're for a virtual box hosted Mint installation.

If you're not running in VB then they are unnecessary.
ImageImage

Post Reply

Return to “Software & Applications”