Need help to talk a friend thru installing HP Deskjet 3512 scanner

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
AZgl1500
Level 10
Level 10
Posts: 3389
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Need help to talk a friend thru installing HP Deskjet 3512 scanner

Post by AZgl1500 » Sun Jun 09, 2019 3:49 pm

I found this link https://www.hamrick.com/download.html

which gives me a .tgz file, double clicking that will let her get to the Extract Button.

now what do I tell her?

I'm no good with .tgz files.

HAWR
Level 1
Level 1
Posts: 25
Joined: Thu Jun 06, 2019 1:15 pm

Re: Need help to talk a friend thru installing HP Deskjet 3512 scanner

Post by HAWR » Sun Jun 09, 2019 4:27 pm

Here you can download the driver for the mentioned HP-printer/scanner. On the left side you find the install instruction:

https://developers.hp.com/hp-linux-imag ... g/gethplip

User avatar
AZgl1500
Level 10
Level 10
Posts: 3389
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Need help to talk a friend thru installing HP Deskjet 3512 scanner

Post by AZgl1500 » Sun Jun 09, 2019 4:47 pm

HAWR wrote:
Sun Jun 09, 2019 4:27 pm
Here you can download the driver for the mentioned HP-printer/scanner. On the left side you find the install instruction:

https://developers.hp.com/hp-linux-imag ... g/gethplip
Tnx,
she is a tax accountant, and I put 18.3 Cinnamon on her PC because the M$ system kept crashing with blue screens. so far, she is pleased at the lack of problems.

hope she is able to follow the instructions.

HAWR
Level 1
Level 1
Posts: 25
Joined: Thu Jun 06, 2019 1:15 pm

Re: Need help to talk a friend thru installing HP Deskjet 3512 scanner

Post by HAWR » Mon Jun 10, 2019 6:56 am

And, did it work? I've seen, that hplip 3.16.3 ist implemented in LM 18.3 by default. Because the printer is an older model, LM 18.3 would have to recognize the printer by itself, too, respectively it could be installed in the printer dialogue in the menue without installing another driver.

User avatar
AZgl1500
Level 10
Level 10
Posts: 3389
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Need help to talk a friend thru installing HP Deskjet 3512 scanner

Post by AZgl1500 » Tue Jun 11, 2019 3:54 am

HAWR wrote:
Mon Jun 10, 2019 6:56 am
And, did it work? I've seen, that hplip 3.16.3 ist implemented in LM 18.3 by default. Because the printer is an older model, LM 18.3 would have to recognize the printer by itself, too, respectively it could be installed in the printer dialogue in the menue without installing another driver.
When I was at their house a year ago, it immediately recognized the printer.
But, she forgot to tell me that she uses the scanner as an input device, and I did not even discuss that with her.

I gave her the info, but she said she was too tired to look at it, and have not heard back.

it is a 5 hour drive to their house, so I won't be going over anytime soon.
Might do that though come Labor Day weekend, as I will be very close to their home for a Motorcycle Rally in Harrison, AR and they live in Cabot, AR on the road going back home.

User avatar
jimallyn
Level 18
Level 18
Posts: 8894
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Need help to talk a friend thru installing HP Deskjet 3512 scanner

Post by jimallyn » Tue Jun 11, 2019 9:28 pm

That printer requires HPLIP 3.12.9 or newer, and Mint 18.3 comes with HPLIP 3.16.3, so there should be no need to install HPLIP. Has your friend actually tried scanning? I think 18.3 comes with SimpleScan, but I prefer xsane, so I always install that.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

User avatar
AZgl1500
Level 10
Level 10
Posts: 3389
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Need help to talk a friend thru installing HP Deskjet 3512 scanner

Post by AZgl1500 » Wed Jun 12, 2019 2:37 am

jimallyn wrote:
Tue Jun 11, 2019 9:28 pm
That printer requires HPLIP 3.12.9 or newer, and Mint 18.3 comes with HPLIP 3.16.3, so there should be no need to install HPLIP. Has your friend actually tried scanning? I think 18.3 comes with SimpleScan, but I prefer xsane, so I always install that.
She says no, but I did not install xsane or SimpleScan for her, and she does not experiment.
glad to know that the drivers are already loaded.

I will try to give her a call after I get back from my NASR-12 trip.

up in Galena, IL.

Post Reply

Return to “Software & Applications”