Page 2 of 5

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Thu Jun 14, 2012 11:59 pm
by SayanRedDevil
HartKnight wrote:gnome-screenshot --interactive (aka going to Accessories → Screenshot) doesn't change anything for the better. Neither does hitting "Print Screen." My problem isn't that it doesn't take screenshots. It does that. It just doesn't take a current one.

Image

Just took another one quickly and the time difference was 6 hours.
Exactly, it DOES take the screenshot with gnome-screenshot utility and print screen but it is never the current one.....

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Wed Jun 20, 2012 10:37 am
by dlalonde
It's definitely the AMD drivers (if that's the graphic card you have).

Use the default ones that come with Linux Mint. It did the trick for me and I have direct rendering enabled. :)

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Wed Jun 20, 2012 10:52 am
by HartKnight
dlalonde wrote:It's definitely the AMD drivers (if that's the graphic card you have).

Use the default ones that come with Linux Mint. It did the trick for me and I have direct rendering enabled. :)
If that's the case then why when logged out of Cinnamon and in with Gnome, the time difference problem with Screenshot clears up?

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Wed Jun 20, 2012 11:57 am
by dlalonde
Because Gnome doesn't use Cinnamon (it's more a problem betweet Cinnamon and the AMD driver, I stand corrected :P)

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Wed Jun 20, 2012 12:29 pm
by HartKnight
dlalonde wrote:Because Gnome doesn't use Cinnamon (it's more a problem betweet Cinnamon and the AMD driver, I stand corrected :P)
I take it you're referring to the FGLRX drivers. I had to install them at first because my monitor (Samsung SyncMaster 712N) wasn't receiving a signal. (I'm glad I could connect to my HD TV via HDMI to install LM13.) Somehow your idea worked for me since I was expecting my monitor to not get a signal again. I was thinking it had something to do with Cinnamon in some way after trying gnome-screenshot in Gnome itself a few weeks ago.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Mon Jul 02, 2012 3:08 pm
by flugmint
Any news on this? I'm having the screenshot problem, too. Definitely seems to be a problem only under cinnamon...

Here's my hardware:

- System: Kernel: 3.2.0-23-generic x86_64 (64 bit) / Desktop: Cinnamon / Distro: Linux Mint 13 Maya
- CPU: Dual core Intel Core2 Duo CPU P8700 (-MCP-) clocked at 800.00 MHz
- Graphics: Card: ATI RV620 [Mobility Radeon HD 3400 Series] / X.Org: 1.11.3 drivers: ati,fglrx (unloaded: vesa,fbdev,radeon) / Resolution: 1680x1050@60.1hz / GLX Renderer: ATI Mobility Radeon HD 3400 Series GLX Version: 3.3.11627 - CPC
- Network: Card-1: Intel PRO/Wireless 5100 AGN [Shiloh] Network Connection driver: iwlwifi / Card-2: Broadcom NetLink BCM5787M Gigabit Ethernet PCI Express driver: tg3

-flugmint

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Thu Jul 05, 2012 8:13 am
by LordFoobar
Same thing here too. I had this problem since the very first day I installed Mint with Cinnamon. I switched to XFCE and the everything worked fine. But had to re-install Mint yesterday as it seems XFCE made my system very unstable (probably a problem with my ATI installation, I don't know) and decided to give Cinnamon a second chance... but all the problems I had a month ago are still not fixed. I too have an ATI video card, a Radeon HD 3600.

It seems that, whatever is responsible of the capture is not updated with the latest screen pixels. Or Cinnamon does not update something correctly. For me, taking a screen shot with whatever screenshot program returns some frozen-in-time image of my desktop of a random moment (since the last X server start) and this same fixed image is returned every single time whenever I take a screenshot. Until I reboot, then it's another fixed random moment that is returned every time. It's very frustrating.

Really the last time I buy ATI stuff. Meanwhile, this should be fixed.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Fri Jul 13, 2012 6:34 am
by ahogg
Don't throw your AMD cards away just yet folks, because I'm having the same problem, and am running Nvidia prop. drivers. Other users have clearly stated that they are having similar problems with Intel HD. So it only makes sense to graduate from the AMD video driver theory. I am inclined to think that it has something to do with Compiz, but if not everybody having this issue is running Compiz, then out the window goes that theory. But I am thinking Compiz, because I have 3 Print Screen images on my desktop as we speak that were taken before I got Compiz up and running. And the Print Screen function worked flawlessly, or at least it worked as expected. Is there a connection? I can't say for sure, because I just discovered the issue, but in my mind, it's more probable than specifically AMD drivers. It's probably good to include that I am running LM13-Mate right now and love it--all except for the "broken" Compiz behavior. This is a huge step for me, because I am finally breaking away from LM9.

By the way, there are a few really good posts that help get Compiz running, but it is still nowhere near what it was in LM9. There was also an update the other day that seams to have made Compiz go a little wonky. The bottom line is Compiz ain't what it used to be. No matter what tweaks you make to the window manager settings in mateconf-editor, or the gtconf-editor for that matter, Compiz really creates problems for other 3D processes like rss-glx screensavers, and I'm sure other things. System Monitor might show CPU efficiency nice and low, but try running a 3D screensaver, and it will skyrocket. Not to mention that the screensaver rendereing itself absolutely sucks.

I'm sure Clem knows about this, and things have fallen way behind in the 3D world. Hope things can get back on track like they were in LM9. That's my only gripe right now. I still love Mate, it has come leaps and bounds since it's inception, but alas, we have leaps and bounds more to go. However, huge thanks be to Clem and all his hard work.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Fri Jul 13, 2012 11:41 am
by ahogg
It appears that I am at least partially correct in my assumptions about Compiz. I completely uninstalled Compiz, and guess what? Print Screen works beautifully. To add further weight to the argument, I happened to have a terminal window opened after reinstalling Compiz and running compiz --replace to sink everthing back up. When I tried the Print Screen function, a message came up in the terminal window that gnome-screenshot was not found. To verify my suspicion, I completely removed Compiz again, and screen shot works beautifully again. Is there a connection with Compiz? It seems obvious, but I wish I had a more specific answer. It may be just one small component of Compiz. BTW, the screen shots are instantly, and are not a shot of a past event.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Fri Jul 13, 2012 5:25 pm
by Rua
I'm having the same problem. Using Mint 13 Cinnamon, ATI Catalyst drivers on a Radeon HD 5770. When I press printscreen, I see a window appear and then it disappears really fast before I can even see what it is. When I go to GIMP after that and try to paste, it tells me there is no image data on the clipboard.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Fri Jul 13, 2012 9:40 pm
by ZubenElgenubi
compazter wrote:I think the screenshot picture is automatic store in picture folder without notification, just check it out.
Sorry for my bad english
Yes dude, that's it.
To everyone: There isn't problem, Cinnamon stores automatically the screenshots in your home/Images folder :mrgreen:

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Sat Jul 14, 2012 5:00 pm
by SayanRedDevil
ZubenElgenubi wrote:
compazter wrote:I think the screenshot picture is automatic store in picture folder without notification, just check it out.
Sorry for my bad english
Yes dude, that's it.
To everyone: There isn't problem, Cinnamon stores automatically the screenshots in your home/Images folder :mrgreen:

boy, u think neither of us know that it stores screenshot automatically in pictures folder? You might wanna go through this thread again to know what we are talking about exactly.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Sun Jul 15, 2012 8:36 am
by DellPrecision
I assign new keyboard shortcut ctrl-P and as a command i put gnome-screenshot --interactive
and seems to work well with not time issues i hope that may help.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Mon Jul 16, 2012 2:48 am
by ridz1ba
Yep - having the same problem here but I solved it by logging out of Cinnamon and then logging back in using a 'Gnome Classis - no effects' session. Using that session the 'Print Screen' and 'Alt-Print Screen' functions worked properly. Not a great solution but a solution nevertheless.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Thu Aug 16, 2012 11:45 pm
by Danko8321
I have a certain workarround, although it isn't precisely a solution. I was also having this problem, both the delay and the automatic screenshot saving (which I DEEPLY hate); my workarround was to use GCONF to modify the command executed by the "Print Screen" button (open GCONF, go to /apps/metacity/keybinding_commands and change the values of "command_screenshot" and "command_window_screenshot"), and I changed it to the proper KSnapShot defaults (ksnapshot instead of gnome-screenshot and ksnapshot --curent instead of gnome-screenshot --window.

I already had KDE installed so this is not precisely a big deal for me (also, I always liked KSnapShot better than Gnome Screenshot, so it's a win for me). If you don't have KDE installed, you can simply install KSnapShot by putting:

Code: Select all

sudo apt-get install ksnapshot
in a terminal.

My two cents.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Wed Aug 29, 2012 11:08 pm
by beyondcr
*Bump this is a issue, So far I found VNC, Teamviewer. Print screen and Kazam Screencaster, (mostly anything that records the desktop) to be inoperable with cinnamon at the moment. I tried 3 different driver releases and still the same issue, Some times I get a perfect picture but it is not current, other times the picture is all jumbled up. It is really annoying. If the devs need logs I am willing to give what ever is needed to fix this issue, But for what I seen on a few of my friends instillation's its not just me so it should not be terribly hard to reproduce the problem.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Mon Sep 03, 2012 12:39 am
by beyondcr
Here is the output of gnome-screenshot in the terminal,

Code: Select all

WARNING **: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11. Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Shell was not provided by any .service files
More output... http://pastebin.com/M8Ls5BtZ

Any help will be greatly appreciated.

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Mon Sep 03, 2012 12:01 pm
by xclusive585
CtrlAltDel wrote:
CreamCorn wrote:Is everyone having this problem running the following?

OS: Linux Mint 13
Desktop: Cinnamon
GPU: AMD Radeon
Drivers: AMD Catalyst 12.4

I *suspect* this problem could be unique to Cinnamon users with AMD Radeon graphics using the official AMD Catalyst drivers.
Nope. I have the same issue with an Intel Graphics HD 2000 integrated chip running Mint 13 Mate with Compiz.

Print screen key simply doesn't work. No blink, no flash, no nothing when pressed. I am, as HartKnight mentioned, able to use the screenshot program that comes with the default installation. Unlike his situation, the program works fine and does normally for me.

I just gave up on the PrintScreen key ever working and, since I had to revert to Compiz to solve video issues, use the screenshot tool located there. Now I hold down the Super button and drag the mouse to encompass whatever area I wish and it pops up an image viewer of my choice with the area I selected in it when I release the mouse button.

Not what I wanted but, it works for the time being. Until someone in this thread tells us how to get it right. :-)
Sorry if this was covered but your issue is with compiz, you need to apply settings to tell compiz to use mate-screenshot, as mate doesnt have gnome-screenshot which is expected by compiz by default....

(running LM13, Mate, Compiz, mate-screenshot works great)


HartKnight wrote:
dlalonde wrote:It's definitely the AMD drivers (if that's the graphic card you have).

Use the default ones that come with Linux Mint. It did the trick for me and I have direct rendering enabled. :)
If that's the case then why when logged out of Cinnamon and in with Gnome, the time difference problem with Screenshot clears up?
Again, because Mate uses mate-screenshot, NOT gnome-screenshot. gnome-screenshot is for Cinnamon (Gnome3), and mate-screenshot is forked for mate. Perhaps it is an issue between AMD and gnome-screenshot, or as others have mentioned perhaps it's because Cinnamon is not loading the same video driver as Mate?

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Mon Sep 03, 2012 12:03 pm
by Devil999
beyondcr wrote:*Bump this is a issue, So far I found VNC, Teamviewer. Print screen and Kazam Screencaster, (mostly anything that records the desktop) to be inoperable with cinnamon at the moment. I tried 3 different driver releases and still the same issue, Some times I get a perfect picture but it is not current, other times the picture is all jumbled up. It is really annoying. If the devs need logs I am willing to give what ever is needed to fix this issue, But for what I seen on a few of my friends instillation's its not just me so it should not be terribly hard to reproduce the problem.
I second this problem. This and the screenshot one. Are they related? Is anyway to quickly fix them, or is there an "official" fix on the way?

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Posted: Mon Sep 03, 2012 12:41 pm
by dagon
See if any of the reported bugs are related:
https://github.com/linuxmint/Cinnamon/i ... screenshot