Nautilus "hangs" when launched [SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Kikito
Level 1
Level 1
Posts: 35
Joined: Mon Aug 16, 2010 9:13 pm

Nautilus "hangs" when launched [SOLVED]

Post by Kikito »

Hey all!

I am a current user of Linux Mint 13, running Gnome Shell. Ever since I installed Maya, Nautilus appears to hang for more than a couple of seconds (~10 secs). I say it appears to, because it's only the cursor showing that the program is still "thinking" and not ready, while for all intents and purposes it is ready and responsive. This also happened on occasion on Mint 12 as well. I've tried looking for an answer on the inter webs to no avail and have been to busy to make a post here.

So, anyone know what I can do to solve what appears to be a cosmetic issue?
Last edited by Kikito on Tue Aug 14, 2012 9:33 am, edited 1 time in total.
bobhuber
Level 1
Level 1
Posts: 2
Joined: Tue Jul 17, 2012 3:06 pm

Re: Nautilus "hangs" when launched

Post by bobhuber »

I've experienced the same problem with 3 different versions of Ubuntu and now Mint 13 (Mate)
In Ubuntu it was caused by setting the system to autologon. In Mate it doesn't seem to make a difference.
Its just a cosmetic fix (get rid of the spinning cursor) but here's what I did.
/usr/share/icons/DMZ-White/cursors
Make copies of the 'watch' and 'left_ptr_watch' cursor files for safe keeping.
Replace both files (keeping the same names) with copies of 'arrow'

Much easier to move the arrow around than a spinning cursor and it doesn't seem to affect anything.
AMD-FX6200 4.1GHZ-60Gig SSD-500 Gig Sata-Nvidia GTX 550Ti-8GB DDR3-Mint 13 {Mate}
Kikito
Level 1
Level 1
Posts: 35
Joined: Mon Aug 16, 2010 9:13 pm

Re: Nautilus "hangs" when launched

Post by Kikito »

Thanks! It did help a bit, but the panel still shows Nautilus as "still loading". In any case, it's less frustrating now at least.

I'm gonna hold on declaring it solved, in case someone has a complete solution to the problem.
Kikito
Level 1
Level 1
Posts: 35
Joined: Mon Aug 16, 2010 9:13 pm

Re: Nautilus "hangs" when launched

Post by Kikito »

Aaaaand after fiddling a bit, discovered that the root of the problem is having the file manager handle the desktop instead of the shell. It's an option you can turn off using gnome-tweak-tool. However, this disallows the ability to have any shortcuts/icons on the desktop as far as I can tell.

It must be some kind of conflict between the file manager and the shell or some bug like that. I'll declare this solved now, and I can finally move on with the next chapter of my life :mrgreen: .
Post Reply

Return to “Software & Applications”