alacarte menu editor, does nothing when clicked

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
Level 2
Level 2
Posts: 55
Joined: Fri Feb 29, 2008 7:41 pm

alacarte menu editor, does nothing when clicked

Postby greenducky » Mon Apr 07, 2008 9:28 am

Hey guys when i right click on the daryna button and click edit menu nothing happens.
also when i hit alt + f2 and then type alacarte & nothing happens.
also when i go to menu preferences and then click mainmenu nothing happens.

by the way if you are reading this and are unaware of what i am talking about. all three things are trying to launch the same
program called alacarte. alacarte is a menu editor for mint menu.

This is what it lookes like when i try it in a terminal.

mint@mint-desktop:~$ alacarte &
[1] 31504
mint@mint-desktop:~$ Traceback (most recent call last):
File "/usr/bin/alacarte", line 36, in <module>
File "/usr/bin/alacarte", line 32, in main
app = MainWindow(datadir, version, sys.argv)
File "/usr/lib/python2.5/site-packages/Alacarte/", line 49, in __init__
self.editor = MenuEditor()
File "/usr/lib/python2.5/site-packages/Alacarte/", line 36, in __init__
File "/usr/lib/python2.5/site-packages/Alacarte/", line 46, in __loadMenus
self.applications.dom = xml.dom.minidom.parse(self.applications.path)
File "/usr/lib/python2.5/site-packages/_xmlplus/dom/", line 1915, in parse
return expatbuilder.parse(file)
File "/usr/lib/python2.5/site-packages/_xmlplus/dom/", line 926, in parse
result = builder.parseFile(fp)
File "/usr/lib/python2.5/site-packages/_xmlplus/dom/", line 207, in parseFile
parser.Parse(buffer, 0)
xml.parsers.expat.ExpatError: not well-formed (invalid token): line 13, column 52


Please help me.
I tried uninstalling it from synaptic and then reinstalling it and then reloading plugins on the mint menu. and nothing. i've restarted x and rebooted.
even when i try to change the session to safe gnome mode. and log inn it still dont work.
it worked fine earlier today, only thing i did between now and then is install adobe cs2 in wine doors.
I hope someone can make some sense of this.

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: alacarte menu editor, does nothing when clicked

Postby Husse » Wed Apr 09, 2008 4:51 pm

The general advice in this case is to reload plugins as you've done and also remove from and add to the panel again.
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Software & Applications”