How to enable Nvidia 32 bit OpenGL libraries on Mint 13

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
daret
Level 2
Level 2
Posts: 79
Joined: Sun Sep 30, 2012 8:42 am

How to enable Nvidia 32 bit OpenGL libraries on Mint 13

Post by daret »

My Problem started after I installed Playonlinux on my new Mint 13 KDE installation.

After i run playonlinux i got a Warning:
playonlinux [Check_OpenGL] Warning: 32bits direct rendering is not enabled
- and of course, DirectX Games didn't worked.

I installed even new driver from nvidia homepage:
http://www.nvidia.com/object/linux-disp ... river.html
and was sure, 32 bit support is installed!

I found out, that path to 32 bit lib. (/usr/lib32) is not known for Mint
I tried:

Code: Select all

export LD_LIBRARY_PATH=/usr/lib32
playonlinux
and it worked :D

The question was, how to make it systemwide?
I found somewhere an information, that setting LD_LIBRARY_PATH is not good idea.

I found

Code: Select all

/etc/ld.so.conf.d/nvidia_settings.conf
- it is symlink to ...

Code: Select all

/usr/lib/nvidia-settings-updates/ld.so.conf
but the file ld.so.conf doesn't exist.

I created one - Text file with:
/usr/lib32
than run:

Code: Select all

sudo ldconfig
and everythink works, even after restart :)
Harkonnen
Level 1
Level 1
Posts: 5
Joined: Wed Dec 26, 2012 4:58 pm

Re: How to enable Nvidia 32 bit OpenGL libraries on Mint 13

Post by Harkonnen »

This also worked for me

to make a long story short
make a file called ld.so.conf in the /urs/lib/nvidia-settings
which contains

/usr/lib32



thats it
this works on Mint Nadia
JefferySanders
Level 1
Level 1
Posts: 1
Joined: Thu Sep 26, 2013 8:19 pm

Re: How to enable Nvidia 32 bit OpenGL libraries on Mint 13

Post by JefferySanders »

I had the same issue.

I used the command "primusrun" instead of optirun in the applications command path to resolve the problem.
Post Reply

Return to “Software & Applications”