Page 1 of 1

linuxmint 14/Libreoffice -- can't

Posted: Thu Nov 29, 2012 12:11 pm
by kkruecke
Using libreoffice writer, I go to Tools -> Options -> Paths, then Edit "My Documents" path, to be /home/kurt/Documents, but it does not change. It stays as /home/kurt. I tried doing

chmod -R a+w ~/.config/libreoffice

but that did not good, either.

Any ideas?

Re: linuxmint 14/Libreoffice -- can't

Posted: Thu Nov 29, 2012 4:16 pm
by Kikito
That's strange, my default for My Documents is home/####/Documents. Also, I was able to change it to something else with no problem.

Have you tried pressing the Default button and see if it goes to the Documents folder?

Also, when you change it to something else, do you pres OK at the end?

Re: linuxmint 14/Libreoffice -- can't

Posted: Thu Nov 29, 2012 4:44 pm
by kkruecke
Yes, it's strange alright. Pressing Default doesn't do anything.

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Dec 21, 2012 5:00 pm
by rdegennaro
I have the same problem. This is after upgrading from Linux Mint 13 to Linux Mint 14 today. Did you ever find an answer?

I found various similar problems and tried the following without success:
Deleting the file .libreoffice/3/user/registrymodifications.xcu
Delete the user directory and .lock file in same path
Uninstall and reinstall Libreoffice

In another thread, I noticed someone else had renamed their computer (hostname), as I did with this computer. Maybe that's a possible cause.

When I installed Dropbox on this install of Linux Mint 14 yesterday, I had a similar problem that I couldn't select a location other than the default. Wonder if it's related. I worked around that by setting location at default, then changing it.

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Dec 21, 2012 7:47 pm
by kkruecke
I'm not sure it is a Libreoffice problem. It might be mint/mate problem? dunno.

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Dec 21, 2012 8:45 pm
by zerozero
@kkruecke
@rdegennaro
are you (re)using the mint13 home in this mint14 install?

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Dec 21, 2012 9:49 pm
by kkruecke
Do you mean is my /home/kurt directory the same as Mint 13. I guess so. Why should that matter?

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Dec 21, 2012 9:51 pm
by zerozero
kkruecke wrote: Why should that matter?
try to create a new user and see if you can replicate those issues

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Dec 21, 2012 10:20 pm
by kkruecke
I created a new user. The problem still exists.

Re: linuxmint 14/Libreoffice -- can't

Posted: Sat Dec 29, 2012 7:36 pm
by rdegennaro
@zerozero: Sorry for slow reply.
For this upgrade (from LM13 > 14), I did NOT keep the same home folder. I recreated everything from scratch.
I created a new user with Admin rights, and got same problem.

I have a separate post about the problem of the system not taking output directory designations when using print to file:
http://forums.linuxmint.com/viewtopic.php?f=47&t=120962
I wonder if these two problems are related since both are rejecting any location except /home.

Finally, I changed my hostname after install, and wonder if that's a cause. I did it correctly, but am just looking for ideas.

Re: linuxmint 14/Libreoffice -- can't

Posted: Wed Jan 02, 2013 1:16 pm
by rdegennaro
@kkruecke: Did you change your hostname (computer name) like I did after installing Mint 14?

Anyone: this remains a problem for me and I welcome any suggestions or advice. I would prefer not to reinstall Mint unless I were sure it will fix it.

Re: linuxmint 14/Libreoffice -- can't

Posted: Wed Jan 02, 2013 4:24 pm
by kkruecke
I don't believe I changed the computer name. Anyway, this has been opened as a Libreoffice bug by Linux Mint support: https://www.libreoffice.org/bugzilla/sh ... i?id=58940

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Jan 11, 2013 8:04 pm
by yonnie
FYI-- On 32-bit LM14 Mate, I have the same issue (can't set default folder), plus a little worse: all the hidden files are displayed in the /home/user directory when trying to open/save as files (and any other directory that may have hidden files). This is version 3.6.2.2 that I'm using. Saving files tosses them into the home/user folder, real PITA!
On 64-bit LM14 Mate the symptoms are slightly different in setting defaults but same results and don't see hidden files/folders.

I've gleaned thru troubles in the Libreoffice website and find nothing like this issue, so I'm guessing this may not be just a Libreoffice problem. Running libreoffice 3.5.5.3 on another nix does not have this issue. Sorry, don't have same version installed there.

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Jan 11, 2013 8:11 pm
by kkruecke
I bought second pc recently with Mint/Cinnamon and the problem is not present. Could be a MATE issue like you said.

Re: linuxmint 14/Libreoffice -- can't

Posted: Fri Jan 11, 2013 8:48 pm
by rdegennaro
This problem now has a bug report on LibreOffice:
Bug 58940 - CONFIGURATION: Can not change paths used by LibreOffice
https://www.libreoffice.org/bugzilla/sh ... i?id=58940
However, status is only "info needed".
At least one person reports the problem on Ubuntu 12.10, so not unique to Mint.