Editing repos in synaptic broken?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 3
Level 3
Posts: 156
Joined: Fri Nov 27, 2009 1:38 am

Editing repos in synaptic broken?

Post by robert-e » Mon Dec 17, 2012 5:19 pm

The kernel is 3.2.0-34-generic on an hp laptop x86_64. The OS is LinuxMint Release: 13 (maya) Edition: MATE 64-bit
It is updated as of today.

synaptic is version 0.75.9ubuntu1. I notice that in synaptic, settings-->repositories does not do anything.
Previously, I could edit the sources.list graphically in synaptic. Could someone enlighten me why, and
what to do to fix this?

Perhaps related:

Using the gui, clicking on the Menu item: Preferences -->Software Sources does nothing obvious.

Running the following as root in cli gives:
rob-hp rob # software-properties-gtk
Traceback (most recent call last):
File "/usr/bin/software-properties-gtk", line 104, in <module>
app = SoftwarePropertiesGtk(datadir=options.data_dir, options=options, file=file)
File "/usr/lib/python2.7/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 89, in __init__
SoftwareProperties.__init__(self, options=options, datadir=datadir)
File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 96, in __init__
File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 584, in reload_sourceslist
File "/usr/lib/python2.7/dist-packages/aptsources/distro.py", line 87, in get_sources
raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template


Level 1
Level 1
Posts: 1
Joined: Fri Jan 11, 2013 9:22 pm

Re: Editing repos in synaptic broken?

Post by fbrcstll » Fri Jan 11, 2013 9:26 pm

I have also the same error. It was disappointing to see that there is no reply.

# I am a necromancer.

Level 1
Level 1
Posts: 7
Joined: Wed Jul 13, 2011 11:46 am

Re: Editing repos in synaptic broken?

Post by Darkraven » Wed Feb 06, 2013 8:22 am

Did you remove the package mintupdate? After doing so, I had the same problem you tell. Reinstalling mintupdate solved it. I guess this should be reported as a bug since there is no apparent dependency between the two packages.

Post Reply

Return to “Software & Applications”