Need help with X server

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
aschueler
Level 1
Level 1
Posts: 3
Joined: Tue Jan 01, 2013 12:39 pm

Need help with X server

Post by aschueler » Tue Jan 01, 2013 12:52 pm

Hello,

I am not totally new to the linux world, but I am having surprising problems with Mint, which I am just now trying to install. Not mentioning some install issues I have worked through, I am stuck at

"Failed to start the X server .... It is likely that it is not set up correctly....X server output to diagnose the problem?"

Important output shows
(==) log file "/var/log/Xorg.0.log"
(==) Using config file "/etc/X11/xorg.conf.d"
vesa: ignoring device with a bound kernel driver
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

I cannot run x configure, it crashes tooo...


I have at/radeon card and know i ought to have fglrx, which I am now installing but any other ideas?

The test disk worked great and I am amazed at the amount of work I have to do...

abnvolk
Level 4
Level 4
Posts: 491
Joined: Thu May 10, 2012 11:05 am

Re: Need help with X server

Post by abnvolk » Tue Jan 01, 2013 12:56 pm

Are you using Mint 13?
Anyway, try this, it worked for me: forums.linuxmint.com/viewtopic.php?t=103142&f=46.

aschueler
Level 1
Level 1
Posts: 3
Joined: Tue Jan 01, 2013 12:39 pm

Re: Need help with X server

Post by aschueler » Tue Jan 01, 2013 1:30 pm

It is Mint 13, 64 bit....the link didn't seem to apply to 64 bit.

Still stuck after getting fglrx.

Still surprised of the trouble given the good reviews .... Hopefully I can actually take a look at it.

User avatar
oobetimer
Level 7
Level 7
Posts: 1879
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle
Contact:

Re: Need help with X server

Post by oobetimer » Tue Jan 01, 2013 2:10 pm

A normal case with Mint. You need to copy /etc/X11/xorg.conf file via liveCD (Puppy, Mageia, etc).

http://forums.linuxmint.com/viewtopic.p ... 83#p667583

aschueler
Level 1
Level 1
Posts: 3
Joined: Tue Jan 01, 2013 12:39 pm

Re: Need help with X server

Post by aschueler » Tue Jan 01, 2013 3:51 pm

I finally just gave up. Something very strange was wrong...can't even run Xorg configure. I installed Misty 13 with KDE, 32 bit over it instead and seems to be working so far, but no sound. I am updating everything now (over 500 files!), and hope to get my video card and sound card working soon.

Thanks for trying.

Oh the other stuff that went wrong: had to remove my wireless card (wasn't using it anyway), and for some reason Grub2 went nuts because I have 3 HDD's, one for windows, one for linux and the third for storage. It renamed everything sda, sdb and sdc in no rational way and then it couldn't find the boot parition...had to run the boot repair program which worked. Sigh.

Post Reply

Return to “Software & Applications”