Brother MFC-665CW not working

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 6
Joined: Tue Feb 05, 2013 2:21 am

Brother MFC-665CW not working

Postby rwest » Mon Feb 11, 2013 2:47 am

Would some one beable to help me to get my Brother MFC-665CW printer / scanner to work
I am running Linux mint 14 Cinnamon 64bit /duel boot windows7
Printer/scanner works in windows.
Linux sees the printer and instales the printer but printer will not print.
Simple scan will not detect the scanner.
Xsane reports no devices available.
I have downloaded and installed new drivers from the Brother site and reinstalled the printer a number of times.
I have installed the driver packaging from Which had the same result as when Mint automaticly installed the printer
(The printer is installed but will not print or scan).
I have yet to try the procedure as outlined in the last link provided by Viking777 (viewtopic.php?f=51&t=80363#p466713). posted by chris215 back in 2011. (will do this next)
(as a work around I have installed a HP Laser Jet printer works just great Mint installed it automaticly, I am using the Brother in windows but would be great to eventually have it working in Mint)
Last edited by rwest on Wed Feb 13, 2013 7:33 am, edited 2 times in total.

Level 1
Level 1
Posts: 2
Joined: Mon Feb 11, 2013 9:02 am

Re: Brother MFC-665CW not working

Postby Maninga » Mon Feb 11, 2013 9:46 am

I too am having the same problem. running Mint 14 32 bit.

The printer is recognised in the printer settings and I have selected it as a default printer. When I go to do a test page nothing happens and when I try using Libre office writer it says' printing cancelled pretty much immediately after I press the print button. Do I need to install a driver? I'm using the Brother MFC-J6710DW can't seem to find a linux based driver for it.


looks like the MFC range is limited in turms of driver compatibility. My MFC J6710DW is not listed in the 'open printing database'

found here

the MFC-665CW isnt listed either and may be the reason it's not working? I know you said that you installed the driver, I'm just not seeing it on the database.

User avatar
Level 14
Level 14
Posts: 5126
Joined: Mon Dec 01, 2008 11:21 am

Re: Brother MFC-665CW not working

Postby viking777 » Mon Feb 11, 2013 11:22 am

This site

indicates that the 665cw is supported (or at least it was for Ubuntu 10 that the page was written for). Have you tried the printer driver installer referred to at the top of the page?

There is also this

Post #403

Or closer to home there is this one:

Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

Return to “Software & Applications”