Unable to mount blank DVR disk.

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 12
Joined: Tue Jan 01, 2013 5:28 pm

Unable to mount blank DVR disk.

Postby Davidicus » Sat Mar 02, 2013 3:36 am

I am running Mint14 64bit, and I cannot write onto a blank DVD. I get the message 'unable to mount blank DVR disk'. I've tried several different types of disks such as +R -R RW and even double layer, but I get the same response. It means I cannot copy anything to a blank DVD. I've also tried various disk writing programs, but when it gets to the actual process of writing to disk, nothing happens.

Level 1
Level 1
Posts: 8
Joined: Sun Mar 24, 2013 9:32 am

Re: Unable to mount blank DVR disk.

Postby joksim » Mon Mar 25, 2013 11:58 am

I have the same problem, except my disks are burned but doesn't work... i.e. they are not bootable (talking about ".iso" files).
Any solution pls?

User avatar
Level 13
Level 13
Posts: 4540
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Unable to mount blank DVR disk.

Postby Flemur » Mon Mar 25, 2013 1:16 pm

I've also tried various disk writing programs,

Try k3b if you haven't. It's the only one that doesn't suck.
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
Level 17
Level 17
Posts: 7543
Joined: Wed Jun 17, 2009 8:20 pm

Re: Unable to mount blank DVR disk.

Postby DrHu » Mon Mar 25, 2013 2:12 pm

The DVD media has to be a match for the DVD drive (dvd R- R+ or other ?)
    xfburn seems to be ok for me, also since you are on the main edition (Gnome base), Gnome baker might work, but I have found xfburn to be more reliable with media

http://www.techdrivein.com/2011/03/9-go ... s-for.html
--you can try others, but I would be careful about media (DVD) being used, as well noting that some brands of media may be better than others, for example the cheapest(not a major brand) may not always be the best..
--I tend to try Maxell, Fugi, being that they had good tape technologies (a good background in magnetic media/coatings, and had little problem switching to optical versions..)
http://www.techimo.com/forum/general-te ... brand.html
http://www.best-dvd-burning-software-re ... -media.asp

You can check, or choose on your own, your experience will tell you which works best: and since you can buy a single copy of a media (disk) you can determine that
    It is also worth considering a rw dvd media in order to use as a scratch disk: many people probably create too many write-once (Read only) dvd media and hardly use them again
    --a matter of organization/planning: it does help to be organized, although it can be a fair amount of work

Level 1
Level 1
Posts: 1
Joined: Thu Jan 10, 2013 4:14 pm

Re: Unable to mount blank DVR disk.

Postby wurzeld » Sat Oct 26, 2013 3:15 pm

Thought I would add my experience here - exactly the same problem, using Brasero, then Xfburn, so downloaded my favourite Gnomebaker.
Still got the same problem. The disk I was using was a Tesco DVD-RW and had been used for a few .iso's so being a thorough person I did not use the fast format option, and repeatedly got the 'unable to mount blank DVR disk' when I tried to burn a new distro, (the disk was showing as mounted in Nemo but not in "Disks") ....and then on a whim I tried the fast format using the "force" option - it worked and I was then able to go ahead and burn a lovely Manjaro iso !!
Manjaro then booted fine from the dvd without any problems.

System was Mint 15, Cinnamon, 64bit on a Lenovo T61

Return to “Software & Applications”

Who is online

Users browsing this forum: xenopeek and 15 guests