Teamviewer - problem with screen sharing

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Tue Mar 12, 2013 9:08 am

Teamviewer - problem with screen sharing

Postby pingvin » Tue Mar 12, 2013 9:15 am

I have a problem with Teamviewer, precisely when someone connects (Remote Control) on my computer, it does not refresh the image to Desktop and he does not see anything that's going on, instead he sees a static (usually from the beginning of the connection) image. If he connect from Windows, he sees a black screen. Teamviewer I downloaded from the official website, at first version 8, then 7 (the same problem occurs), and at the end of 7 for 32-bit Linux (again the same story).

I do not know how much is this important, but I have a Dell Inspiron N5010 (with ATI Radeon HD 5400 Series, currently using video driver for the AMD graphics acceleratos for fglrx) and Cinnamon environment.

CPU Dual-core Intel Core i3 CPU M 330 (-HT-MCP-) clocked at 931 000 Mhz Kernel ~ 3.5.0-17-generic x86_64 Up ~ 2:35 Mem ~ ~ 1160.2/3819.5MB HDD 500.1GB (1.8% used ) procs ~ 183 Client ~ Shell ~ INXILE 1.8.4

Does anyone know a solution to this problem?

Thank you in advance!

User avatar
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Teamviewer - problem with screen sharing

Postby Fornhamfred » Tue Mar 12, 2013 2:52 pm


I have experienced this same problem trying to support friends using Teamviewer 7 on my LMDE Mate installation. I recently installed version 8 and have just tried it out controlling my XP machine with no problems at all. Perhaps it is best to use 8 both ends.

My linux machine also has AMD graphics

Level 1
Level 1
Posts: 2
Joined: Thu Jan 24, 2013 10:04 am

Re: Teamviewer - problem with screen sharing

Postby slcpunk » Fri Apr 12, 2013 9:10 am

Same problem here. If you uninstall the fglrx drivers and go back to the open source ones, it seems to work. However, I find the open source drivers are very slow for some things....

Interestingly, this bug seems to be in the fglrx driver, as it affects not only Teamviewer but Cisco WebEx as well. Since TV uses wine, and WebEx uses java ... it has to be something in the driver causing the problem.

oh well. (LM 14, cinnamon )

ps - I tried also loading the AMD drivers, ( catalyst v 12 ? ) This also did not work, same behavior.
pps - just tried 13.1 catalyst drivers ... no love either.

Level 1
Level 1
Posts: 1
Joined: Wed Sep 09, 2015 8:45 am

Re: Teamviewer - problem with screen sharing

Postby R.Schreurs » Wed Sep 09, 2015 9:17 am

I have seen this issue with VNC Vino server and Team Viewer 10 on a Linux Mint 17 installation. The screen did not refresh on a Windows 10 client, running RealVNC, TigerVNC or Teamviewer 10.

Interestingly, this bug seems to be in the fglrx driver

This is also what I experienced: after changing from fglrx to xserver-xorg-video-ati, the screen was updated on the remote client. Unfortunately, the xorg driver only allows a screen resolution of 800 x 600 :cry:

How could I improve that?

Return to “Software & Applications”

Who is online

Users browsing this forum: BenTrabetere, Bing [Bot] and 16 guests