[SOLVED] VirtualBox-4.2 not updating beyond 4.2.0

Questions about applications and software
Forum rules
Before you post please read how to get help
jurinad
Level 1
Level 1
Posts: 2
Joined: Wed Apr 17, 2013 12:30 pm

[SOLVED] VirtualBox-4.2 not updating beyond 4.2.0

Postby jurinad » Wed Apr 17, 2013 12:36 pm

Hi,
I added oracle repo as described here https://www.virtualbox.org/wiki/Linux_Downloads and installed package virtualbox-4.2. This resulted in 4.2.0, despite the fact that current version (in oracle repo) is 4.2.12.
Here's what apt-cache shows:

Code: Select all

$apt-cache madison virtualbox-4.2
virtualbox-4.2 | 4.2.12-84980~Ubuntu~precise | http://download.virtualbox.org/virtualbox/debian/ precise/contrib amd64 Packages
virtualbox-4.2 | 4.2.0-80737~Ubuntu~precise | http://packages.linuxmint.com/ nadia/import amd64 Packages


But "apt-get update && apt-get upgrade" does not upgrade vritualbox from 4.2.0 to 4.2.12.
Why? How to make it upgrade?
Last edited by jurinad on Thu Apr 18, 2013 7:08 am, edited 2 times in total.

User avatar
catweazel
Level 10
Level 10
Posts: 3138
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: VirtualBox-4.2 not updating beyond 4.2.0

Postby catweazel » Wed Apr 17, 2013 4:57 pm

jurinad wrote:How to make it upgrade?

In a word, wait.

The repos lag behind by quite a margin so you won't see 4.2.12 there for some time. If you want the latest version then download it, along with the machine extension pack, from the Oracle website. If your browser doesn't launch the application automatically, just double click the downloaded file from within your file manager.
Mint Donor #6036
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

jurinad
Level 1
Level 1
Posts: 2
Joined: Wed Apr 17, 2013 12:30 pm

Re: VirtualBox-4.2 not updating beyond 4.2.0

Postby jurinad » Thu Apr 18, 2013 6:07 am

But my apt has oracle repo in lists, why doesn't it want to update from there?

So apparently Oracle repo has a low apt priority by default (explanation here http://wiki.debian.org/AptPreferences#A ... references and in $ man apt_preferences).

After adding

Code: Select all

Package: virtualbox-4.2
Pin: version *
Pin-Priority: 800

to the top of /etc/apt/preferences file virtualbox successfully updated to latest version. It would probably work with "Package: virtualbox*" as well, gotta try it on next update.


Return to “Software & Applications”

Who is online

Users browsing this forum: Bing [Bot], deepakdeshp and 16 guests