Cannot add users through Users and Groups

Questions about applications and software
Forum rules
Before you post please read how to get help
Narcoleptic
Level 1
Level 1
Posts: 1
Joined: Mon Jun 09, 2008 8:38 pm
Location: Crafton, TX

Cannot add users through Users and Groups

Postby Narcoleptic » Mon Jun 09, 2008 8:51 pm

I'm having a problem with Mint 5, not sure if this is the right sub-forum for this particular problem, but here it goes: I cannot add users through Administration | Users and Groups. Once I click "Unlock", then "Add User", and then their information, the applet seems to take it. Then if I close the applet, and re-launch it the user is no longer there. There is a group with the user's name, but no user. If you try the command line "adduser" it complains about the group already existing. Deleting the group and then adding through "adduser" does work.

I had this same problem in the 5 betas, too.

lanrun
Level 3
Level 3
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Re: Cannot add users through Users and Groups

Postby lanrun » Tue Jun 10, 2008 1:39 am

I have the same problem. Not found any solutions yet.

shoeshy
Level 1
Level 1
Posts: 2
Joined: Wed Jun 11, 2008 2:52 am

Re: Cannot add users through Users and Groups

Postby shoeshy » Wed Jun 11, 2008 3:06 am

The problem seems to stem from the way the 'users-admin' application is run.

It works as expected using "Run Application" (Alt-F2) and typing it in. Now when it runs the 'Unlock' button is available to switch to admin mode.

It does not work from the Terminal, but there are some errors that may make sense to someone more experienced:

$ users-admin

** (users-admin:19465): CRITICAL **: Cannot create session bus: Failed to connect to socket /tmp/dbus-muHvPq2man: Connection refused

** (users-admin:19465): CRITICAL **: Unable to find session for cookie


lanrun
Level 3
Level 3
Posts: 158
Joined: Tue Oct 23, 2007 7:31 am
Location: Lillehammer - Norway

Re: Cannot add users through Users and Groups

Postby lanrun » Thu Jun 12, 2008 2:38 am



Now I have read this:
"edrangas: You're right - in my case, a simple:

'sudo passwd -l root'

...fixes my issue! I can now use the users-admin tool again."

So sudo passwd -l root will lock the root account. :This option disables an account by changing
the password to a value which matches no possible encrypted value.

I can not understand why this will help, as the root account was not enabled during the installation process.

regards
lanrun

User avatar
ominousluv
Level 1
Level 1
Posts: 18
Joined: Tue Oct 02, 2007 11:00 am
Location: Michigan, USA

Re: Cannot add users through Users and Groups

Postby ominousluv » Thu Jun 12, 2008 2:13 pm

lanrun wrote:


Now I have read this:
"edrangas: You're right - in my case, a simple:

'sudo passwd -l root'

...fixes my issue! I can now use the users-admin tool again."

So sudo passwd -l root will lock the root account. :This option disables an account by changing
the password to a value which matches no possible encrypted value.

I can not understand why this will help, as the root account was not enabled during the installation process.

regards
lanrun



Thanks, solved the problem for me as well.


Return to “Software & Applications”

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 13 guests