Need help understanding installing from source and dependenc

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
wolfe.inugami
Level 1
Level 1
Posts: 7
Joined: Fri Jun 14, 2013 9:48 pm

Need help understanding installing from source and dependenc

Post by wolfe.inugami »

Hi, I was installing some tools i'm used to having around on linux; (aircrack-ng, fern-wifi-cracker) but I am having a dependency issue during the installation of fern-wifi-cracker: Dependency: aircrack-ng.

I was able to install aircrack-ng from source but when trying to install fern-wifi-cracker from a *.deb it says

Code: Select all

wolf@inugami ~/Downloads $ sudo dpkg -i Fern*.deb
Selecting previously unselected package fern-wifi-cracker.
(Reading database ... 189262 files and directories currently installed.)
Unpacking fern-wifi-cracker (from Fern-Wifi-Cracker_1.6_all.deb) ...
dpkg: dependency problems prevent configuration of fern-wifi-cracker:
 fern-wifi-cracker depends on aircrack-ng; however:
  Package aircrack-ng is not installed.
 fern-wifi-cracker depends on python-scapy (>= 2.0); however:
  Package python-scapy is not installed.

dpkg: error processing fern-wifi-cracker (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 fern-wifi-cracker
wolf@inugami ~/Downloads $ 
So that told me, aircrack-ng is "not installed?"
When i check to see version:

Code: Select all

wolf@inugami ~/Downloads $ aircrack-ng --help
  Aircrack-ng 1.2 beta1 - (C) 2006-2010 Thomas d'Otreppe
  Original work: Christophe Devine
  http://www.aircrack-ng.org
I can issue commands pertaining to aircrack-ng suit too.

So then I look here:

Code: Select all

 
wolf@inugami ~ $ apt-show-versions python-scapy
^[[Apython-scapy/testing uptodate 2.2.0-1
wolf@inugami ~ $ apt-show-versions aircrack-ng
aircrack-ng not installed (even not available)
wolf@inugami ~ $ 


And it still shows as aircrack-ng not installed...

---puzzled---
:?:
Last edited by wolfe.inugami on Thu Jun 20, 2013 8:43 am, edited 1 time in total.
trapperjohn
Level 5
Level 5
Posts: 849
Joined: Wed Jul 11, 2012 4:10 pm
Contact:

Re: Need help understanding installing from source and depen

Post by trapperjohn »

Have a look at the dpkg man page by running
man dpkg

Scroll down to the info for the "-i" switch.

This suggests that we may solve the problem by running:

sudo dpkg -i YourDeb_package.deb
sudo apt-get -f install
User avatar
wolfe.inugami
Level 1
Level 1
Posts: 7
Joined: Fri Jun 14, 2013 9:48 pm

Re: Need help understanding installing from source and depen

Post by wolfe.inugami »

trapperjohn wrote:Have a look at the dpkg man page by running
man dpkg

Scroll down to the info for the "-i" switch.

This suggests that we may solve the problem by running:

sudo dpkg -i YourDeb_package.deb
sudo apt-get -f install
Thanks for the prompt reply but I fear you might not be understanding me. I will try and clarify.

So I try to install Fern-wifi-cracker.deb:

Code: Select all

wolf@inugami ~/Downloads $ sudo dpkg -i Fern*.deb
[sudo] password for wolf: 
Selecting previously unselected package fern-wifi-cracker.
(Reading database ... 189556 files and directories currently installed.)
Unpacking fern-wifi-cracker (from Fern-Wifi-Cracker_1.6_all.deb) ...
dpkg: dependency problems prevent configuration of fern-wifi-cracker:
 fern-wifi-cracker depends on aircrack-ng; however:
  Package aircrack-ng is not installed.

dpkg: error processing fern-wifi-cracker (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 fern-wifi-cracker


Here' i learn that there are dependency issues where aircrack-ng appears to not be installed even thought I have installed it already from source (unless I've done something wrong or incomplete). Yet, further more, im able to make commands related to aircrack-ng. Is it possible to run the program (aircrack-ng) yet not be installed?

So, I try to install failed dependencies right? "apt-get -f install" and i get this:
(understandably because aircrack-ng is in neither of the repos that come with linux mint debian edition olivia.

Code: Select all

 
wolf@inugami ~/Downloads $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  fern-wifi-cracker
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 3,514 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 189807 files and directories currently installed.)
Removing fern-wifi-cracker ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
It looks like it REMOVED the failed install of Fern-wifi-cracker.deb

My repos are as follow:

Code: Select all

 
deb http://packages.linuxmint.com/ debian main upstream import universe
deb http://mirror.metrocast.net/linuxmint-debian/latest testing main contrib non-free
deb http://mirror.metrocast.net/linuxmint-debian/latest/security testing/updates main contrib non-free
deb http://mirror.metrocast.net/linuxmint-debian/latest/multimedia testing main non-free

## Depôt MultiSystem
deb http://liveusb.info/multisystem/depot all main

I've been trying to keep to the official mint repos and install from source only if needed.

Any additional info you could share much welcome and appreciated! :)
User avatar
wolfe.inugami
Level 1
Level 1
Posts: 7
Joined: Fri Jun 14, 2013 9:48 pm

Re: Need help understanding installing from source and depen

Post by wolfe.inugami »

Ok here's an update...
I read on another forum on how to install Fern-wifi-cracker and it suggested to run the following lines which worked like a charm:

Code: Select all

 
root@host:~# svn checkout http://fern-wifi-cracker.googlecode.com/svn/Fern-Wifi-Cracker/
root@host:~# python execute.py


Fren-wifi-cracker installed and runs. No errors (yet.)

After that, I notcied Aircrack-ng is now in "user/local/bin/aircrack-ng" . -?-
And also, aircrack-ng is still in ~/Downloads/aircrack-ng-1.2-beta1/ " That folder was built when I extracted and made from source.
I deleted the folder "~/Downloads/aircrack-ng-1.2-beta1/" and aircrack-ng still works ok HOWEVER, when running locate aircrack-ng it still lists as ~/Downloads/aircrack-ng-1.2-beta1 even though the folder was deleted. -puzzled-

Explanations welcome.
Thanks.
User avatar
proxima_centauri
Level 11
Level 11
Posts: 3944
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Need help understanding installing from source and depen

Post by proxima_centauri »

Just a reminder to keep this thread focused on installation and dependency resolution only.

Please no information or questions pertaining to usage of these tools as it violates our forum rules.
Post Reply