[SOLVED with bug] Synaptic crashes, apt-get segfaults

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 3
Level 3
Posts: 154
Joined: Sat Sep 17, 2011 11:09 am
Location: Netherlands

[SOLVED with bug] Synaptic crashes, apt-get segfaults

Post by Rua »

I am using Mint 15 MATE edition 64-bit, and I tried to add the removed archive to the software sources through Synaptic. But something went wrong along the way and suddenly it just crashed and exited. I haven't been able to run it again. When I try, the GUI comes up for a moment and then it exits without a notice. Running "apt-get update" (without sudo) gives a segmentation fault, while running "sudo apt-get update" does nothing at all, it just gives back the terminal prompt. I tried restarting but nothing changed, so I am guessing there is something in a configuration file that isn't right. I have no idea what though, and I don't know where to look, but in the meantime I'm not able to install or update anything. Does anyone know what to do?

Edit: I was able to solve it through... trying I suppose. I was puzzled by /etc/apt/sources.list which various online resources referred to. There was nothing in that file, so I checked with my laptop and that was the same, so that was not the problem. Then I noticed there was also /etc/apt/sources.list.d/ which contained more files. One of the files there was removed.list, which I was then able to edit with a text editor. Apparently it had become corrupted, and apt did not like that so it just crashed. I fixed the format by looking at the other files as an example, and now it works.

However, the real cause of this problem was Synaptic's own "repositories" setting! When I used it to add the repository, it created this badly formatted file. I don't know if this is a known problem, but still.

Edit again: It looks like others have had similar problems: http://forums.linuxmint.com/viewtopic.php?f=47&t=138279&p=737510
Level 1
Level 1
Posts: 11
Joined: Wed Jun 10, 2009 12:35 pm

Re: [SOLVED with bug] Synaptic crashes, apt-get segfaults

Post by zota »

I'm having the very same problem with mint 15 and CINNAMON (I saw someone suspicious of MATE...): I'll try your recipe before downgrade to 14 or 13...
Post Reply

Return to “Software & Applications”