<SOLVED> Update Manager Failure

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Level 1
Level 1
Posts: 33
Joined: Sat Jul 03, 2010 1:35 am
Location: Canberra, Australia

<SOLVED> Update Manager Failure

Post by oldal »

When I attempted to update using update manager, the following error messages were shown.
I am using linuxmint-14-KDE-64bit. My PC is amd64 type - J&J motherboard 790 GX extreme;
AMD Phenom II X4 Quad Core processor. I have been able to get updates with kubuntu OS's on the same PC, however I do prefer to use linuxmint.

If I should get some additional information, please let me know how.

I do not know what I can do to enable critical updates. If you can help, kindly let me know.


The following are the error messages by the update manager and two dialogs on CLI to show the running Operating system:

W: GPG error: http://archive.ubuntu.com quantal Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
E: Encountered a section with no Package: header
E: Problem with Mergelists /var/lib/apt/lists/packages.medibuntu.org_dists_quantal_free_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.

ak@supremo ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description: Linux Mint 14 Nadia
Release: 14
Codename: nadia
ak@supremo ~ $

ak@supremo ~ $ sudo uname -a
[sudo] password for ak:
Linux supremo 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ak@supremo ~ $

After reading "apt update failure" thread it seemed to me that the same technique should be applicable to updates with "Update Manager". As a precaution, I saved the
in my home directory, then deleted the offending Translation-en and Translation-en_AU files from the /var/lib/apt lists and doing
sudo apt-get update

After all that the error message is

Fetched 2,347 kB in 30s (76.9 kB/s)
Reading package lists... Done
W: GPG error: http://archive.ubuntu.com quantal Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

So now I will delete all files in the /var/lib/apt/lists and do the "apt-get update". Looks dangerous, but perhaps that will solve the problem. If it does not, then I will copy the list
saved in the HOME directory to /var/lib/apt/ and hope the OS still works, though without updates...

Fetched 21.8 MB in 1min 47s (202 kB/s)
Reading package lists... Done
ak@supremo /var/lib/apt/lists

You see, I have called my black box computer "sujpremo" when I first got it to work. Not very modest, I am afraid. My user name is always "ak".
So far all seems to work - I am relying the comming week on my Lithuanian language installation, as I have to write something in that lovely, but
very complex language. If my linuxmint 14 KDE develops real problems, I will add a note to that effect to this thread. The thread is justified by
the request "please report" in the Update Manager notices when reporting a failure to the users.

Thanks for reading this,
Last edited by oldal on Sat Jul 20, 2013 8:00 am, edited 1 time in total.
OldAl - in Canberra, the capital of Australia

Level 6
Level 6
Posts: 1027
Joined: Fri Jan 25, 2013 3:54 am

Re: Update Manager Failure

Post by kurotsugi »

there are several way to fix it but I found it was the simplest

Code: Select all

- disable all repository
- run 'sudo apt-get update'
- re-enable the repository
- run 'sudo apt-get update' once more 
these trick works like reset button for apt. if you still got problem please give us the result of 'inxi -Fxr'

Post Reply

Return to “Software & Applications”