(BUMP)Enter password for keyring "Default" to unlock

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
nonferrousbueller
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 7:12 pm

(BUMP)Enter password for keyring "Default" to unlock

Post by nonferrousbueller »

Enter password for keyring "Default" to unlock

Getting the above in a pop-up box whenever I open chromium browser. I've tried the instructions in this thread:
[url]http://forums.linuxmint.com/viewtopic.php?f=47&t=117272[/url]
which suggested the following command line entry:

Code: Select all

sudo sed -i 's/gnome_keyring/mate_keyring/g' /etc/pam.d/*
as well as the one here:

[url]http://forums.linuxmint.com/viewtopic.php?f=90&t=137967&p=734829[/url]
Which involved going to keyrings and passwords and setting the password to blank.

With no luck. This thing just won't go away and is driving me MAD. Reminds me of the annoying KDE kwallet, one of the reasons I left that distro!

Running Mint Olivia Cinnamon.

Thanks for any help!
Last edited by nonferrousbueller on Mon Jul 29, 2013 3:55 am, edited 1 time in total.
nonferrousbueller
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 7:12 pm

Re: Enter password for keyring "Default" to unlock

Post by nonferrousbueller »

Bumping this, as I haven't had any luck sorting this out, and it appears that the problem is suffered by others as well:

[url]http://forums.linuxmint.com/viewtopic.php?f=90&t=137967&p=747285#p747285[/url]

I'd file a bug report if I knew it was a bug, but I'm not sure if something is just set wrong.
nonferrousbueller
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 7:12 pm

Re: Enter password for keyring "Default" to unlock

Post by nonferrousbueller »

Sorry to keep bumping this, but it's driving me mad, and is still an issue.

I found a suggestion on the Ubuntu forums (from 2009) that said you should go into passwords, make "login" the default, go into the "default passwords" directory and write down all the passwords for everything in there, delete that keyring, and re-log into every website the file had passwords for. This will be an epic PITA as there are about 50 entries in there, and I'm not sure it will even work (if I was, I'd do it, this is starting to bother me that much!).

Can anyone offer guidance on whether this method might work? Is this where Chrom(e/ium) stores its passwords or am I safe to delete it knowing Chrome has my back?

Thanks


nonferrousbueller wrote:Bumping this, as I haven't had any luck sorting this out, and it appears that the problem is suffered by others as well:

[url]http://forums.linuxmint.com/viewtopic.php?f=90&t=137967&p=747285#p747285[/url]

I'd file a bug report if I knew it was a bug, but I'm not sure if something is just set wrong.
nonferrousbueller
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 7:12 pm

Re: Enter password for keyring "Default" to unlock

Post by nonferrousbueller »

I should add that when I installed Mint I set it up to autologin. A couple of topics have suggested that this could lead to the issue. I went into Users and accounts and set my account to NOT autologin and rebooted. However, the computer didn't prompt me for password on bootup and the Chrome issue still exists. Checking back to the user accounts page, the tickbox for autologin still says "off".

I've set my wife's netbook up with Mint 14 Cinnamon (I'm on 15) and she has the identical problem. It bothers her a lot less than it does me ;)

I should also note - and this may be important - that when the "enter password" dialogue box pops up, I hit "cancel" instead of entering a password, and everything still works i.e. - I don't have to enter web passwords. This is what's leading me to think something is broken.

Argh.
User avatar
tdockery97
Level 14
Level 14
Posts: 5060
Joined: Sun Jan 10, 2010 8:54 am
Location: Mt. Angel, Oregon

Re: (BUMP)Enter password for keyring "Default" to unlock

Post by tdockery97 »

When the Keyring box pops up, are there 2 input boxes (to enter & reenter the password), or only one? If there are two, try just hitting enter when it pops up. It should then ask you if you want to store it as "unsafe". Just hit enter again and it will not pop up again.
Mint MATE 20.1
nonferrousbueller
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 7:12 pm

Re: (BUMP)Enter password for keyring "Default" to unlock

Post by nonferrousbueller »

tdockery97 wrote:When the Keyring box pops up, are there 2 input boxes (to enter & reenter the password), or only one? If there are two, try just hitting enter when it pops up. It should then ask you if you want to store it as "unsafe". Just hit enter again and it will not pop up again.
Nope, there's only one. A couple of the solutions I have come across mention the two boxes, but I haven't seen that yet.
Chrisnz
Level 2
Level 2
Posts: 66
Joined: Sun May 20, 2012 6:08 am
Location: New Zealand

Re: (BUMP)Enter password for keyring "Default" to unlock

Post by Chrisnz »

Yeh I'm now getting this on a later version
-Version-
Kernel : Linux 3.2.0-4-486 (i686)
Compiled : #1 Debian 3.2.32-1
Distribution : LMDE Xfce Edition

Running Mate - For me I now get it on running Evolution Email and what started out as a minor irritation is now a major. I used to be able to just minimize it and see email and edit ok. Now It will not give me that option as a work around. I actually found the password that worked and then the last few days that stopped!. I tried an earlier terminal fix for the same problem I had last year. That didn't work either. I also tried the "set password in default to blank/empty" that didn't work as well.
Has anyone had a fix on this issue for the same conditions?
Chrisnz
Level 2
Level 2
Posts: 66
Joined: Sun May 20, 2012 6:08 am
Location: New Zealand

Re: (BUMP)Enter password for keyring "Default" to unlock

Post by Chrisnz »

for me yesterday - the option to "save password every time run Evolution" was no longer greyed out - so I "went for it" :) problem has ceased!
:D
nonferrousbueller
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 7:12 pm

Re: (BUMP)Enter password for keyring "Default" to unlock

Post by nonferrousbueller »

Chrisnz wrote:for me yesterday - the option to "save password every time run Evolution" was no longer greyed out - so I "went for it" :) problem has ceased!
:D
STILL having this issue, slowly driving me mad. SOMEONE must have an answer. Is there a way to disable the keyring?

Again, I'm running Cinnamon, so Evolution not installed. This is popping up when I run Chrome. Seriously considering trying another distro at this point, which is frustrating as everything else in Mint is so far better than my experience with Kubuntu.
User avatar
NM5TF
Level 2
Level 2
Posts: 51
Joined: Sat Feb 16, 2013 10:10 pm
Location: Magdalena, New Mexico
Contact:

Re: (BUMP)Enter password for keyring "Default" to unlock

Post by NM5TF »

having the exact same problem as @nonferrousbueller...

opening Chromium gives the dreaded "enter password to unlock keyring" as is common in Ubuntu 12.04...

this only started to happen after the last update maybe 1-2 weeks ago...was this propagated from Ubu ??

mostly just an annoyance as I can just hit cancel & proceed as usual

has anyone filed a bug report yet ???

Tommy
Linux Mint 18.3 Sylvia, Arch Linux, openSUSE Tumbleweed Linux
Registered Linux User # 529389
my improved web page http://users.gilanet.com/~tfrost
Hutch
Level 1
Level 1
Posts: 18
Joined: Sat Mar 14, 2009 6:25 pm

Re:Enter password for keyring "Default" to unlock {SOLVED}

Post by Hutch »

go to Peferences -> Passwords + Keys ->View. right click on Login and Change Password -> Give old p/w and change to Blank. The old password is set to your user password by default.
nonferrousbueller
Level 1
Level 1
Posts: 45
Joined: Tue Apr 09, 2013 7:12 pm

Re: Re:Enter password for keyring "Default" to unlock

Post by nonferrousbueller »

Hutch wrote:go to Peferences -> Passwords + Keys ->View. right click on Login and Change Password -> Give old p/w and change to Blank. The old password is set to your user password by default.
Thanks for the try Hutch, but that doesn't help. Still have the issue. Still driving me nuts!
kcaldwel
Level 2
Level 2
Posts: 58
Joined: Sat Mar 08, 2014 6:16 pm

Re: (BUMP)Enter password for keyring "Default" to unlock

Post by kcaldwel »

I think I just managed to fix this for Mint 16 Cinnamon. I opened Passwords and Keys from the Menu, select View, By Keyring. I was very brave (stupid?) and right clicked the Default (locked), and deleted it.

Next time I opened Chrome, I was asked for a new Keyring password. I just left it blank, and accepted the unsecure message. Now it doesn't ask for a Keyring password when I open Chrome, and the Default Keyring shows as unlocked in the Password and Keys window.

So far, so good!

Kevin
Chrisnz
Level 2
Level 2
Posts: 66
Joined: Sun May 20, 2012 6:08 am
Location: New Zealand

Re: (BUMP)Enter password for keyring "Default" to unlock

Post by Chrisnz »

I'm running Chromium Version 34.0.1847.116 Built on Ubuntu 13.10, running on LinuxMint 16 - No issues so far. I just get caught occasionally now with Evolution requireing passwords when I try to Send emails.

Your right nusance value at the moment and that too "Will Pass in time" ;)

Cheers Guys
Post Reply

Return to “Software & Applications”