Both NetBeans 7.0.1 and 7.3.1 will now work.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Obsidian
Level 1
Level 1
Posts: 1
Joined: Sat Aug 03, 2013 10:17 pm

Both NetBeans 7.0.1 and 7.3.1 will now work.

Post by Obsidian »

Hello I am new to Linux and Mint is the first one I've used so far.

My problem is that I have tried to download Netbeans via Synaptic package manger and that was outdated, version 7.0.1, it opens fine but when I go "new project" it tell me to "Please wait" and I cannot continue any further.
So I tired to download version 7.3.1 from the site, It tells me warning could not install some modules and the gui locks up. What am I doing wrong?
I am using the latest version of Mint Linux with KDE if that makes any difference.

Thanks
- Obsidian
User avatar
z1p101
Level 1
Level 1
Posts: 31
Joined: Tue Jul 24, 2012 7:29 pm

Re: Both NetBeans 7.0.1 and 7.3.1 will now work.

Post by z1p101 »

Netbeans runs in the Java Runtime Enviroment (JRE) and technically does not have to be "installed". You can open a terminal and cd into the netbeans/bin directory that you unpacked and just type netbeans and it should start.

You also have to make sure you installed a java JDK first. You can install the openjdk using the package manager or install the oracle jdk which may work better using the [url=http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html]instructions here[/url].
MacCruiskeen
Level 1
Level 1
Posts: 10
Joined: Sun Dec 30, 2012 12:30 pm

Re: Both NetBeans 7.0.1 and 7.3.1 will now work.

Post by MacCruiskeen »

I'm having exactly the same issue with Mint 15 and Netbeans. I had it set running fine (on an older laptop) with Mint 14. I've got openjdk installed. It just crashes with an error window saying various modules not found.
teatime
Level 2
Level 2
Posts: 67
Joined: Thu Aug 16, 2012 12:47 pm

Re: Both NetBeans 7.0.1 and 7.3.1 will now work.

Post by teatime »

Netbeans needs the openjdk development files: openjdk-6-jdk (sudo apt-get install openjdk-6-jdk) as out of the box only openjdk-6-jre is installed and afterwards it should work.
MacCruiskeen
Level 1
Level 1
Posts: 10
Joined: Sun Dec 30, 2012 12:30 pm

Re: Both NetBeans 7.0.1 and 7.3.1 will now work.

Post by MacCruiskeen »

Okay--I figured it out. The problem was that Netbeans wasn't looking in the right place for the JDK. I reinstalled, and made sure to check when it asked to select the Java folder. Now it works.
MacCruiskeen
Level 1
Level 1
Posts: 10
Joined: Sun Dec 30, 2012 12:30 pm

Re: Both NetBeans 7.0.1 and 7.3.1 will now work.

Post by MacCruiskeen »

All right, I spoke too soon. Now when I try to start a new project, ithangs while loading the types of projects. Sigh.
Indunil
Level 1
Level 1
Posts: 1
Joined: Wed Oct 29, 2014 11:24 pm

Re: Both NetBeans 7.0.1 and 7.3.1 will now work.

Post by Indunil »

When will it work Netbeans 8? :(
Post Reply

Return to “Software & Applications”