Unable to install gparted [SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
odo5435
Level 4
Level 4
Posts: 374
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Unable to install gparted [SOLVED]

Postby odo5435 » Mon Sep 23, 2013 4:04 am

I've tried the Software Manager which shows gparted but hitting the install button achieves nothing. Synaptic and apt-get both end with the error message

Code: Select all

Err http://archive.getdeb.net/ubuntu/ quantal-getdeb/apps gparted amd64 0.16.1-1~getdeb1
  404  Not Found
Failed to fetch http://archive.getdeb.net/ubuntu/pool/apps/g/gparted/gparted_0.16.1-1~getdeb1_amd64.deb 404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Trying Update didn't solve the problem, the apt-get -fix-missing command didn't work and that's the limit of my skills. I'm now just frustrated.

My software sources are the probably causing the problem but I don't know which repos to point to. Currently /etc/apt/sources.list contains (I use the Internode mirrors 'cos I'm a customer of theirs and download speeds are very good).:

Code: Select all

deb http://mirror.internode.on.net/pub/linuxmint-packages/ nadia upstream import main backport
deb http://mirror.internode.on.net/pub/ubuntu/ubuntu/ quantal main restricted universe multiverse
deb http://mirror.internode.on.net/pub/ubuntu/ubuntu/ quantal-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ quantal partner
# deb http://packages.medibuntu.org/ quantal free non-free

deb http://archive.getdeb.net/ubuntu quantal-getdeb apps
deb http://archive.getdeb.net/ubuntu quantal-getdeb games


Just in case they're relevant here are my system specifications:

Code: Select all

markate@markate-Desktop ~ $ inxi -Fxx
System:    Host: markate-Desktop Kernel: 3.5.0-17-generic x86_64 (64 bit, gcc: 4.7.2)
           Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine:   Mobo: ASUSTeK model: P8Z77-V LX version: Rev X.0x Bios: American Megatrends version: 1502 date: 11/09/2012
CPU:       Quad core Intel Core i5-3470 CPU (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25675.8
           Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz
Graphics:  Card: NVIDIA GK107 [GeForce GT 630] bus-ID: 01:00.0
           X.Org: 1.13.0 driver: nvidia Resolution: 1680x1050@60.0hz, 1024x768@60.0hz
           GLX Renderer: GeForce GT 630/PCIe/SSE2 GLX Version: 4.2.0 NVIDIA 304.88 Direct Rendering: Yes
Audio:     Card-1: NVIDIA GF108 High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network:   Card-1: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: eth0 state: down mac: 08:60:6e:f4:53:e7
           Card-2: Ralink RT2070 Wireless Adapter driver: rt2800usb ver: 2.3.0 usb-ID: 148f:2070
           IF: wlan0 state: up mac: 74:ea:3a:8e:71:0a
Drives:    HDD Total Size: 1370.3GB (73.8% used) 1: id: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB serial: 50026B723200A818 temp: 32C
           2: id: /dev/sdb model: WDC_WD10EACS size: 1000.2GB serial: WD-WCAU42655230 temp: 38C
           3: id: /dev/sdc model: ST3250820AS size: 250.1GB serial: 3QE06CFH temp: 43C
Partition: ID: / size: 9.7G used: 4.7G (52%) fs: ext4 ID: /home size: 97G used: 69G (76%) fs: ext4
RAID:      System: supported: N/A
           No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:41C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 163 Uptime: 47 min Memory: 1213.1/7936.9MB Runlevel: 2 Gcc sys: 4.7.2 Client: Shell inxi: 1.8.4
Last edited by odo5435 on Mon Sep 23, 2013 5:26 am, edited 1 time in total.
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon

User avatar
daveinuk
Level 7
Level 7
Posts: 1526
Joined: Tue Mar 23, 2010 7:52 pm
Location: Manchester, England.
Contact:

Re: Unable to install gparted

Postby daveinuk » Mon Sep 23, 2013 4:31 am

Have you previously uninstalled it, it's already installed on my LM13 cinnamon?

User avatar
odo5435
Level 4
Level 4
Posts: 374
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Re: Unable to install gparted

Postby odo5435 » Mon Sep 23, 2013 4:52 am

daveinuk wrote:Have you previously uninstalled it, it's already installed on my LM13 cinnamon?

No, not deliberately anyway. :lol:

It's been installed on all my past LM versions also. I can't recall having used Gparted since I installed LM14. It's likely that I used it immediately after installation though I can't say for sure that I did. It certainly ain't there now:

Code: Select all

markate@markate-Desktop ~ $ sudo gparted
[sudo] password for markate:
sudo: gparted: command not found

Which has led me here. :?
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon

User avatar
odo5435
Level 4
Level 4
Posts: 374
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Re: Unable to install gparted [SOLVED]

Postby odo5435 » Mon Sep 23, 2013 5:39 am

While browsing I came upon an instruction to run 'apt-get upgrade' in a thread on a totally unrelated matter. Having nothing to lose i ran the command and, sure enough, Gparted was able to be installed. Dunno why that one worked, just grateful that it did.

That just leaves the mystery of what happened to the initial installation. It probably had something to do with the part between the chair and the keyboard but, for the life of me i can't recall having done anything with GParted since installing LM14, let alone deleting it. I've hardly done any tweaking at all. :? :!:
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon

ninomrki
Level 3
Level 3
Posts: 100
Joined: Wed Jan 16, 2013 7:49 pm
Location: Zagreb, Croatia
Contact:

Re: Unable to install gparted [SOLVED]

Postby ninomrki » Mon Sep 23, 2013 5:04 pm

I installed both 32 and 64 bit versions of Mint 14 MATE and neither had Gparted installed by default.
Home is where the Wi-Fi is.

Registered Linux user #562302

User avatar
odo5435
Level 4
Level 4
Posts: 374
Joined: Thu Mar 31, 2011 1:21 am
Location: Perth, Westerm Australia

Re: Unable to install gparted [SOLVED]

Postby odo5435 » Mon Sep 23, 2013 9:21 pm

Ahhh, thank you @ninomrki, I feel somehow vindicated. 8) I'd been racking my brain trying to recall how I might have removed it. Considering the checks and balances in the system it is hard to remove software by mistake.

I've been trying to find a list of all software that's included in the release. You'd think it would be easy to find that list somewhere on the LM website but 15 - 20 minutes of searching failed to find a list. Not on this page nor on this page. You would think there would at least be a link to a full list somewhere on these pages. I'd be happy for someone to point me to it.

The best list I can find is the one at Distrowatch which doesn't mention Gparted as being included in any of the releases. I know that's not right.

EDIT= Ah, i found that I had to hit the refresh button on Distrowatch's page to get the complete list of included software. It shows that GParted V0.12.1 is indeed supposed to be included. Which brings me back to wondering what happened to my (and ninomrki's) copy. :x
LinuxMint 14 'Nadia' 64-bit dual boot with Win' 7 :::<<>>::: Linux Registered User No. 545697
Kernel: Linux 3.5.0-17-generic (x86_64) >< Cinnamon


Return to “Software & Applications”