Could not refresh the list packages.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
fredhoud
Level 1
Level 1
Posts: 26
Joined: Thu Oct 24, 2013 10:22 pm

Could not refresh the list packages.

Post by fredhoud »

Could not refresh the list packages.
Linux Mint 15 KDE
OS Version: Linux 3.8.0-26-generic
KDE SC Version: 4.10.5

When you start the computer, at the lower bottom right hand side of screen, you get a red X saying "could not refresh the list package. When you click on the icon, a message pops out saying, "Could not download all repository indexes".

The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.

ERROR###ERROR###ERROR###ERROR###ERROR###ERROR###ERROR
W:Failed to fetch http://packages.medibuntu.org/dists/raring/Release.gpg Something wicked happened resolving 'packages.medibuntu.org:http' (-11 - System error)
, W:Failed to fetch http://packages.medibuntu.org/dists/raring/free/i18n/Translation-en Something wicked happened resolving 'packages.medibuntu.org:http' (-11 - System error)
, W:Failed to fetch http://packages.medibuntu.org/dists/raring/non-free/i18n/Translation-en Something wicked happened resolving 'packages.medibuntu.org:http' (-11 - System error)
, W:Failed to fetch http://packages.medibuntu.org/dists/raring/free/binary-amd64/Packages Something wicked happened resolving 'packages.medibuntu.org:http' (-11 - System error)
, W:Failed to fetch http://packages.medibuntu.org/dists/raring/non-free/binary-amd64/Packages Something wicked happened resolving 'packages.medibuntu.org:http' (-11 - System error)
, W:Failed to fetch http://packages.medibuntu.org/dists/raring/free/binary-i386/Packages Something wicked happened resolving 'packages.medibuntu.org:http' (-11 - System error)
, W:Failed to fetch http://packages.medibuntu.org/dists/raring/non-free/binary-i386/Packages Something wicked happened resolving 'packages.medibuntu.org:http' (-11 - System error)
, E:Some index files failed to download. They have been ignored, or old ones used instead.

Is there any solution to this problem, or is it going to fix when a major update becomes available?
Thanks in advance,
FredHoud
User avatar
karlchen
Level 21
Level 21
Posts: 13363
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Could not refresh the list packages.

Post by karlchen »

Hello, FredHoud.

Rumours say there is a sticky thread about the problem which you reported: [url=http://forum.linuxmint.com/viewtopic.php?f=90&t=147271]How to fix: update errors about Medibuntu[/url].

Cheers,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)
fredhoud
Level 1
Level 1
Posts: 26
Joined: Thu Oct 24, 2013 10:22 pm

Re: Could not refresh the list packages.

Post by fredhoud »

Hi karl,

I opened the root terminal and typed "apt-get update", and then I ran it. It went through the update process. then I typed the following command you provided:
"sudo sed -i '/^deb http:\/\/packages.medibuntu.org*/d' /etc/apt/sources.list /etc/apt/sources.list.d/*.list".
How ever nothing happened, but it seemed that it worked when I ran the update. I restarted the computer, and no error message popped out. I'll keep you inform if it shows up again.
I switched from Ununtu 13.10 to Linux Mint 15 KDE, and I absolutely love it even more than ever since this is all fixed.
Thanks a lot Karl, I really appreciate your help.

Fred
User avatar
karlchen
Level 21
Level 21
Posts: 13363
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Could not refresh the list packages.

Post by karlchen »

Hello, Fredhoud.

1. Problem where the instruction fails for you:

Isn't this a nice challenge that with every new release a few details keep on changing so as to make a step by step instruction which works fine on Mint 13 and Mint 14 useless on Mint 15? :wink:
Up to Mint 14 the main file which pointed to the Linux Mint repository and to the Ubuntu repositories and to the Medibuntu repository, too, was the file /etc/apt/sources.list.
Other repositories which a user added himself later on would be found in *.list files in the subfolder /etc/apt/sources.list.d.
It seems that starting with Mint 15, the main file is now /etc/apt/sources.list.d/official-package-repositories.list.
So you will have to work on /etc/apt/sources.list.d/official-package-repositories.list, not /etc/apt/sources.list.

2. Problem where the instruction fails for you:

apt-get: Any apt-get command line has got to be run with root privileges. Example:

Code: Select all

sudo apt-get update
Yet, before this commandline will succeed the 1st problem has got to be solved.

Essence:

Instead of sending you to xenopeek's post, I should have sent you a few posts further down in the same thread. [url=http://forum.linuxmint.com/viewtopic.php?p=773839#p773839]Here iowabeakster explains[/url] how to correct the main sources list file in all cases where this file is named /etc/apt/sources.list.d/official-package-repositories.list.

Step 1:
With root privileges edit /etc/apt/sources.list.d/official-package-repositories.list and remove any line which mentions http://packages.medibuntu.org.

Step 2:
Execute

Code: Select all

sudo apt-get update
HTH,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)
JackBW
Level 1
Level 1
Posts: 28
Joined: Thu Sep 03, 2009 10:28 am

Re: Could not refresh the list packages.

Post by JackBW »

I've done all this (KDE 15) and still getting the same error messages.

First, I run--

inxi -r

which gives me--
Repos: Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com/ olivia main upstream import
deb http://archive.ubuntu.com/ubuntu raring main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu raring-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ raring partner


Then--

sudo apt-get update

Which yields (after a long list of packages) --

GPG error: http://archive.ubuntu.com raring Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_raring_main_i18n_Translation-en%5fUS
E: The package lists or status file could not be parsed or opened.

The red "X" is still in the panel, won't update, and the Software Manager won't load after entering my password.
"Did you ever get the feeling the world was a tuxedo, and you were a pair of brown shoes?"--George Gobel
User avatar
karlchen
Level 21
Level 21
Posts: 13363
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Could not refresh the list packages.

Post by karlchen »

Hello, JackBW.

As your error messages are not about Medibuntu, your problem has got a different root cause.

Open a terminal window and execute these commands:

Code: Select all

cd /var/lib/apt
sudo mv lists lists_prev
sudo mkidr -p lists/partial
sudo apt-get update
Provided the error message that you reported does not occur again you may remove the renamed backup of the "lists" subfolder tree "/var/lib/apt/lists_prev".

Kind regards,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)
mrs_geekwanabe
Level 1
Level 1
Posts: 1
Joined: Sat Mar 29, 2014 2:58 pm
Location: Washington, DC; USA

Re: Could not refresh the list packages.

Post by mrs_geekwanabe »

Thank you, Karl! This worked for me!
Dell Studio 17 - Linux Mint KDE 15
Toshiba Portege M400 - Linux Mint 15
Compaq C700 - Kubuntu 12.04
AnnieB
Level 1
Level 1
Posts: 5
Joined: Mon Apr 28, 2014 12:09 am

Re: Could not refresh the list packages.

Post by AnnieB »

Thank you Karl! This just worked for me too. :D
AnnieB
Level 1
Level 1
Posts: 5
Joined: Mon Apr 28, 2014 12:09 am

Re: Could not refresh the list packages.

Post by AnnieB »

The problem occurred again a week ago and was fixed by repeating the advice. However it's just happened again and the fix didn't work. Is there anything else I can try? Hopefully nothing too grunty because I'm still taking very little steps with this stuff.
Thanks. :?
Post Reply

Return to “Software & Applications”