Broken packages - firefox-3.0

Questions about applications and software
Forum rules
Before you post please read how to get help
Spewbacca
Level 1
Level 1
Posts: 26
Joined: Mon Aug 27, 2007 5:56 pm
Location: Virginia - USA
Contact:

Broken packages - firefox-3.0

Postby Spewbacca » Thu Jul 24, 2008 3:50 pm

LM5-Elyssa newly installed today, firefox was displayed on the launcher.
Completed the basic system setup steps network cfg, printer setup, etc, etc,
after which I did: apt-get update, and then apt-get dist-upgrade all seemed well.
Except now I notice firefox is missing from launcher.
So I do...
# dpkg -l firefox
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
rc firefox 3.0~rc1+nobino meta package for the popular mozilla web bro

??
Next I try...
# apt-get install firefox-3.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
firefox-3.0: Depends: xulrunner-1.9 (>= 1.9~rc) but it is not going to be installed
E: Broken packages

What's the prob ? repository fouled up ??

# apt-get install opera
yields a fine/working browser ...but I'd sure like to get firefox installed again.

Any idea how I'd accomplish this?

Thx!

Dark_Fire
Level 1
Level 1
Posts: 25
Joined: Tue Jun 24, 2008 5:31 pm

Re: Broken packages - firefox-3.0

Postby Dark_Fire » Thu Jul 24, 2008 4:41 pm

I have actually posted on this.

viewtopic.php?f=47&t=15232

So your not alone. But lets try and keep it to one thread. No point in making 50. :)

Im sure its just a small upgrade error.
Processor: Intel(R) Pentium(R) 4, 2.8GHz Dule Core
RAM: 2x 256MB + 2x 512MB (1.5GB)
HDD: 80GB, 400GB SATA (480BG)
Graphics Card: ATI Radeon 9200
OS: LinuxMint 5 Elyssa

msuggs
Level 5
Level 5
Posts: 880
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local
Contact:

Re: Broken packages - firefox-3.0

Postby msuggs » Thu Jul 24, 2008 5:21 pm

Dark_Fire wrote:
Im sure its just a small upgrade error.


or maybe a sudo ap-get upgrade error

Stick to mintUpdate and the levelled updates.

User avatar
clem
Level 15
Level 15
Posts: 5667
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: Broken packages - firefox-3.0

Postby clem » Thu Jul 24, 2008 7:01 pm

An Ubuntu update on xulrunner broke our own version of firefox. The problem is gone now that we've upgraded FF to 3.0.1. Make sure to stick to mintUpdate and to level 1 and 2. Choose updates level 3 selectively.

Explanations and solution for this problem: http://www.linuxmint.com/forum/viewtopi ... 448#p93448

Clem.
Image

Spewbacca
Level 1
Level 1
Posts: 26
Joined: Mon Aug 27, 2007 5:56 pm
Location: Virginia - USA
Contact:

Re: Broken packages - firefox-3.0

Postby Spewbacca » Thu Jul 24, 2008 11:46 pm

clem wrote:An Ubuntu update on xulrunner broke our own version of firefox. The problem is gone now that we've upgraded FF to 3.0.1. Make sure to stick to mintUpdate and to level 1 and 2. Choose updates level 3 selectively.

Explanations and solution for this problem: viewtopic.php?f=6&p=93448#p93448

Clem.


Thx Clem!
I didn't realize the advantages of using mintUpdate vs command line updating via apt-get ...the old debian habits die hard, don't you know. :oops: :arrow:

Spewbacca
Level 1
Level 1
Posts: 26
Joined: Mon Aug 27, 2007 5:56 pm
Location: Virginia - USA
Contact:

Re: Broken packages - firefox-3.0

Postby Spewbacca » Fri Jul 25, 2008 12:36 am

Dark_Fire wrote:I have actually posted on this.

viewtopic.php?f=47&t=15232

So your not alone. But lets try and keep it to one thread. No point in making 50. :)

Im sure its just a small upgrade error.

Sorry Darky... :roll: I didn't mean to steal your spot light!

Dark_Fire wrote:I got really down. Didn't know what to do or where to go.
Hope this it the right place.
And yea, I get like this when I'm low on energy. :P
Thanks in advance. Love you guys!
The Dark_Fire!

I sure hope you've cheered up, and re-energized by now.
BONUS ...the " Broken packages - firefox-3.0" issue has been resolved :D

Dark_Fire
Level 1
Level 1
Posts: 25
Joined: Tue Jun 24, 2008 5:31 pm

Re: Broken packages - firefox-3.0

Postby Dark_Fire » Sat Jul 26, 2008 6:46 am

Yea, you better be. Now your post has more replies than mine. I hope you feel ashamed.

lol. Its cool man. Least you said sorry. :)

Anyway. Just wanted to know. (guess I should start a new thread) but, when I installed mint 1st time everything worked. This time compiz wasnt enabled by default.

I have a ATI Radeon 9200. According to EnvyNG (this also happened in my old installation) the driver isnt supported for my OS. I dont understand. And what driver did I run last that isnt installed now?

I want me compiz back :(

(PS: I formatted coz I screwed it so up that I couldnt evin update anymore. Guess it didnt wanne play with me anymore :( o well)
Processor: Intel(R) Pentium(R) 4, 2.8GHz Dule Core
RAM: 2x 256MB + 2x 512MB (1.5GB)
HDD: 80GB, 400GB SATA (480BG)
Graphics Card: ATI Radeon 9200
OS: LinuxMint 5 Elyssa


Return to “Software & Applications”

Who is online

Users browsing this forum: cliffcoggin and 14 guests