Page 1 of 1

Anyone else having trouble with AdBlock on Mint?

Posted: Tue Dec 10, 2013 9:30 pm
by hoppimike
Hey peeps :)

I have AdBlock Plus with 2 subscriptions on here (EasyList and Facebook Annoyances Blocker). I have also whitelisted linuxmint.com and duckduckgo.com :wink:

Aaaaanywho, on Windows all the adds on Facebook went bye-bye even with just EasyList I think, but on here I get broken images on them but still lots of ads.

Anyone else have any problems?

Re: Anyone else having trouble with AdBlock on Mint?

Posted: Tue Dec 10, 2013 10:24 pm
by gold_finger
You may already know this, but just in case....

Open Adblock's "Filter preferences"
adblock1.png
Then make sure to un-check the box next to "Allow some non-intrusive advertising". Facebook may be one of the ones they get funding from, thus allow through the filter.
adblock2.png
If that doesn't do it, try clicking the Adblock button and picking "Open blockable items". There will probably be tons of things listed, but maybe you can figure out which are the offenders and block them manually that way.

Otherwise, an addon called "RequestPolicy" blocks just about everything. Can be a pain to use though. Similar to NoScript (if you've used that) -- you'll need to tell it what to allow on all the sites you visit. Over time, as you've set the preferences for various site, it won't be in the way so much -- but will definitely make casual browsing a nuisance for a while.

Re: Anyone else having trouble with AdBlock on Mint?

Posted: Tue Dec 10, 2013 10:40 pm
by hoppimike
Oh, seems it's a Chromium problem - it works fine on Firefox with the same settings.

Odd.

Even right clicking something and saying "Block Element" doesn't work on Chromium :(

Re: Anyone else having trouble with AdBlock on Mint?

Posted: Wed Dec 11, 2013 4:11 am
by ImpliedConsent
hoppimike wrote:Oh, seems it's a Chromium problem - it works fine on Firefox with the same settings. Odd. Even right clicking something and saying "Block Element" doesn't work on Chromium :(
It's a Chrome browser/Adblock issue, not a Linux or Mint issue. Been seeing this for the past 2-3 days. I just reload the extension and it works fine. https://productforums.google.com/forum/ ... ies/chrome .

Re: Anyone else having trouble with AdBlock on Mint?

Posted: Wed Dec 11, 2013 8:48 am
by hoppimike
Ah ok. Well, good to know where the problem lies anyway, and that's good that reloading the plugin might work - I'll try that :)

Thanks!