Broken packages? <SOLVED>

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
kennerd
Level 1
Level 1
Posts: 4
Joined: Fri Jul 26, 2013 10:35 am

Broken packages? <SOLVED>

Post by kennerd »

When I select a package in Synaptic, the checkbox turns red. Applying changes results in:

Code: Select all

Could not apply changes! 
Fix broken packages first.
When I do that, I get this error:

Code: Select all

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
With apt-get in the terminal, I get this for anything I try to install:

Code: Select all

sudo apt-get install gedit
[sudo] password for kenmint16: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gedit : Depends: python-support (>= 0.90.0) but it is not installable
         Depends: libgtksourceview2.0-0 (>= 2.10.0) but it is not installable
         Depends: python-gtksourceview2 (>= 2.9.2) but it is not installable
E: Unable to correct problems, you have held broken packages.
This is on a fresh install of Mint 16, KDE. Is it just me, or are the repositories broken?
Last edited by kennerd on Sat Jan 18, 2014 5:03 pm, edited 1 time in total.

User avatar
xenopeek
Level 24
Level 24
Posts: 24279
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Broken packages?

Post by xenopeek »

Run the following commands to give us some diagnostics. Share the output here please (see Edit menu in Konsole for copying text).

Code: Select all

apt-cache stats

Code: Select all

apt-cache policy gedit gedit-common
Image

kennerd
Level 1
Level 1
Posts: 4
Joined: Fri Jul 26, 2013 10:35 am

Re: Broken packages?

Post by kennerd »

Thank you for the reply! Here's the results:

Code: Select all

kenmint16@kenmint16:~ > apt-cache stats
Total package names: 4568 (91.4 k)
Total package structures: 7240 (405 k)
  Normal packages: 2468
  Pure virtual packages: 88
  Single virtual packages: 666
  Mixed virtual packages: 19
  Missing: 3999
Total distinct versions: 2490 (179 k)
Total distinct descriptions: 2224 (53.4 k)
Total dependencies: 25977 (727 k)
Total ver/file relations: 2574 (61.8 k)
Total Desc/File relations: 2224 (53.4 k)
Total Provides mappings: 946 (18.9 k)
Total globbed strings: 135 (1,225 )
Total dependency version space: 137 k
Total slack space: 41.2 k
Total space accounted for: 1,435 k


kenmint16@kenmint16:~ > apt-cache policy gedit gedit-common
gedit:
  Installed: (none)
  Candidate: 2.30.5+petra
  Version table:
     2.30.5+petra 0
        700 http://packages.linuxmint.com/ petra/upstream amd64 Packages
gedit-common:
  Installed: 2.30.5+petra
  Candidate: 2.30.5+petra
  Version table:
 *** 2.30.5+petra 0
        700 http://packages.linuxmint.com/ petra/upstream amd64 Packages
        100 /var/lib/dpkg/status

kennerd
Level 1
Level 1
Posts: 4
Joined: Fri Jul 26, 2013 10:35 am

Re: Broken packages?

Post by kennerd »

I am getting a bunch of 404 errors when doing the update and dist-upgrade.

Code: Select all

kenmint16@kenmint16:~ > sudo apt-get update && sudo apt-get dist-upgrade
[sudo] password for kenmint16: 
Ign http://dl.google.com stable InRelease
Ign http://packages.linuxmint.com petra InRelease                                                                                             
Ign http://extra.linuxmint.com petra InRelease                                                                                                
Hit http://dl.google.com stable Release.gpg                                                                                                   
Get:1 http://packages.linuxmint.com petra Release.gpg [198 B]                                                                                 
Hit http://dl.google.com stable Release                                                                                                       
Get:2 http://extra.linuxmint.com petra Release.gpg [198 B]                                                                                    
Get:3 http://packages.linuxmint.com petra Release [18.5 kB]                                                                                   
Hit http://dl.google.com stable/main amd64 Packages                                                                                           
Get:4 http://extra.linuxmint.com petra Release [3,090 B]                                                                                      
Ign http://security.ubuntu.com petra-security InRelease                                                                                       
Ign http://archive.ubuntu.com petra InRelease                                                                                                 
Ign http://ppa.launchpad.net saucy InRelease                                                                                                  
Ign http://archive.canonical.com petra InRelease                                                                                              
Hit http://dl.google.com stable/main i386 Packages                                                                                            
Get:5 http://extra.linuxmint.com petra/main amd64 Packages [655 B]                                                                            
Get:6 http://packages.linuxmint.com petra/main amd64 Packages [29.3 kB]                                                                       
Get:7 http://extra.linuxmint.com petra/main i386 Packages [655 B]                                                                             
Ign http://security.ubuntu.com petra-security Release.gpg                                                                                     
Ign http://archive.ubuntu.com petra-updates InRelease                                                                                         
Hit http://ppa.launchpad.net saucy Release.gpg                                                                                                
Ign http://archive.canonical.com petra Release.gpg                                                                                            
Hit http://downloads.sourceforge.net all InRelease                                                                                            
Get:8 http://packages.linuxmint.com petra/upstream amd64 Packages [23.3 kB]                                                                   
Ign http://security.ubuntu.com petra-security Release                                                                                         
Ign http://archive.ubuntu.com petra Release.gpg                                                                                               
Hit http://ppa.launchpad.net saucy Release                                                                                                    
Ign http://archive.canonical.com petra Release                                                                                                
Get:9 http://packages.linuxmint.com petra/import amd64 Packages [40.1 kB]                                                                     
Ign http://archive.ubuntu.com petra-updates Release.gpg                                                                                       
Hit http://ppa.launchpad.net saucy/main Sources                                                                                               
Ign http://dl.google.com stable/main Translation-en_US                                                                                        
Hit http://downloads.sourceforge.net all/main amd64 Packages                                                                                  
Ign http://archive.ubuntu.com petra Release                                                                                                   
Hit http://ppa.launchpad.net saucy/main amd64 Packages                                                                                        
Ign http://dl.google.com stable/main Translation-en                                                                                           
Get:10 http://packages.linuxmint.com petra/main i386 Packages [28.7 kB]                                                                       
Hit http://downloads.sourceforge.net all/main i386 Packages                                                                                   
Ign http://archive.ubuntu.com petra-updates Release                                                                                            
Hit http://ppa.launchpad.net saucy/main i386 Packages                                                                                          
Get:11 http://packages.linuxmint.com petra/upstream i386 Packages [23.3 kB]                                                                    
Get:12 http://packages.linuxmint.com petra/import i386 Packages [40.5 kB]                                                                      
Ign http://extra.linuxmint.com petra/main Translation-en_US                                                                                    
Ign http://extra.linuxmint.com petra/main Translation-en                                                                                       
Ign http://downloads.sourceforge.net all/main Translation-en_US                                                                               
Ign http://downloads.sourceforge.net all/main Translation-en                                                                                  
Ign http://ppa.launchpad.net saucy/main Translation-en_US                                                         
Ign http://ppa.launchpad.net saucy/main Translation-en                                                            
Err http://archive.canonical.com petra/partner amd64 Packages                                                                
  404  Not Found [IP: 91.189.92.150 80]
Ign http://packages.linuxmint.com petra/import Translation-en_US                            
Ign http://packages.linuxmint.com petra/import Translation-en         
Ign http://packages.linuxmint.com petra/main Translation-en_US                              
Err http://archive.canonical.com petra/partner i386 Packages                                                                 
  404  Not Found [IP: 91.189.92.150 80]
Ign http://packages.linuxmint.com petra/main Translation-en                                                                  
Ign http://archive.canonical.com petra/partner Translation-en_US                                                             
Ign http://packages.linuxmint.com petra/upstream Translation-en_US                          
Ign http://packages.linuxmint.com petra/upstream Translation-en                             
Ign http://archive.canonical.com petra/partner Translation-en                               
Err http://security.ubuntu.com petra-security/main amd64 Packages                                                                             
  404  Not Found [IP: 91.189.92.201 80]
Err http://security.ubuntu.com petra-security/restricted amd64 Packages                                                                       
  404  Not Found [IP: 91.189.92.201 80]
Err http://security.ubuntu.com petra-security/universe amd64 Packages                                                                         
  404  Not Found [IP: 91.189.92.201 80]
Err http://security.ubuntu.com petra-security/multiverse amd64 Packages                                                                       
  404  Not Found [IP: 91.189.92.201 80]
Err http://security.ubuntu.com petra-security/main i386 Packages                                                                              
  404  Not Found [IP: 91.189.92.201 80]
Err http://security.ubuntu.com petra-security/restricted i386 Packages                                                                        
  404  Not Found [IP: 91.189.92.201 80]
Err http://security.ubuntu.com petra-security/universe i386 Packages                                                                          
  404  Not Found [IP: 91.189.92.201 80]
Err http://security.ubuntu.com petra-security/multiverse i386 Packages                                                                        
  404  Not Found [IP: 91.189.92.201 80]
Ign http://security.ubuntu.com petra-security/main Translation-en_US                                                                          
Ign http://security.ubuntu.com petra-security/main Translation-en                                                                             
Ign http://security.ubuntu.com petra-security/multiverse Translation-en_US                                                                    
Ign http://security.ubuntu.com petra-security/multiverse Translation-en                                                                       
Ign http://security.ubuntu.com petra-security/restricted Translation-en_US                                                                    
Ign http://security.ubuntu.com petra-security/restricted Translation-en
Ign http://security.ubuntu.com petra-security/universe Translation-en_US
Ign http://security.ubuntu.com petra-security/universe Translation-en
Err http://archive.ubuntu.com petra/main amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra/restricted amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra/universe amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra/multiverse amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra/main i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra/restricted i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra/universe i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra/multiverse i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Ign http://archive.ubuntu.com petra/main Translation-en_US
Ign http://archive.ubuntu.com petra/main Translation-en
Ign http://archive.ubuntu.com petra/multiverse Translation-en_US
Ign http://archive.ubuntu.com petra/multiverse Translation-en
Ign http://archive.ubuntu.com petra/restricted Translation-en_US
Ign http://archive.ubuntu.com petra/restricted Translation-en
Ign http://archive.ubuntu.com petra/universe Translation-en_US
Ign http://archive.ubuntu.com petra/universe Translation-en
Err http://archive.ubuntu.com petra-updates/main amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra-updates/restricted amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra-updates/universe amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra-updates/multiverse amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra-updates/main i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra-updates/restricted i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra-updates/universe i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com petra-updates/multiverse i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Ign http://archive.ubuntu.com petra-updates/main Translation-en_US
Ign http://archive.ubuntu.com petra-updates/main Translation-en
Ign http://archive.ubuntu.com petra-updates/multiverse Translation-en_US
Ign http://archive.ubuntu.com petra-updates/multiverse Translation-en
Ign http://archive.ubuntu.com petra-updates/restricted Translation-en_US
Ign http://archive.ubuntu.com petra-updates/restricted Translation-en
Ign http://archive.ubuntu.com petra-updates/universe Translation-en_US
Ign http://archive.ubuntu.com petra-updates/universe Translation-en
Fetched 209 kB in 25s (8,215 B/s)
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/petra-security/main/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/petra-security/restricted/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/petra-security/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/petra-security/multiverse/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/petra-security/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/petra-security/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/petra-security/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/petra-security/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/petra/partner/binary-amd64/Packages  404  Not Found [IP: 91.189.92.150 80]

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/petra/partner/binary-i386/Packages  404  Not Found [IP: 91.189.92.150 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra/main/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra/restricted/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra/multiverse/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra-updates/main/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra-updates/restricted/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra-updates/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra-updates/multiverse/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra-updates/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra-updates/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra-updates/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/petra-updates/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
And here is my sources.list:

Code: Select all

sudo nano /etc/apt/sources.list
# deb cdrom:[Linux Mint 16 _petra_ - Release amd64 20131216]/ saucy contrib main non-free
# deb http://archive.removed/ubuntu raring-removed apps games

deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
That seems rather sparse, I would think it would contain a bunch more lines than that?

User avatar
xenopeek
Level 24
Level 24
Posts: 24279
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Broken packages?

Post by xenopeek »

The apt-cache stats confirmed you have broken repository configuration. The apt-get update you ran shows your Ubuntu package base repositories as used by Linux Mint are somehow configured with "petra" distribution name--but that should be "saucy".

Please run this command to show all your repository configuration files and contents:

Code: Select all

inxi -r
You can probably easily spot which files to edit in /etc/apt/sources.list.d/ from that, all the repositories with "ubuntu" or "canonical" in their URL should have "petra" replaced by "saucy". If you need more help with that, please share the inxi -r output.

After changing the repository configuration run the apt-get update again and afterwards you should be able to install software again.
Image

kennerd
Level 1
Level 1
Posts: 4
Joined: Fri Jul 26, 2013 10:35 am

Re: Broken packages?

Post by kennerd »

It was a simple enough matter to edit the repositories within Synaptic, and your advice to change "petra" to "saucy" in the particular repositories with "ubuntu" or "canonical" in their URL did the trick. Thank you kindly!

User avatar
myrkat
Level 2
Level 2
Posts: 71
Joined: Sun Feb 02, 2014 7:10 pm

Re: Broken packages? <SOLVED>

Post by myrkat »

kennerd wrote:...
This is on a fresh install of Mint 16, KDE. Is it just me, or are the repositories broken?
I just installed a fresh Mint 16 KDE (x64) and got the same problem trying to install the nfs-common package...

I followed the advice of xenopeek and also saw "petra" for all the ubuntu references. So I edited all "petra" to "saucy" and got:

Code: Select all

user@machine:~ > inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/removed.list
           deb http://archive.removed/ubuntu/ saucy-removed apps
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com/ saucy main upstream import
           deb http://extra.linuxmint.com/ saucy main
           deb http://archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ saucy partner
Then I sudo apt-get update and notice many linuxmint.com/dists/saucy misses (error 404):

Code: Select all

W: Failed to fetch http://extra.linuxmint.com/dists/saucy/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://extra.linuxmint.com/dists/saucy/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://packages.linuxmint.com/dists/saucy/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://packages.linuxmint.com/dists/saucy/upstream/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://packages.linuxmint.com/dists/saucy/import/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://packages.linuxmint.com/dists/saucy/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://packages.linuxmint.com/dists/saucy/upstream/binary-i386/Packages  404  Not Found

W: Failed to fetch http://packages.linuxmint.com/dists/saucy/import/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
However, I can now sudo apt-get install nfs-common as well as scribus - which I was not able to before.

Not sure what is up with the KDE flavor of Mint 16, but this was annoying. I had no issues with the Mint 16 Xfce Petra I was running for months.

UPDATE: Karl's response in this thread set me straight regarding the linuxmint packages not being found. Once I added petra to the linuxmint, but kept ubuntu saucy, it all worked out.
Main Comp: i7-4770K @ 3.5GHz + nVidia 760GTX + 16GB RAM + SSD + HDD²
Linux Mint 17.2 - KDE 4.14.2 - kernel 3.16.0-38-generic
Join me and become a Linux Mint Community Sponsor and share some love! (for as little as USD$20 a month)

Post Reply

Return to “Software & Applications”