[SOLVED] Changing synclient settings after update to Petra

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
felixrulz
Level 1
Level 1
Posts: 2
Joined: Mon Jan 20, 2014 6:10 pm

[SOLVED] Changing synclient settings after update to Petra

Post by felixrulz »

I have just upgraded from Olivia (Mint 15) to Petra (Mint 16) using these (http://www.tecmint.com/upgrade-linux-mi ... -16-petra/) instructions. Everything seemed to work fine but now I can't use my touch pad properly.

[When I go to All Settings -> Mouse and Touchpad changing the settings has no affect.]

To (temporarily) fix the problems I changed the appropriate synclient settings. You can enter #synclient to see the current settings.

Problem 1: Could not tap to click.
Resolved by executing: #synclient tapbutton1=1

Problem 2: Two finger tap for right click
Fixed using #synclient TapButton2=3

Problem 3: Two finger scrolling
Fixed with #synclient VertTwoFingerScroll=1

Problem 4: Natural Scrolling.
I can scroll using the right side of the touch pad. I would like to disable this.
Disabled using #synclient VertEdgeScroll=0

The current scrolling is also inverted to what I am used to.
To fix this you need to change the sign of VertScrollDelta. In my case: #synclient VertScrollDelta=104

***

So now I want to make these changes permanent. I read you can do this by editing /usr/share/X11/xorg.conf.d/10-synaptics.conf and putting the changes in below Section "InputClass". When I open this file the header states:
"# DO NOT EDIT THIS FILE, your distribution will likely overwrite it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first."

So I copied the xorg.conf.d file to /etc/X11/xorg.conf.d/ (I had to create this directory) and added the following options:

Option "TapButton1" "1"
Option "TapButton2" "3"
Option "VertTwoFingerScroll" "1"
Option "VertEdgeScroll" "0"
Option "VertScrollDelta" "104"

But when I restart the changes are not saved...

Hopefully someone can help me out. Cheers.
Last edited by felixrulz on Tue Jan 21, 2014 1:10 am, edited 1 time in total.

hiroaki
Level 2
Level 2
Posts: 58
Joined: Tue Jan 14, 2014 7:24 am

Re: Changing synclient settings after update to Petra

Post by hiroaki »

Hi felixrulz

I have just answered to the same question in Linux Mint Forum Japan.
A solution is to add synclient command to Startup Applications.

Find "Startup Applications" from Menu and click "Add".
Then a window comes up.
Screenshot-Add-Startup-Program.png
Fill the fields.
Name: Any name you want. e.g. Synclient
Command:

Code: Select all

synclient TapButton1=1 TapButton2=3 VertTwoFingerScroll=1 VertEdgeScroll=0 VertScrollDelta=104
Comment: Any comment you want. e.g. Set up touch pad

Click "Add" and logout, login. You don't have to restart.
Then it should work.
Please mark the topic as [SOLVED] when the problem is solved.
Hiroaki Ban
Linux Mint 16 Petra KDE 64bit
Three simple techniques to make terminal input easier
http://forums.linuxmint.com/viewtopic.php?f=42&t=157171

felixrulz
Level 1
Level 1
Posts: 2
Joined: Mon Jan 20, 2014 6:10 pm

Re: Changing synclient settings after update to Petra

Post by felixrulz »

Thanks *heaps* for your help. Works perfectly!
Weird how the settings in the gui don't work.

Post Reply

Return to “Software & Applications”